summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-01-06 23:37:59 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-01-06 23:37:59 +0000
commit8c3cd13f0d76b9c54cbc50fcd5a5407c72b36f93 (patch)
tree83a2f565d824260ee86a3782adc77befac748b4c /sys-libs/ss/ss-1.38.ebuild
parentupdate dodoc line #118109 by Matteo Spreafico (diff)
downloadgentoo-2-8c3cd13f0d76b9c54cbc50fcd5a5407c72b36f93.tar.gz
gentoo-2-8c3cd13f0d76b9c54cbc50fcd5a5407c72b36f93.tar.bz2
gentoo-2-8c3cd13f0d76b9c54cbc50fcd5a5407c72b36f93.zip
Replace an userland check by $CHOST check; added comment with reasons.
(Portage version: 2529-svn)
Diffstat (limited to 'sys-libs/ss/ss-1.38.ebuild')
-rw-r--r--sys-libs/ss/ss-1.38.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/sys-libs/ss/ss-1.38.ebuild b/sys-libs/ss/ss-1.38.ebuild
index f6ffeb5daf6b..b4ce6e54184a 100644
--- a/sys-libs/ss/ss-1.38.ebuild
+++ b/sys-libs/ss/ss-1.38.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/ss/ss-1.38.ebuild,v 1.16 2005/11/10 21:26:46 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/ss/ss-1.38.ebuild,v 1.17 2006/01/06 23:37:59 flameeyes Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -31,11 +31,14 @@ src_compile() {
export CC=$(tc-getCC)
export STRIP=/bin/true
+ # We want to use the "bsd" libraries while building on Darwin, but while
+ # building on other Gentoo/*BSD we prefer elf-naming scheme.
local libtype
- case ${USERLAND} in
- Darwin) libtype=bsd;;
- *) libtype=elf;;
+ case ${CHOST} in
+ *-darwin*) libtype=bsd;;
+ *) libtype=elf;;
esac
+
mkdir -p lib/{blkid,e2p,et,ext2fs,ss,uuid}/{checker,elfshared,pic,profiled} #102412
econf \
--enable-${libtype}-shlibs \