summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-01-04 18:03:29 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-01-04 18:03:29 +0000
commitb51717d3fe3247451ee0251b06577861a7780390 (patch)
treeec54257b516e929eb1f1709e5cb64b78f85c002e /sys-libs/tdb
parentBump, thanks to Jason Wallace (diff)
downloadgentoo-2-b51717d3fe3247451ee0251b06577861a7780390.tar.gz
gentoo-2-b51717d3fe3247451ee0251b06577861a7780390.tar.bz2
gentoo-2-b51717d3fe3247451ee0251b06577861a7780390.zip
Bump
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/tdb')
-rw-r--r--sys-libs/tdb/ChangeLog9
-rw-r--r--sys-libs/tdb/tdb-1.2.0.ebuild69
2 files changed, 76 insertions, 2 deletions
diff --git a/sys-libs/tdb/ChangeLog b/sys-libs/tdb/ChangeLog
index 2bc0aae368e9..9f7fc034d89c 100644
--- a/sys-libs/tdb/ChangeLog
+++ b/sys-libs/tdb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/tdb
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/tdb/ChangeLog,v 1.9 2009/12/06 16:57:49 flameeyes Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/tdb/ChangeLog,v 1.10 2010/01/04 18:03:29 patrick Exp $
+
+*tdb-1.2.0 (04 Jan 2010)
+
+ 04 Jan 2010; Patrick Lauer <patrick@gentoo.org> +tdb-1.2.0.ebuild:
+ Bump
06 Dec 2009; Diego E. Pettenò <flameeyes@gentoo.org> tdb-1.1.5-r1.ebuild:
Block older samba (to force uninstall).
diff --git a/sys-libs/tdb/tdb-1.2.0.ebuild b/sys-libs/tdb/tdb-1.2.0.ebuild
new file mode 100644
index 000000000000..4539eb74df98
--- /dev/null
+++ b/sys-libs/tdb/tdb-1.2.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/tdb/tdb-1.2.0.ebuild,v 1.1 2010/01/04 18:03:29 patrick Exp $
+
+EAPI="2"
+
+inherit confutils eutils autotools
+
+DESCRIPTION="Samba tdb"
+HOMEPAGE="http://tdb.samba.org/"
+SRC_URI="http://samba.org/ftp/tdb/${P}.tar.gz"
+LICENSE="GPL-3"
+IUSE="python tools tdbtest"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+DEPEND="!<net-fs/samba-3.3
+ !<net-fs/samba-libs-3.4
+ "
+RDEPEND="${DEPEND}"
+
+BINPROGS="bin/tdbdump bin/tdbtool bin/tdbbackup"
+
+src_prepare() {
+ eautoconf -Ilibreplace
+ sed -e 's:$(SHLD_FLAGS) :$(SHLD_FLAGS) $(LDFLAGS) :' -i Makefile.in || die "sed failed"
+}
+
+src_configure() {
+
+ econf \
+ --sysconfdir=/etc/samba \
+ --localstatedir=/var \
+ $(use_enable python) \
+ || die "econf failed"
+
+}
+
+src_compile() {
+
+ emake dirs || die "emake dirs failed"
+ emake showflags || die "emake showflags failed"
+ emake shared-build || die "emake shared-build failed"
+ if use tools ; then emake ${BINPROGS} || die "emake binaries failed"; fi
+ if use python ; then emake build-python || die "emake build-python failed"; fi
+ if use tdbtest ; then make bin/tdbtest || die "emake tdbtest failed"; fi
+
+}
+
+src_install() {
+
+ dolib.a sharedbuild/lib/libtdb.a
+ dolib.so sharedbuild/lib/libtdb.so
+
+ if use python || use tools ; then
+ emake install DESTDIR="${D}" || die "emake install failed"
+ fi
+
+ if ! use tools ; then
+ for prog in ${BINPROGS} ; do
+ rm -f "${D}/usr/${prog}"
+ done
+ fi
+
+ if use tdbtest ; then
+ dobin bin/tdbtest
+ fi
+
+}