summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-03-11 03:27:45 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-03-11 03:27:45 +0000
commit18014a31167d04387b977df26389610239a62503 (patch)
tree156d818f276ebd99f9f8d13b5d97f434a5d13a1c /sys-libs/tevent
parentAdding matplotlib dep #460584 (diff)
downloadgentoo-2-18014a31167d04387b977df26389610239a62503.tar.gz
gentoo-2-18014a31167d04387b977df26389610239a62503.tar.bz2
gentoo-2-18014a31167d04387b977df26389610239a62503.zip
Bump
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sys-libs/tevent')
-rw-r--r--sys-libs/tevent/ChangeLog7
-rw-r--r--sys-libs/tevent/tevent-0.9.18.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/sys-libs/tevent/ChangeLog b/sys-libs/tevent/ChangeLog
index 403780962b61..5f6ccedef770 100644
--- a/sys-libs/tevent/ChangeLog
+++ b/sys-libs/tevent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/tevent
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/tevent/ChangeLog,v 1.34 2013/03/06 10:27:11 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/tevent/ChangeLog,v 1.35 2013/03/11 03:27:45 patrick Exp $
+
+*tevent-0.9.18 (11 Mar 2013)
+
+ 11 Mar 2013; Patrick Lauer <patrick@gentoo.org> +tevent-0.9.18.ebuild:
+ Bump
06 Mar 2013; Agostino Sarubbo <ago@gentoo.org> tevent-0.9.17.ebuild:
Stable for sh, wrt bug #458712
diff --git a/sys-libs/tevent/tevent-0.9.18.ebuild b/sys-libs/tevent/tevent-0.9.18.ebuild
new file mode 100644
index 000000000000..35d984335677
--- /dev/null
+++ b/sys-libs/tevent/tevent-0.9.18.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/tevent/tevent-0.9.18.ebuild,v 1.1 2013/03/11 03:27:45 patrick Exp $
+
+EAPI=4
+PYTHON_DEPEND="2"
+
+inherit waf-utils python
+
+DESCRIPTION="Samba tevent library"
+HOMEPAGE="http://tevent.samba.org/"
+SRC_URI="http://samba.org/ftp/tevent/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=sys-libs/talloc-2.0.6[python]"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_install() {
+ waf-utils_src_install
+ insinto $(python_get_sitedir)
+ doins tevent.py
+}
+
+pkg_postinst() {
+ python_mod_optimize tevent.py
+}
+
+pkg_postrm() {
+ python_mod_cleanup tevent.py
+}