summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Drake <dsd@gentoo.org>2004-10-28 23:30:24 +0000
committerDaniel Drake <dsd@gentoo.org>2004-10-28 23:30:24 +0000
commit0582c1dbd2d9ea16f7d7689f939b6a8cfaa88e4a (patch)
treeda58ee31748aa958572a9e5c15f5816eb55b9621 /sys-libs
parent version bump as per bug #69261 (Manifest recommit) (diff)
downloadgentoo-2-0582c1dbd2d9ea16f7d7689f939b6a8cfaa88e4a.tar.gz
gentoo-2-0582c1dbd2d9ea16f7d7689f939b6a8cfaa88e4a.tar.bz2
gentoo-2-0582c1dbd2d9ea16f7d7689f939b6a8cfaa88e4a.zip
Add exit condition to stop people running into bug 69258
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/ChangeLog5
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20041021.ebuild15
2 files changed, 17 insertions, 3 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index 2f74e8432d56..badf087a76dd 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-libs/glibc
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.282 2004/10/28 05:48:26 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.283 2004/10/28 23:30:24 dsd Exp $
+
+ 29 Oct 2004; Daniel Drake <dsd@gentoo.org> glibc-2.3.4.20041021.ebuild:
+ Add exit condition to prevent more people running into bug 69258
27 Oct 2004; Travis Tilley <lv@gentoo.org> -glibc-2.3.4.20041006.ebuild,
glibc-2.3.4.20041021.ebuild:
diff --git a/sys-libs/glibc/glibc-2.3.4.20041021.ebuild b/sys-libs/glibc/glibc-2.3.4.20041021.ebuild
index 1327fe2128c7..acb5ae82dce1 100644
--- a/sys-libs/glibc/glibc-2.3.4.20041021.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20041021.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041021.ebuild,v 1.2 2004/10/28 05:48:26 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041021.ebuild,v 1.3 2004/10/28 23:30:24 dsd Exp $
inherit eutils flag-o-matic gcc
@@ -228,7 +228,7 @@ do_makecheck() {
ATIME=`mount | awk '{ print $3,$6 }' | grep ^\/\ | grep noatime`
if [ "$ATIME" = "" ]; then
cd ${WORKDIR}/${MYMAINBUILDDIR}
- make check || die
+ make check || die
else
ewarn "remounting / without noatime option so that make check"
ewarn "does not fail!"
@@ -277,6 +277,17 @@ setup_locales() {
pkg_setup() {
+ # We have a nasty nptl --> nptlonly migration bug
+ # http://bugs.gentoo.org/69258
+ # Lets make sure nobody else runs into it
+ if [ -e "/lib/tls/libc.so.6" ] && use nptlonly ; then
+ eerror "Migrating from \"+nptl -nptlonly\" to \"+nptl +nptlonly\""
+ eerror "causes a serious bug at this time."
+ eerror "Please use \"-nptlonly\" for now."
+ einfo "See http://bugs.gentoo.org/69258 for more info."
+ die "Can't migrate from nptl to nptlonly at this time"
+ fi
+
# give some sort of warning about the nptl logic changes...
if want_nptl && use !nptlonly ; then
ewarn "Warning! Gentoo's GLIBC with NPTL enabled now behaves like the"