summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoel Martin <kanaka@gentoo.org>2006-07-01 17:20:34 +0000
committerJoel Martin <kanaka@gentoo.org>2006-07-01 17:20:34 +0000
commit0d5436167151b0425b7c596bef5399cee260199e (patch)
tree52196f0289b0408f523f6922512b95aeb2d2ddab /sys-libs
parent1.1 version bump for bug 138734. Thanks to Taku Murakami <murakami.taku at gm... (diff)
downloadgentoo-2-0d5436167151b0425b7c596bef5399cee260199e.tar.gz
gentoo-2-0d5436167151b0425b7c596bef5399cee260199e.tar.bz2
gentoo-2-0d5436167151b0425b7c596bef5399cee260199e.zip
Compile native zic first and use that if we are cross-compiling.
(Portage version: 2.1-r1)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/timezone-data/ChangeLog5
-rw-r--r--sys-libs/timezone-data/timezone-data-2006g.ebuild10
2 files changed, 12 insertions, 3 deletions
diff --git a/sys-libs/timezone-data/ChangeLog b/sys-libs/timezone-data/ChangeLog
index 6aded9d75608..22183c417967 100644
--- a/sys-libs/timezone-data/ChangeLog
+++ b/sys-libs/timezone-data/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-libs/timezone-data
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/timezone-data/ChangeLog,v 1.33 2006/06/27 20:32:43 the_paya Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/timezone-data/ChangeLog,v 1.34 2006/07/01 17:20:34 kanaka Exp $
+
+ 01 Jul 2006; Joel Martin <kanaka@gentoo.org> timezone-data-2006g.ebuild:
+ Compile native zic first and use that if we are cross-compiling.
27 Jun 2006; Javier Villavicencio <the_paya@gentoo.org>
timezone-data-2006g.ebuild:
diff --git a/sys-libs/timezone-data/timezone-data-2006g.ebuild b/sys-libs/timezone-data/timezone-data-2006g.ebuild
index 876f643d9d05..ff1b69a63c9c 100644
--- a/sys-libs/timezone-data/timezone-data-2006g.ebuild
+++ b/sys-libs/timezone-data/timezone-data-2006g.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/timezone-data/timezone-data-2006g.ebuild,v 1.3 2006/06/27 20:32:43 the_paya Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/timezone-data/timezone-data-2006g.ebuild,v 1.4 2006/07/01 17:20:34 kanaka Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -21,6 +21,7 @@ S=${WORKDIR}
src_unpack() {
unpack ${A}
epatch "${FILESDIR}"/${PN}-2005n-makefile.patch
+ tc-is-cross-compiler && cp -pR ${S} ${S}-native
}
src_compile() {
@@ -31,7 +32,12 @@ src_compile() {
}
src_install() {
- make install DESTDIR="${D}" || die
+ local zic=""
+ if tc-is-cross-compiler; then
+ make -C ${S}-native CC=$(tc-getBUILD_CC) zic || die
+ zic="zic=${S}-native/zic"
+ fi
+ make install ${zic} DESTDIR="${D}" || die
rm -rf "${D}"/usr/share/zoneinfo-leaps
dodoc README Theory
dohtml *.htm *.jpg