summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-09-10 16:48:21 +0000
committerTravis Tilley <lv@gentoo.org>2004-09-10 16:48:21 +0000
commit0e0e3ecb0907ecbc038dc413558ddf52b44df333 (patch)
tree36312e01f754c4511e2616398faa8dc403d074ce /sys-libs
parentInitial import of myth.eclass (diff)
downloadgentoo-2-0e0e3ecb0907ecbc038dc413558ddf52b44df333.tar.gz
gentoo-2-0e0e3ecb0907ecbc038dc413558ddf52b44df333.tar.bz2
gentoo-2-0e0e3ecb0907ecbc038dc413558ddf52b44df333.zip
small patch mini-typo fix and add userlocales change to 2.3.4.20040619-r1
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/files/2.3.4/glibc-gentoo-libdir.patch4
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20040619-r1.ebuild10
2 files changed, 7 insertions, 7 deletions
diff --git a/sys-libs/glibc/files/2.3.4/glibc-gentoo-libdir.patch b/sys-libs/glibc/files/2.3.4/glibc-gentoo-libdir.patch
index 147968b3776f..01f414bb1255 100644
--- a/sys-libs/glibc/files/2.3.4/glibc-gentoo-libdir.patch
+++ b/sys-libs/glibc/files/2.3.4/glibc-gentoo-libdir.patch
@@ -10,10 +10,10 @@ diff -Nru glibc-2.3.3.old/sysdeps/unix/sysv/linux/configure glibc-2.3.3/sysdeps/
- sparc/sparc64 | x86_64 | powerpc/powerpc64 | s390/s390-64 | \
- mips/mips64/n64/* )
- libc_cv_slibdir="/lib64"
-+ libc_cv_slibdir="/@GENTOO_LIBDIR@/"
++ libc_cv_slibdir="/@GENTOO_LIBDIR@"
if test "$libdir" = '${exec_prefix}/lib'; then
- libdir='${exec_prefix}/lib64';
-+ libdir='${exec_prefix}/@GENTOO_LIBDIR@/'
++ libdir='${exec_prefix}/@GENTOO_LIBDIR@'
# Locale data can be shared between 32bit and 64bit libraries
libc_cv_localedir='${exec_prefix}/lib/locale'
fi
diff --git a/sys-libs/glibc/glibc-2.3.4.20040619-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20040619-r1.ebuild
index 4c4f6f374d6c..910941e49f4c 100644
--- a/sys-libs/glibc/glibc-2.3.4.20040619-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20040619-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040619-r1.ebuild,v 1.15 2004/09/06 05:25:49 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040619-r1.ebuild,v 1.16 2004/09/10 16:48:21 lv Exp $
inherit eutils flag-o-matic gcc
@@ -45,7 +45,7 @@ fi
LICENSE="LGPL-2"
SLOT="2.2"
KEYWORDS="-* ~x86 mips amd64 ~hppa ~ppc ~ia64"
-IUSE="nls pic build nptl erandom hardened makecheck multilib debug"
+IUSE="userlocales pic build nptl erandom hardened makecheck multilib debug"
RESTRICT="nostrip" # we'll handle stripping ourself #46186
# We need new cleanup attribute support from gcc for NPTL among things ...
@@ -249,9 +249,9 @@ install_locales() {
setup_locales() {
- if use nls || use makecheck; then
- einfo "nls or makecheck in USE, installing -ALL- locales..."
- install_locales
+ if use !userlocales || use makecheck; then
+ einfo "makecheck in USE or userlocales not enabled, installing -ALL- locales..."
+ install_locales || die
elif [ -e /etc/locales.build ]; then
einfo "Installing locales in /etc/locales.build..."
echo 'SUPPORTED-LOCALES=\' > SUPPORTED.locales