summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-06-19 17:03:28 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-06-19 17:03:28 +0000
commit15739e88906d09e87683654e4a27cfc17d78050a (patch)
tree83b93078f91b2ddbc7a976a6c8fa617890c0a898 /sys-libs
parentAdd blockers against alsa-firmware[alsa_cards_ca0132], bug #473784. (diff)
downloadgentoo-2-15739e88906d09e87683654e4a27cfc17d78050a.tar.gz
gentoo-2-15739e88906d09e87683654e4a27cfc17d78050a.tar.bz2
gentoo-2-15739e88906d09e87683654e4a27cfc17d78050a.zip
Revision bump: EAPI 5, utilize autotools-utils eclass, add compatibility with automake 1.13, wrt bug #471950
(Portage version: 2.2.0_alpha181/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libmath++/ChangeLog10
-rw-r--r--sys-libs/libmath++/libmath++-0.0.4-r1.ebuild49
2 files changed, 57 insertions, 2 deletions
diff --git a/sys-libs/libmath++/ChangeLog b/sys-libs/libmath++/ChangeLog
index a8e50bc2a5f4..2ddb98a8c6e3 100644
--- a/sys-libs/libmath++/ChangeLog
+++ b/sys-libs/libmath++/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/libmath++
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libmath++/ChangeLog,v 1.13 2008/04/20 21:51:02 flameeyes Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libmath++/ChangeLog,v 1.14 2013/06/19 17:03:28 pinkbyte Exp $
+
+*libmath++-0.0.4-r1 (19 Jun 2013)
+
+ 19 Jun 2013; Sergey Popov <pinkbyte@gentoo.org> +libmath++-0.0.4-r1.ebuild:
+ Revision bump: EAPI 5, utilize autotools-utils eclass, add compatibility with
+ automake 1.13, wrt bug #471950
20 Apr 2008; Diego Pettenò <flameeyes@gentoo.org> libmath++-0.0.4.ebuild:
Run eautoreconf in src_unpack phase, bug #207479.
diff --git a/sys-libs/libmath++/libmath++-0.0.4-r1.ebuild b/sys-libs/libmath++/libmath++-0.0.4-r1.ebuild
new file mode 100644
index 000000000000..8c288456c7da
--- /dev/null
+++ b/sys-libs/libmath++/libmath++-0.0.4-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libmath++/libmath++-0.0.4-r1.ebuild,v 1.1 2013/06/19 17:03:28 pinkbyte Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils
+
+DESCRIPTION="template based math library, written in C++, for symbolic and numeric calculus applications"
+HOMEPAGE="http://rm-rf.in/libmath%2B%2B/"
+SRC_URI="http://upstream.rm-rf.in/libmath%2B%2B/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~amd64 ~ppc ~s390 ~x86"
+IUSE="doc static-libs"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+DOCS=( AUTHORS README TODO )
+
+src_prepare() {
+ # Autotools 1.13 compatibility, bug #471950
+ sed -i -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' configure.in || die 'sed on configure.in failed'
+
+ autotools-utils_src_prepare
+}
+
+src_compile() {
+ autotools-utils_src_compile
+
+ if use doc; then
+ pushd "${AUTOTOOLS_BUILD_DIR}" >/dev/null
+ emake -C doc api-doc
+ popd >/dev/null
+ fi
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if use doc; then
+ pushd "${AUTOTOOLS_BUILD_DIR}" >/dev/null
+ dohtml -r doc/user-api/*
+ popd >/dev/null
+ fi
+}