summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-07-26 00:48:53 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-07-26 00:48:53 +0000
commit2afe40acdc1d3bd98a034c4a5370cf3351efc2c6 (patch)
treeb5665b73735670c441e7d0e1525b0a4759c2eda8 /sys-libs
parentVersion bump. (diff)
downloadgentoo-2-2afe40acdc1d3bd98a034c4a5370cf3351efc2c6.tar.gz
gentoo-2-2afe40acdc1d3bd98a034c4a5370cf3351efc2c6.tar.bz2
gentoo-2-2afe40acdc1d3bd98a034c4a5370cf3351efc2c6.zip
bump a new snapshot with multilib support.
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libcxxrt/ChangeLog8
-rw-r--r--sys-libs/libcxxrt/libcxxrt-0.0_p20130725.ebuild71
2 files changed, 78 insertions, 1 deletions
diff --git a/sys-libs/libcxxrt/ChangeLog b/sys-libs/libcxxrt/ChangeLog
index 13b49d847870..0c8a8ef0e948 100644
--- a/sys-libs/libcxxrt/ChangeLog
+++ b/sys-libs/libcxxrt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/libcxxrt
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxxrt/ChangeLog,v 1.14 2013/07/03 21:30:05 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxxrt/ChangeLog,v 1.15 2013/07/26 00:48:53 aballier Exp $
+
+*libcxxrt-0.0_p20130725 (26 Jul 2013)
+
+ 26 Jul 2013; Alexis Ballier <aballier@gentoo.org>
+ +libcxxrt-0.0_p20130725.ebuild:
+ bump a new snapshot with multilib support.
03 Jul 2013; Alexis Ballier <aballier@gentoo.org> libcxxrt-9999.ebuild:
Go multilib, based on a patch by Yuta SATOH in bug #475294
diff --git a/sys-libs/libcxxrt/libcxxrt-0.0_p20130725.ebuild b/sys-libs/libcxxrt/libcxxrt-0.0_p20130725.ebuild
new file mode 100644
index 000000000000..db1b4110af00
--- /dev/null
+++ b/sys-libs/libcxxrt/libcxxrt-0.0_p20130725.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxxrt/libcxxrt-0.0_p20130725.ebuild,v 1.1 2013/07/26 00:48:53 aballier Exp $
+
+EAPI=5
+
+EGIT_REPO_URI="git://github.com/pathscale/libcxxrt.git"
+
+[ "${PV%9999}" != "${PV}" ] && SCM="git-2" || SCM=""
+
+inherit flag-o-matic toolchain-funcs portability ${SCM} multilib-minimal
+
+DESCRIPTION="C++ Runtime from PathScale, FreeBSD and NetBSD."
+HOMEPAGE="https://github.com/pathscale/libcxxrt http://www.pathscale.com/node/265"
+if [ "${PV%9999}" = "${PV}" ] ; then
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+ DEPEND="app-arch/xz-utils"
+else
+ SRC_URI=""
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+if [ "${PV%9999}" = "${PV}" ] ; then
+ KEYWORDS="~amd64 ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+else
+ KEYWORDS=""
+fi
+IUSE="libunwind static-libs"
+
+RDEPEND="libunwind? ( >=sys-libs/libunwind-1.0.1-r1[static-libs?] )"
+DEPEND="${RDEPEND}
+ ${DEPEND}"
+
+DOCS=( AUTHORS COPYRIGHT README )
+
+src_prepare() {
+ cp "${FILESDIR}/Makefile" src/ || die
+ cp "${FILESDIR}/Makefile.test" test/Makefile || die
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ # Notes: we build -nodefaultlibs to avoid linking to gcc libs.
+ # libcxxrt needs: dladdr (dlopen_lib), libunwind or libgcc_s and the libc.
+ tc-export CC CXX AR
+ append-ldflags "-Wl,-z,defs" # make sure we are not underlinked
+ cd "${BUILD_DIR}/src"
+ LIBS="$(dlopen_lib) -l$(usex libunwind unwind gcc_s) -lc" emake shared
+ use static-libs && emake static
+}
+
+multilib_src_test() {
+ cd "${BUILD_DIR}/test"
+ LD_32_LIBRARY_PATH="${BUILD_DIR}/src:${LD_32_LIBRARY_PATH}" \
+ LD_LIBRARY_PATH="${BUILD_DIR}/src:${LD_LIBRARY_PATH}" \
+ LIBS="-L${BUILD_DIR}/src -lcxxrt -lc" \
+ emake check
+}
+
+multilib_src_install() {
+ # TODO: See README. Maybe hide it in a subdir and let only libcxx know about
+ # it. FreeBSD head installs it in /lib
+ dolib.so src/${PN}.so*
+ use static-libs && dolib.a src/${PN}.a
+}
+
+multilib_src_install_all() {
+ insinto /usr/include/libcxxrt/
+ doins src/cxxabi.h src/unwind*.h
+}