summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-03-21 16:42:19 +0000
committerAnthony G. Basile <blueness@gentoo.org>2015-03-21 16:42:19 +0000
commit3738f19479380059762765df1e4c9c98b4827d80 (patch)
tree5fb2d869f65ff542c0fe66b4e3196e076c56e5e4 /sys-libs
parentuse dobin instead of exeinto /usr/bin/ && doexe; drop old (diff)
downloadgentoo-2-3738f19479380059762765df1e4c9c98b4827d80.tar.gz
gentoo-2-3738f19479380059762765df1e4c9c98b4827d80.tar.bz2
gentoo-2-3738f19479380059762765df1e4c9c98b4827d80.zip
Version bump. Add sym link for ldd.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/musl/ChangeLog7
-rw-r--r--sys-libs/musl/musl-1.1.7.ebuild103
2 files changed, 109 insertions, 1 deletions
diff --git a/sys-libs/musl/ChangeLog b/sys-libs/musl/ChangeLog
index 5f185d285f4b..e6fa5ae5dd11 100644
--- a/sys-libs/musl/ChangeLog
+++ b/sys-libs/musl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/musl
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/musl/ChangeLog,v 1.43 2015/03/07 21:08:24 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/musl/ChangeLog,v 1.44 2015/03/21 16:42:19 blueness Exp $
+
+*musl-1.1.7 (21 Mar 2015)
+
+ 21 Mar 2015; Anthony G. Basile <blueness@gentoo.org> +musl-1.1.7.ebuild:
+ Version bump. Add sym link for ldd.
07 Mar 2015; Anthony G. Basile <blueness@gentoo.org> musl-9999.ebuild:
Provide a sym link to ld.so for ldd. Bug #542026.
diff --git a/sys-libs/musl/musl-1.1.7.ebuild b/sys-libs/musl/musl-1.1.7.ebuild
new file mode 100644
index 000000000000..cbfa7dc37229
--- /dev/null
+++ b/sys-libs/musl/musl-1.1.7.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/musl/musl-1.1.7.ebuild,v 1.1 2015/03/21 16:42:19 blueness Exp $
+
+EAPI=5
+
+inherit eutils flag-o-matic multilib toolchain-funcs
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.musl-libc.org/musl"
+ inherit git-2
+fi
+
+export CBUILD=${CBUILD:-${CHOST}}
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY} == cross-* ]] ; then
+ export CTARGET=${CATEGORY#cross-}
+ fi
+fi
+
+DESCRIPTION="Lightweight, fast and simple C library focused on standards-conformance and safety"
+HOMEPAGE="http://www.musl-libc.org/"
+if [[ ${PV} != "9999" ]] ; then
+ PATCH_VER=""
+ SRC_URI="http://www.musl-libc.org/releases/${P}.tar.gz"
+ KEYWORDS="-* ~amd64 ~arm ~mips ~ppc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="crosscompile_opts_headers-only"
+
+if [[ ${CATEGORY} != cross-* ]] ; then
+ RDEPEND+=" sys-apps/getent"
+fi
+
+is_crosscompile() {
+ [[ ${CHOST} != ${CTARGET} ]]
+}
+
+just_headers() {
+ use crosscompile_opts_headers-only && is_crosscompile
+}
+
+pkg_setup() {
+ if [ ${CTARGET} == ${CHOST} ] ; then
+ case ${CHOST} in
+ *-musl*) ;;
+ *) die "Use sys-devel/crossdev to build a musl toolchain" ;;
+ esac
+ fi
+
+ epatch_user
+}
+
+src_configure() {
+ tc-getCC ${CTARGET}
+ just_headers && export CC=true
+
+ ./configure \
+ --target="${CTARGET}" \
+ --prefix="/usr" \
+ --disable-gcc-wrapper
+}
+
+src_compile() {
+ emake include/bits/alltypes.h || die
+ just_headers && return 0
+
+ emake || die
+}
+
+src_install() {
+ local sysroot=${D}
+ is_crosscompile && sysroot+="/usr/${CTARGET}"
+
+ local target="install"
+ just_headers && target="install-headers"
+ emake DESTDIR="${sysroot}" ${target} || die
+
+ # Make sure we install the sys-include symlink so that when
+ # we build a 2nd stage cross-compiler, gcc finds the target
+ # system headers correctly. See gcc/doc/gccinstall.info
+ if is_crosscompile ; then
+ dosym usr/include /usr/${CTARGET}/sys-include
+ fi
+
+ # musl provides ldd via a sym link to its ld.so
+ local ldso=$(basename ${D}/lib/ld-musl-*)
+ dosym /lib/${ldso} /usr/bin/ldd
+}
+
+pkg_postinst() {
+ is_crosscompile && return 0
+
+ [ "${ROOT}" != "/" ] && return 0
+
+ # TODO: musl doesn't use ldconfig, instead here we can
+ # create sym links to libraries outside of /lib and /usr/lib
+ ldconfig
+ # reload init ...
+ /sbin/telinit U 2>/dev/null
+}