summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2009-03-21 12:23:59 +0000
committerCaleb Tennis <caleb@gentoo.org>2009-03-21 12:23:59 +0000
commit470684a655f42af9d5d090a3328cdace1fc29476 (patch)
tree373d98f16851eceec6b9dd71189e46c26b0b4f21 /sys-libs
parentVersion bump. (diff)
downloadgentoo-2-470684a655f42af9d5d090a3328cdace1fc29476.tar.gz
gentoo-2-470684a655f42af9d5d090a3328cdace1fc29476.tar.bz2
gentoo-2-470684a655f42af9d5d090a3328cdace1fc29476.zip
Bumping db 4.6 and 4.7 per 259039
(Portage version: 2.1.6.7/cvs/Linux i686)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/db/ChangeLog9
-rw-r--r--sys-libs/db/db-4.6.21_p4.ebuild165
-rw-r--r--sys-libs/db/db-4.7.25_p3.ebuild146
3 files changed, 319 insertions, 1 deletions
diff --git a/sys-libs/db/ChangeLog b/sys-libs/db/ChangeLog
index 37b9daf85b25..7711a58a6145 100644
--- a/sys-libs/db/ChangeLog
+++ b/sys-libs/db/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-libs/db
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.276 2009/03/14 12:54:49 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.277 2009/03/21 12:23:59 caleb Exp $
+
+*db-4.7.25_p3 (21 Mar 2009)
+*db-4.6.21_p4 (21 Mar 2009)
+
+ 21 Mar 2009; Caleb Tennis <caleb@gentoo.org> +db-4.6.21_p4.ebuild,
+ +db-4.7.25_p3.ebuild:
+ Bumping db 4.6 and 4.7 per 259039
14 Mar 2009; Mike Frysinger <vapier@gentoo.org> db-4.2.52_p4-r2.ebuild,
db-4.2.52_p5.ebuild, db-4.2.52_p5-r1.ebuild, db-4.3.29-r2.ebuild,
diff --git a/sys-libs/db/db-4.6.21_p4.ebuild b/sys-libs/db/db-4.6.21_p4.ebuild
new file mode 100644
index 000000000000..673ef41a0f72
--- /dev/null
+++ b/sys-libs/db/db-4.6.21_p4.ebuild
@@ -0,0 +1,165 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.6.21_p4.ebuild,v 1.1 2009/03/21 12:23:59 caleb Exp $
+
+inherit eutils db flag-o-matic java-pkg-opt-2 autotools libtool
+
+#Number of official patches
+#PATCHNO=`echo ${PV}|sed -e "s,\(.*_p\)\([0-9]*\),\2,"`
+PATCHNO=${PV/*.*.*_p}
+if [[ ${PATCHNO} == "${PV}" ]] ; then
+ MY_PV=${PV}
+ MY_P=${P}
+ PATCHNO=0
+else
+ MY_PV=${PV/_p${PATCHNO}}
+ MY_P=${PN}-${MY_PV}
+fi
+
+S="${WORKDIR}/${MY_P}/build_unix"
+DESCRIPTION="Oracle Berkeley DB"
+HOMEPAGE="http://www.oracle.com/technology/software/products/berkeley-db/index.html"
+SRC_URI="http://download.oracle.com/berkeley-db/${MY_P}.tar.gz"
+for (( i=1 ; i<=${PATCHNO} ; i++ )) ; do
+ export SRC_URI="${SRC_URI} http://www.oracle.com/technology/products/berkeley-db/db/update/${MY_PV}/patch.${MY_PV}.${i}"
+done
+
+LICENSE="OracleDB"
+SLOT="4.6"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="tcl java doc nocxx"
+
+DEPEND="tcl? ( >=dev-lang/tcl-8.4 )
+ java? ( >=virtual/jdk-1.4 )
+ >=sys-devel/binutils-2.16.1"
+RDEPEND="tcl? ( dev-lang/tcl )
+ java? ( >=virtual/jre-1.4 )"
+
+src_unpack() {
+ unpack "${MY_P}".tar.gz
+ cd "${WORKDIR}"/"${MY_P}"
+ for (( i=1 ; i<=${PATCHNO} ; i++ ))
+ do
+ epatch "${DISTDIR}"/patch."${MY_PV}"."${i}"
+ done
+ epatch "${FILESDIR}"/"${PN}"-"${SLOT}"-libtool.patch
+
+ # use the includes from the prefix
+ epatch "${FILESDIR}"/"${PN}"-"${SLOT}"-jni-check-prefix-first.patch
+ epatch "${FILESDIR}"/"${PN}"-4.3-listen-to-java-options.patch
+
+ # Include the SLOT for Java JAR files
+ # This supersedes the unused jarlocation patches.
+ sed -r -i \
+ -e '/jarfile=.*\.jar$/s,(.jar$),-$(LIBVERSION)\1,g' \
+ "${S}"/../dist/Makefile.in
+
+ cd "${S}"/../dist
+ rm -f aclocal/libtool.m4
+ sed -i \
+ -e '/AC_PROG_LIBTOOL$/aLT_OUTPUT' \
+ configure.ac
+ sed -i \
+ -e '/^AC_PATH_TOOL/s/ sh, none/ bash, none/' \
+ aclocal/programs.m4
+ AT_M4DIR="aclocal aclocal_java" eautoreconf
+ # Upstream sucks - they do autoconf and THEN replace the version variables.
+ . ./RELEASE
+ sed -i \
+ -e "s/__EDIT_DB_VERSION_MAJOR__/$DB_VERSION_MAJOR/g" \
+ -e "s/__EDIT_DB_VERSION_MINOR__/$DB_VERSION_MINOR/g" \
+ -e "s/__EDIT_DB_VERSION_PATCH__/$DB_VERSION_PATCH/g" \
+ -e "s/__EDIT_DB_VERSION_STRING__/$DB_VERSION_STRING/g" \
+ -e "s/__EDIT_DB_VERSION_UNIQUE_NAME__/$DB_VERSION_UNIQUE_NAME/g" \
+ -e "s/__EDIT_DB_VERSION__/$DB_VERSION/g" configure
+}
+
+src_compile() {
+ # compilation with -O0 fails on amd64, see bug #171231
+ if use amd64; then
+ replace-flags -O0 -O2
+ is-flagq -O[s123] || append-flags -O2
+ fi
+
+ local myconf=""
+
+ use amd64 && myconf="${myconf} --with-mutex=x86/gcc-assembly"
+
+ myconf="${myconf} $(use_enable !nocxx cxx)"
+
+ use tcl \
+ && myconf="${myconf} --enable-tcl --with-tcl=/usr/$(get_libdir)" \
+ || myconf="${myconf} --disable-tcl"
+
+ myconf="${myconf} $(use_enable java)"
+ if use java; then
+ myconf="${myconf} --with-java-prefix=${JAVA_HOME}"
+ # Can't get this working any other way, since it returns spaces, and
+ # bash doesn't seem to want to pass correctly in any way i try
+ local javaconf="-with-javac-flags=$(java-pkg_javac-args)"
+ fi
+
+ [[ -n ${CBUILD} ]] && myconf="${myconf} --build=${CBUILD}"
+
+ # the entire testsuite needs the TCL functionality
+ if use tcl && has test $FEATURES ; then
+ myconf="${myconf} --enable-test"
+ else
+ myconf="${myconf} --disable-test"
+ fi
+
+ # Add linker versions to the symbols. Easier to do, and safer than header file
+ # mumbo jumbo.
+ if use userland_GNU; then
+ append-ldflags -Wl,--default-symver
+ fi
+
+ cd "${S}" && ECONF_SOURCE="${S}"/../dist econf \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --datadir=/usr/share \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --libdir=/usr/"$(get_libdir)" \
+ --enable-compat185 \
+ --enable-o_direct \
+ --without-uniquename \
+ --enable-rpc \
+ --host="${CHOST}" \
+ ${myconf} "${javaconf}" || die "configure failed"
+
+ sed -e "s,\(^STRIP *=\).*,\1\"none\"," Makefile > Makefile.cpy \
+ && mv Makefile.cpy Makefile
+
+ emake || die "make failed"
+}
+
+src_install() {
+ einstall libdir="${D}/usr/$(get_libdir)" STRIP="none" || die
+
+ db_src_install_usrbinslot
+
+ db_src_install_headerslot
+
+ db_src_install_doc
+
+ db_src_install_usrlibcleanup
+
+ dodir /usr/sbin
+ mv "${D}"/usr/bin/berkeley_db_svc "${D}"/usr/sbin/berkeley_db"${SLOT/./}"_svc
+
+ if use java; then
+ java-pkg_regso "${D}"/usr/"$(get_libdir)"/libdb_java*.so
+ java-pkg_dojar "${D}"/usr/"$(get_libdir)"/*.jar
+ rm -f "${D}"/usr/"$(get_libdir)"/*.jar
+ fi
+}
+
+pkg_postinst() {
+ db_fix_so
+}
+
+pkg_postrm() {
+ db_fix_so
+}
diff --git a/sys-libs/db/db-4.7.25_p3.ebuild b/sys-libs/db/db-4.7.25_p3.ebuild
new file mode 100644
index 000000000000..86fdc4f82011
--- /dev/null
+++ b/sys-libs/db/db-4.7.25_p3.ebuild
@@ -0,0 +1,146 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.7.25_p3.ebuild,v 1.1 2009/03/21 12:23:59 caleb Exp $
+
+inherit eutils db flag-o-matic java-pkg-opt-2 autotools libtool
+
+#Number of official patches
+#PATCHNO=`echo ${PV}|sed -e "s,\(.*_p\)\([0-9]*\),\2,"`
+PATCHNO=${PV/*.*.*_p}
+if [[ ${PATCHNO} == "${PV}" ]] ; then
+ MY_PV=${PV}
+ MY_P=${P}
+ PATCHNO=0
+else
+ MY_PV=${PV/_p${PATCHNO}}
+ MY_P=${PN}-${MY_PV}
+fi
+
+S="${WORKDIR}/${MY_P}/build_unix"
+DESCRIPTION="Oracle Berkeley DB"
+HOMEPAGE="http://www.oracle.com/technology/software/products/berkeley-db/index.html"
+SRC_URI="http://download.oracle.com/berkeley-db/${MY_P}.tar.gz"
+for (( i=1 ; i<=${PATCHNO} ; i++ )) ; do
+ export SRC_URI="${SRC_URI} http://www.oracle.com/technology/products/berkeley-db/db/update/${MY_PV}/patch.${MY_PV}.${i}"
+done
+
+LICENSE="OracleDB"
+SLOT="4.7"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="doc java nocxx tcl test"
+
+# the entire testsuite needs the TCL functionality
+DEPEND="tcl? ( >=dev-lang/tcl-8.4 )
+ test? ( >=dev-lang/tcl-8.4 )
+ java? ( >=virtual/jdk-1.5 )
+ >=sys-devel/binutils-2.16.1"
+RDEPEND="tcl? ( dev-lang/tcl )
+ java? ( >=virtual/jre-1.5 )"
+
+src_unpack() {
+ unpack "${MY_P}".tar.gz
+ cd "${WORKDIR}"/"${MY_P}"
+ for (( i=1 ; i<=${PATCHNO} ; i++ ))
+ do
+ epatch "${DISTDIR}"/patch."${MY_PV}"."${i}"
+ done
+ epatch "${FILESDIR}"/"${PN}"-4.6-libtool.patch
+
+ # use the includes from the prefix
+ epatch "${FILESDIR}"/"${PN}"-4.6-jni-check-prefix-first.patch
+ epatch "${FILESDIR}"/"${PN}"-4.3-listen-to-java-options.patch
+
+ # Include the SLOT for Java JAR files
+ # This supersedes the unused jarlocation patches.
+ sed -r -i \
+ -e '/jarfile=.*\.jar$/s,(.jar$),-$(LIBVERSION)\1,g' \
+ "${S}"/../dist/Makefile.in
+
+ cd "${S}"/../dist
+ rm -f aclocal/libtool.m4
+ sed -i \
+ -e '/AC_PROG_LIBTOOL$/aLT_OUTPUT' \
+ configure.ac
+ sed -i \
+ -e '/^AC_PATH_TOOL/s/ sh, none/ bash, none/' \
+ aclocal/programs.m4
+ AT_M4DIR="aclocal aclocal_java" eautoreconf
+ # Upstream sucks - they do autoconf and THEN replace the version variables.
+ . ./RELEASE
+ sed -i \
+ -e "s/__EDIT_DB_VERSION_MAJOR__/$DB_VERSION_MAJOR/g" \
+ -e "s/__EDIT_DB_VERSION_MINOR__/$DB_VERSION_MINOR/g" \
+ -e "s/__EDIT_DB_VERSION_PATCH__/$DB_VERSION_PATCH/g" \
+ -e "s/__EDIT_DB_VERSION_STRING__/$DB_VERSION_STRING/g" \
+ -e "s/__EDIT_DB_VERSION_UNIQUE_NAME__/$DB_VERSION_UNIQUE_NAME/g" \
+ -e "s/__EDIT_DB_VERSION__/$DB_VERSION/g" configure
+}
+
+src_compile() {
+ # compilation with -O0 fails on amd64, see bug #171231
+ if use amd64; then
+ replace-flags -O0 -O2
+ is-flagq -O[s123] || append-flags -O2
+ fi
+
+ # use `set` here since the java opts will contain whitespace
+ set --
+ if use java ; then
+ set -- "$@" \
+ --with-java-prefix="${JAVA_HOME}" \
+ --with-javac-flags="$(java-pkg_javac-args)"
+ fi
+
+ # Add linker versions to the symbols. Easier to do, and safer than header file
+ # mumbo jumbo.
+ if use userland_GNU ; then
+ append-ldflags -Wl,--default-symver
+ fi
+
+ cd "${S}"
+ ECONF_SOURCE="${S}"/../dist \
+ STRIP="true" \
+ econf \
+ --enable-compat185 \
+ --enable-o_direct \
+ --without-uniquename \
+ --enable-rpc \
+ $(use amd64 && echo --with-mutex=x86/gcc-assembly) \
+ $(use_enable !nocxx cxx) \
+ $(use_enable java) \
+ $(use_enable tcl) \
+ $(use tcl && echo --with-tcl=/usr/$(get_libdir)) \
+ $(use_enable test) \
+ "$@"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ db_src_install_usrbinslot
+
+ db_src_install_headerslot
+
+ db_src_install_doc
+
+ db_src_install_usrlibcleanup
+
+ dodir /usr/sbin
+ mv "${D}"/usr/bin/berkeley_db_svc "${D}"/usr/sbin/berkeley_db"${SLOT/./}"_svc
+
+ if use java; then
+ java-pkg_regso "${D}"/usr/"$(get_libdir)"/libdb_java*.so
+ java-pkg_dojar "${D}"/usr/"$(get_libdir)"/*.jar
+ rm -f "${D}"/usr/"$(get_libdir)"/*.jar
+ fi
+}
+
+pkg_postinst() {
+ db_fix_so
+}
+
+pkg_postrm() {
+ db_fix_so
+}