summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2005-04-23 20:17:52 +0000
committerMartin Schlemmer <azarah@gentoo.org>2005-04-23 20:17:52 +0000
commit4b6359084789392a75de704f18c34b3b70c6f26f (patch)
tree1de33e2d1922f893443103cad2f65b67abe38315 /sys-libs
parentAdded to ~amd64. (diff)
downloadgentoo-2-4b6359084789392a75de704f18c34b3b70c6f26f.tar.gz
gentoo-2-4b6359084789392a75de704f18c34b3b70c6f26f.tar.bz2
gentoo-2-4b6359084789392a75de704f18c34b3b70c6f26f.zip
Small fixor in unpack order.
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-2.3.5.20050421.ebuild17
1 files changed, 12 insertions, 5 deletions
diff --git a/sys-libs/glibc/glibc-2.3.5.20050421.ebuild b/sys-libs/glibc/glibc-2.3.5.20050421.ebuild
index 67d74752d67c..981acabee159 100644
--- a/sys-libs/glibc/glibc-2.3.5.20050421.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5.20050421.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5.20050421.ebuild,v 1.1 2005/04/23 17:44:31 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5.20050421.ebuild,v 1.2 2005/04/23 20:17:52 azarah Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -192,10 +192,11 @@ toolchain-glibc_src_unpack() {
unpack ${PN}-manpages-${GLIBC_MANPAGE_VERSION:-${GLIBC_RELEASE_VER}}.tar.bz2
fi
- if [[ ${GLIBC_INFOPAGE_VERSION} != "none" ]] ; then
- cd ${S}
- unpack ${PN}-infopages-${GLIBC_INFOPAGE_VERSION:-${GLIBC_RELEASE_VER}}.tar.bz2
- fi
+# FIXME: I updated the infopages, but forgot to regen th branch-update
+# if [[ ${GLIBC_INFOPAGE_VERSION} != "none" ]] ; then
+# cd ${S}
+# unpack ${PN}-infopages-${GLIBC_INFOPAGE_VERSION:-${GLIBC_RELEASE_VER}}.tar.bz2
+# fi
if [[ -n ${BRANCH_UPDATE} ]] ; then
cd ${WORKDIR}
@@ -212,6 +213,12 @@ toolchain-glibc_src_unpack() {
sed -i -e "s:\(#define RELEASE\).*:\1 \"${BRANCH_UPDATE}\":" version.h
fi
+# FIXME: I updated the infopages, but forgot to regen th branch-update
+ if [[ ${GLIBC_INFOPAGE_VERSION} != "none" ]] ; then
+ cd ${S}
+ unpack ${PN}-infopages-${GLIBC_INFOPAGE_VERSION:-${GLIBC_RELEASE_VER}}.tar.bz2
+ fi
+
if [[ -n ${PATCH_VER} ]] ; then
EPATCH_EXCLUDE="${GLIBC_PATCH_EXCLUDE}"
EPATCH_SUFFIX="patch"