summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-07-16 04:16:47 +0000
committerMike Frysinger <vapier@gentoo.org>2005-07-16 04:16:47 +0000
commit68f17505391787ed17da71bee7bdce6afb341596 (patch)
tree9f80e0aa2520e4ef82a453339403dbc699ea38d2 /sys-libs
parentAdding patches needed for mysql-5.0.9_beta (diff)
downloadgentoo-2-68f17505391787ed17da71bee7bdce6afb341596.tar.gz
gentoo-2-68f17505391787ed17da71bee7bdce6afb341596.tar.bz2
gentoo-2-68f17505391787ed17da71bee7bdce6afb341596.zip
Fix support for Darwin8. Patch by Kito #99143.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/readline/ChangeLog6
-rw-r--r--sys-libs/readline/files/readline-5.0-darwin.patch17
-rw-r--r--sys-libs/readline/readline-5.0-r2.ebuild5
3 files changed, 25 insertions, 3 deletions
diff --git a/sys-libs/readline/ChangeLog b/sys-libs/readline/ChangeLog
index 8ef5be04aebf..bb7c3dccd27f 100644
--- a/sys-libs/readline/ChangeLog
+++ b/sys-libs/readline/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/readline
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/ChangeLog,v 1.48 2005/06/27 22:15:27 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/ChangeLog,v 1.49 2005/07/16 04:16:47 vapier Exp $
+
+ 16 Jul 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/readline-5.0-darwin.patch, readline-5.0-r2.ebuild:
+ Fix support for Darwin8. Patch by Kito #99143.
27 Jun 2005; Aron Griffis <agriffis@gentoo.org>
+files/readline-5.0-parallel.patch, readline-5.0-r2.ebuild:
diff --git a/sys-libs/readline/files/readline-5.0-darwin.patch b/sys-libs/readline/files/readline-5.0-darwin.patch
new file mode 100644
index 000000000000..b8bcb9ccea3f
--- /dev/null
+++ b/sys-libs/readline/files/readline-5.0-darwin.patch
@@ -0,0 +1,17 @@
+Support Darwin8 properly.
+
+Patch by Kito.
+
+http://bugs.gentoo.org/99143
+
+--- support/shobj-conf
++++ support/shobj-conf
+@@ -146,7 +146,7 @@
+ SHLIB_LIBSUFF='dylib'
+
+ case "${host_os}" in
+- darwin7*) SHOBJ_LDFLAGS=''
++ darwin[78]*) SHOBJ_LDFLAGS=''
+ SHLIB_XLDFLAGS='-dynamiclib -arch_only `/usr/bin/arch` -install_name $(libdir)/$@ -current_version $(SHLIB_MAJOR)$(SHLIB_MINOR) -compatibility_version $(SHLIB_MAJOR) -v'
+ ;;
+ *) SHOBJ_LDFLAGS='-dynamic'
diff --git a/sys-libs/readline/readline-5.0-r2.ebuild b/sys-libs/readline/readline-5.0-r2.ebuild
index e23f10d19e6a..0f31b82344a3 100644
--- a/sys-libs/readline/readline-5.0-r2.ebuild
+++ b/sys-libs/readline/readline-5.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-5.0-r2.ebuild,v 1.4 2005/06/27 22:15:27 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-5.0-r2.ebuild,v 1.5 2005/07/16 04:16:47 vapier Exp $
inherit eutils gnuconfig
@@ -35,12 +35,13 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-no_rpath.patch
epatch "${FILESDIR}"/${P}-self-insert.patch
epatch "${FILESDIR}"/${P}-del-backspace-policy.patch
+ epatch "${FILESDIR}"/${P}-darwin.patch
# force ncurses linking #71420
sed -i -e 's:^SHLIB_LIBS=:SHLIB_LIBS=-lncurses:' support/shobj-conf || die "sed"
# fix building in parallel
- epatch ${FILESDIR}/readline-5.0-parallel.patch
+ epatch "${FILESDIR}"/readline-5.0-parallel.patch
}
src_compile() {