summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2008-09-01 17:29:18 +0000
committerHanno Böck <hanno@gentoo.org>2008-09-01 17:29:18 +0000
commit6c655c749031e2e6eba002645a8a2b0f775573d3 (patch)
treeba30924979a0f3b379c8dbc93a47e0a46d1e3add /sys-libs
parentversion bump, solves bug #235382. (diff)
downloadgentoo-2-6c655c749031e2e6eba002645a8a2b0f775573d3.tar.gz
gentoo-2-6c655c749031e2e6eba002645a8a2b0f775573d3.tar.bz2
gentoo-2-6c655c749031e2e6eba002645a8a2b0f775573d3.zip
gwenhywfar bump
(Portage version: 2.2_rc8/cvs/Linux 2.6.26.3 i686)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/gwenhywfar/ChangeLog7
-rw-r--r--sys-libs/gwenhywfar/gwenhywfar-3.4.1.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/sys-libs/gwenhywfar/ChangeLog b/sys-libs/gwenhywfar/ChangeLog
index a91c6dc8b8dd..4b7bc8a9518c 100644
--- a/sys-libs/gwenhywfar/ChangeLog
+++ b/sys-libs/gwenhywfar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/gwenhywfar
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/ChangeLog,v 1.58 2008/08/22 22:51:36 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/ChangeLog,v 1.59 2008/09/01 17:29:18 hanno Exp $
+
+*gwenhywfar-3.4.1 (01 Sep 2008)
+
+ 01 Sep 2008; Hanno Boeck <hanno@gentoo.org> +gwenhywfar-3.4.1.ebuild:
+ Version bump.
22 Aug 2008; Markus Meier <maekke@gentoo.org> gwenhywfar-2.6.2.ebuild:
amd64 stable, bug #233536
diff --git a/sys-libs/gwenhywfar/gwenhywfar-3.4.1.ebuild b/sys-libs/gwenhywfar/gwenhywfar-3.4.1.ebuild
new file mode 100644
index 000000000000..1b97dfd8d661
--- /dev/null
+++ b/sys-libs/gwenhywfar/gwenhywfar-3.4.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/gwenhywfar-3.4.1.ebuild,v 1.1 2008/09/01 17:29:18 hanno Exp $
+
+inherit flag-o-matic
+
+append-ldflags -Wl,--no-as-needed
+RESTRICT="test"
+
+DESCRIPTION="A multi-platform helper library for other libraries"
+HOMEPAGE="http://gwenhywfar.sourceforge.net"
+SRC_URI="http://files.hboeck.de/aq/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="debug ssl doc ncurses"
+
+RDEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )
+ sys-libs/ncurses
+ ncurses? ( sys-libs/ncurses )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_compile() {
+ econf \
+ $(use_enable ssl) \
+ $(use_enable debug) \
+ $(use_enable doc full-doc) \
+ $(use_enable ncurses gwenui) \
+ --with-docpath="/usr/share/doc/${PF}/apidoc" || die "configure failed"
+ emake || die "emake failed"
+ if use doc ; then
+ emake srcdoc || die "emake failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc README* AUTHORS ChangeLog TODO || die "dodoc failed"
+ if use doc ; then
+ make DESTDIR="${D}" install-srcdoc || die "install doc failed"
+ fi
+ find "${D}" -name '*.la' -delete
+}