summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-04-21 07:08:38 +0000
committerUlrich Müller <ulm@gentoo.org>2008-04-21 07:08:38 +0000
commit6d66c0d9a3109b6edc41074d82b90f62bfc1de34 (patch)
tree3b413e6bd261a14c74c6b72b636a6876c365c570 /sys-libs
parentVersion bump. (diff)
downloadgentoo-2-6d66c0d9a3109b6edc41074d82b90f62bfc1de34.tar.gz
gentoo-2-6d66c0d9a3109b6edc41074d82b90f62bfc1de34.tar.bz2
gentoo-2-6d66c0d9a3109b6edc41074d82b90f62bfc1de34.zip
Suppress creation of spurious /usr/share/emacs directory, fixes bug 202946.
Finally remove commented lines for Emacs support wrt bug 99533 comment 18. Add missing app-arch/lzma-utils to DEPEND. (Portage version: 2.1.5_rc5)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/gpm/ChangeLog8
-rw-r--r--sys-libs/gpm/files/gpm-1.20.3-no-emacs-dir.patch11
-rw-r--r--sys-libs/gpm/gpm-1.20.3.ebuild26
3 files changed, 28 insertions, 17 deletions
diff --git a/sys-libs/gpm/ChangeLog b/sys-libs/gpm/ChangeLog
index ef4b80011175..c80810def662 100644
--- a/sys-libs/gpm/ChangeLog
+++ b/sys-libs/gpm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/gpm
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/ChangeLog,v 1.65 2008/04/19 08:23:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/ChangeLog,v 1.66 2008/04/21 07:08:37 ulm Exp $
+
+ 21 Apr 2008; Ulrich Mueller <ulm@gentoo.org>
+ +files/gpm-1.20.3-no-emacs-dir.patch, gpm-1.20.3.ebuild:
+ Suppress creation of spurious /usr/share/emacs directory, fixes bug 202946.
+ Finally remove commented lines for Emacs support wrt bug 99533 comment 18.
+ Add missing app-arch/lzma-utils to DEPEND.
*gpm-1.20.3 (19 Apr 2008)
diff --git a/sys-libs/gpm/files/gpm-1.20.3-no-emacs-dir.patch b/sys-libs/gpm/files/gpm-1.20.3-no-emacs-dir.patch
new file mode 100644
index 000000000000..d3edf560d06c
--- /dev/null
+++ b/sys-libs/gpm/files/gpm-1.20.3-no-emacs-dir.patch
@@ -0,0 +1,11 @@
+--- gpm-1.20.3-orig/Makefile.in 2008-04-15 16:34:13.000000000 +0200
++++ gpm-1.20.3/Makefile.in 2008-04-20 23:30:30.000000000 +0200
+@@ -51,7 +51,7 @@
+
+ installdirs:
+ $(MKDIR) $(libdir) $(bindir) $(sbindir) $(includedir) $(sysconfdir); \
+- if test "x@ELISP@" != "x" ; then \
++ if test "x$(ELISP)" != "x" ; then \
+ $(MKDIR) $(lispdir) ; \
+ fi
+
diff --git a/sys-libs/gpm/gpm-1.20.3.ebuild b/sys-libs/gpm/gpm-1.20.3.ebuild
index 2ec3aeb7d623..bc9f4eafb564 100644
--- a/sys-libs/gpm/gpm-1.20.3.ebuild
+++ b/sys-libs/gpm/gpm-1.20.3.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/gpm-1.20.3.ebuild,v 1.2 2008/04/21 00:33:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/gpm-1.20.3.ebuild,v 1.3 2008/04/21 07:08:37 ulm Exp $
# emacs support disabled due to Bug 99533
inherit toolchain-funcs
-#elisp-common
DESCRIPTION="Console-based mouse driver"
HOMEPAGE="http://linux.schottelius.org/gpm/"
@@ -14,12 +13,18 @@ SRC_URI="http://linux.schottelius.org/gpm/archives/${P}.tar.lzma"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="selinux" # emacs"
+IUSE="selinux"
-DEPEND="sys-libs/ncurses"
-# emacs? ( virtual/emacs )"
+DEPEND="sys-libs/ncurses
+ app-arch/lzma-utils"
RDEPEND="selinux? ( sec-policy/selinux-gpm )"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-no-emacs-dir.patch
+}
+
src_compile() {
econf \
--libdir=/$(get_libdir) \
@@ -32,12 +37,6 @@ src_compile() {
emake -j1 -C doc || die
emake EMACS=: || die "emake failed"
-
-# local lisp="emacs/t-mouse.el emacs/t-mouse.elc"
-# if use emacs ; then
-# cd "${S}"/contrib ; make clean
-# make EMACS=emacs ELISP="${lisp}" || die
-# fi
}
src_install() {
@@ -49,11 +48,6 @@ src_install() {
mv "${D}"/$(get_libdir)/libgpm.a "${D}"/usr/$(get_libdir)/ || die
gen_usr_ldscript libgpm.so
-# if use emacs ; then
-# cd "${S}"/contrib/emacs
-# elisp-install . t-mouse*
-# fi
-
insinto /etc/gpm
doins conf/gpm-*.conf