summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2011-05-29 10:10:23 +0000
committerLars Wendler <polynomial-c@gentoo.org>2011-05-29 10:10:23 +0000
commit7a1afbb4b2b9d6fa72395ff51f12074327f3946f (patch)
tree8800fcd05f34e450e43a364a8e12511d38203dab /sys-libs
parentppc64 stable wrt #355595 (diff)
downloadgentoo-2-7a1afbb4b2b9d6fa72395ff51f12074327f3946f.tar.gz
gentoo-2-7a1afbb4b2b9d6fa72395ff51f12074327f3946f.tar.bz2
gentoo-2-7a1afbb4b2b9d6fa72395ff51f12074327f3946f.zip
Fixed building with >=gcc-4.6.0
(Portage version: 2.2.0_alpha37/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libsmbios/ChangeLog10
-rw-r--r--sys-libs/libsmbios/files/libsmbios-2.2.26-gcc46.patch35
-rw-r--r--sys-libs/libsmbios/libsmbios-2.2.26.ebuild7
3 files changed, 47 insertions, 5 deletions
diff --git a/sys-libs/libsmbios/ChangeLog b/sys-libs/libsmbios/ChangeLog
index 21a37a7abab6..2549d5ee6c4c 100644
--- a/sys-libs/libsmbios/ChangeLog
+++ b/sys-libs/libsmbios/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/libsmbios
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsmbios/ChangeLog,v 1.28 2010/09/28 15:33:23 polynomial-c Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsmbios/ChangeLog,v 1.29 2011/05/29 10:10:23 polynomial-c Exp $
+
+ 29 May 2011; Lars Wendler <polynomial-c@gentoo.org> libsmbios-2.2.26.ebuild,
+ +files/libsmbios-2.2.26-gcc46.patch:
+ Fixed building with >=gcc-4.6.0. Thanks to Billy DeVincentis for reporting
+ this issue in bug #364285 and to steveb for giving the right hints how to fix
+ this.
*libsmbios-2.2.26 (28 Sep 2010)
diff --git a/sys-libs/libsmbios/files/libsmbios-2.2.26-gcc46.patch b/sys-libs/libsmbios/files/libsmbios-2.2.26-gcc46.patch
new file mode 100644
index 000000000000..cc13c8fb9ac5
--- /dev/null
+++ b/sys-libs/libsmbios/files/libsmbios-2.2.26-gcc46.patch
@@ -0,0 +1,35 @@
+--- libsmbios-2.2.26/Makefile.am
++++ libsmbios-2.2.26/Makefile.am
+@@ -18,8 +18,8 @@
+ TESTS=
+
+ AM_CPPFLAGS = -I$(top_builddir)/out/include -I$(top_srcdir)/src/include -DLIBSMBIOS_LOCALEDIR=\"$(localedir)\"
+-AM_CFLAGS = -Werror -Wall
+-AM_CXXFLAGS = -Werror -Wall
++AM_CFLAGS = -Wall
++AM_CXXFLAGS = -Wall
+ AM_LDADD = $(LIBINTL)
+ AM_LDFLAGS = -L$(top_builddir)/out/ -Wl,--no-undefined @LDFLAG_AS_NEEDED@
+
+--- libsmbios-2.2.26/src/include/smbios/config/compiler/gcc.hpp
++++ libsmbios-2.2.26/src/include/smbios/config/compiler/gcc.hpp
+@@ -113,7 +113,7 @@
+ # error "Compiler not configured - please reconfigure"
+ #endif
+ //
+-#if (__GNUC__ > 4) || ((__GNUC__ == 4) && (__GNUC_MINOR__ > 5))
++#if (__GNUC__ > 4) || ((__GNUC__ == 4) && (__GNUC_MINOR__ > 6))
+ # if defined(LIBSMBIOS_ASSERT_CONFIG)
+ # error "Unknown compiler version - please run the configure tests and report the results"
+ # else
+--- libsmbios-2.2.26/src/include/smbios_c/config/compiler/gcc.h
++++ libsmbios-2.2.26/src/include/smbios_c/config/compiler/gcc.h
+@@ -24,7 +24,7 @@
+ # error "GCC versions < 2.90 not supported"
+ #endif
+ //
+-#if (__GNUC__ > 4) || ((__GNUC__ == 4) && (__GNUC_MINOR__ > 5))
++#if (__GNUC__ > 4) || ((__GNUC__ == 4) && (__GNUC_MINOR__ > 6))
+ # if defined(LIBSMBIOS_C_ASSERT_CONFIG)
+ # error "Unknown compiler version - please run the configure tests and report the results"
+ # else
diff --git a/sys-libs/libsmbios/libsmbios-2.2.26.ebuild b/sys-libs/libsmbios/libsmbios-2.2.26.ebuild
index be05af5a078c..e672e0551b4f 100644
--- a/sys-libs/libsmbios/libsmbios-2.2.26.ebuild
+++ b/sys-libs/libsmbios/libsmbios-2.2.26.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsmbios/libsmbios-2.2.26.ebuild,v 1.1 2010/09/28 15:33:23 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsmbios/libsmbios-2.2.26.ebuild,v 1.2 2011/05/29 10:10:23 polynomial-c Exp $
EAPI=2
PYTHON_DEPEND="python? *:2.4"
-inherit python flag-o-matic autotools
+inherit eutils python flag-o-matic autotools
DESCRIPTION="Provide access to (SM)BIOS information"
HOMEPAGE="http://linux.dell.com/libsmbios/main/index.html"
@@ -27,6 +27,7 @@ DEPEND="${RDEPEND}
test? ( >=dev-util/cppunit-1.9.6 )"
src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.2.26-gcc46.patch
rm pkg/py-compile
ln -s "$(type -P true)" pkg/py-compile || die
eautoreconf