summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-08-04 14:01:47 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-08-04 14:01:47 +0000
commit819fffdbd23684622da5a164ea85c016d4df6bff (patch)
tree2f262aedc35f42007a6413d00f00ed1d15bfbf2f /sys-libs
parentOld. (diff)
downloadgentoo-2-819fffdbd23684622da5a164ea85c016d4df6bff.tar.gz
gentoo-2-819fffdbd23684622da5a164ea85c016d4df6bff.tar.bz2
gentoo-2-819fffdbd23684622da5a164ea85c016d4df6bff.zip
USE="static-libs" and remove unnecessary libtool files
(Portage version: 2.2.0_alpha47/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libunwind/ChangeLog7
-rw-r--r--sys-libs/libunwind/libunwind-0.99-r1.ebuild26
2 files changed, 22 insertions, 11 deletions
diff --git a/sys-libs/libunwind/ChangeLog b/sys-libs/libunwind/ChangeLog
index 66a204cae21a..6af0a679f72b 100644
--- a/sys-libs/libunwind/ChangeLog
+++ b/sys-libs/libunwind/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-libs/libunwind
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libunwind/ChangeLog,v 1.13 2010/05/19 20:27:30 armin76 Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libunwind/ChangeLog,v 1.14 2011/08/04 14:01:47 ssuominen Exp $
+
+ 04 Aug 2011; Samuli Suominen <ssuominen@gentoo.org> libunwind-0.99-r1.ebuild:
+ USE="static-libs" and remove unnecessary libtool files
19 May 2010; Raúl Porcel <armin76@gentoo.org> libunwind-0.99-r1.ebuild:
ia64 stable wrt #318613
diff --git a/sys-libs/libunwind/libunwind-0.99-r1.ebuild b/sys-libs/libunwind/libunwind-0.99-r1.ebuild
index d6cfb55997eb..bc1c7797cee3 100644
--- a/sys-libs/libunwind/libunwind-0.99-r1.ebuild
+++ b/sys-libs/libunwind/libunwind-0.99-r1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libunwind/libunwind-0.99-r1.ebuild,v 1.4 2010/05/19 20:27:30 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libunwind/libunwind-0.99-r1.ebuild,v 1.5 2011/08/04 14:01:47 ssuominen Exp $
+EAPI=4
inherit autotools eutils
DESCRIPTION="Portable and efficient API to determine the call-chain of a program"
@@ -11,20 +12,27 @@ SRC_URI="http://download.savannah.nongnu.org/releases/libunwind/${P}.tar.gz"
LICENSE="MIT"
SLOT="7"
KEYWORDS="amd64 ia64 x86"
-IUSE=""
+IUSE="static-libs"
RESTRICT="test" # https://savannah.nongnu.org/bugs/?22368
# https://bugs.gentoo.org/273372
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-disable-setjmp.patch \
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-disable-setjmp.patch \
"${FILESDIR}"/${P}-implicit-declaration.patch
eautoreconf
}
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
src_install() {
- emake install DESTDIR="${D}" || die
- dodoc AUTHORS ChangeLog NEWS README TODO
+ default
+ # libunwind-ptrace.a (and libunwind-ptrace.h) is separate API and without
+ # shared library, so we keep it in any case
+ use static-libs || rm -f "${D}"usr/lib*/libunwind{-generic.a,*.la}
}