summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-01-23 14:14:30 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-01-23 14:14:30 +0000
commit907259b130b8ee7f6a243b8455d7bef804a82728 (patch)
tree2eef3d2eaca4aa9d524dde692a015217fbbbfc2e /sys-libs
parentAdd new HOMEPAGE. Fix live toolchain patch. (diff)
downloadgentoo-2-907259b130b8ee7f6a243b8455d7bef804a82728.tar.gz
gentoo-2-907259b130b8ee7f6a243b8455d7bef804a82728.tar.bz2
gentoo-2-907259b130b8ee7f6a243b8455d7bef804a82728.zip
Remove older version
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/musl/ChangeLog5
-rw-r--r--sys-libs/musl/musl-0.9.14.ebuild92
2 files changed, 4 insertions, 93 deletions
diff --git a/sys-libs/musl/ChangeLog b/sys-libs/musl/ChangeLog
index aeedea2e08fc..d5932d0e6cb3 100644
--- a/sys-libs/musl/ChangeLog
+++ b/sys-libs/musl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-libs/musl
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/musl/ChangeLog,v 1.14 2014/01/14 17:52:03 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/musl/ChangeLog,v 1.15 2014/01/23 14:14:30 blueness Exp $
+
+ 23 Jan 2014; Anthony G. Basile <blueness@gentoo.org> -musl-0.9.14.ebuild:
+ Remove older version
*musl-0.9.15 (14 Jan 2014)
diff --git a/sys-libs/musl/musl-0.9.14.ebuild b/sys-libs/musl/musl-0.9.14.ebuild
deleted file mode 100644
index af8ae05db7ab..000000000000
--- a/sys-libs/musl/musl-0.9.14.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/musl/musl-0.9.14.ebuild,v 1.1 2013/09/24 12:06:52 blueness Exp $
-
-EAPI="5"
-
-inherit eutils flag-o-matic multilib toolchain-funcs
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.musl-libc.org/musl"
- inherit git-2
-fi
-
-export CBUILD=${CBUILD:-${CHOST}}
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
- export CTARGET=${CATEGORY/cross-}
- fi
-fi
-
-DESCRIPTION="Lightweight, fast and simple C library focused on standards-conformance and safety"
-HOMEPAGE="http://www.musl-libc.org/"
-if [[ ${PV} != "9999" ]] ; then
- PATCH_VER=""
- SRC_URI="http://www.musl-libc.org/releases/${P}.tar.gz"
- KEYWORDS="-* ~amd64 ~arm ~mips ~x86"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="crosscompile_opts_headers-only"
-
-is_crosscompile() {
- [[ ${CHOST} != ${CTARGET} ]]
-}
-
-just_headers() {
- use crosscompile_opts_headers-only && is_crosscompile
-}
-
-pkg_setup() {
- if [ ${CTARGET} == ${CHOST} ] ; then
- case ${CHOST} in
- *-musl*) ;;
- *) die "Use sys-devel/crossdev to build a musl toolchain" ;;
- esac
- fi
-}
-
-src_configure() {
- tc-export CC
-
- ./configure \
- --target="${CTARGET}" \
- --prefix="/usr" \
- --disable-gcc-wrapper
-}
-
-src_compile() {
- emake include/bits/alltypes.h || die
- just_headers && return 0
-
- emake || die
-}
-
-src_install() {
- local sysroot=${D}
- is_crosscompile && sysroot+="/usr/${CTARGET}"
-
- local target="install"
- just_headers && target="install-headers"
- emake DESTDIR="${sysroot}" ${target} || die
-
- # Make sure we install the sys-include symlink so that when
- # we build a 2nd stage cross-compiler, gcc finds the target
- # system headers correctly. See gcc/doc/gccinstall.info
- if is_crosscompile ; then
- dosym usr/include /usr/${CTARGET}/sys-include
- fi
-}
-
-pkg_postinst() {
- is_crosscompile && return 0
-
- [ "${ROOT}" != "/" ] && return 0
-
- # TODO: musl doesn't use ldconfig, instead here we can
- # create sym links to libraries outside of /lib and /usr/lib
- ldconfig
- # reload init ...
- /sbin/telinit U 2>/dev/null
-}