summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-09-30 06:29:21 +0000
committerMike Frysinger <vapier@gentoo.org>2010-09-30 06:29:21 +0000
commit9a9644463f97a75b3de2ae3bef702ce20c192740 (patch)
treefd860d302ee8b6a8df30345ebaad3353e87cba7a /sys-libs
parentstandardize output a bit (diff)
downloadgentoo-2-9a9644463f97a75b3de2ae3bef702ce20c192740.tar.gz
gentoo-2-9a9644463f97a75b3de2ae3bef702ce20c192740.tar.bz2
gentoo-2-9a9644463f97a75b3de2ae3bef702ce20c192740.zip
Take care of checking binutils gnu indirect support ourselves for now #336792 by Sergei Trofimovich.
(Portage version: 2.2_rc86/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/ChangeLog7
-rw-r--r--sys-libs/glibc/files/eblits/common.eblit15
-rw-r--r--sys-libs/glibc/files/eblits/src_compile.eblit3
3 files changed, 21 insertions, 4 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index 1f51b711d730..e18ac7551568 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/glibc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.714 2010/09/24 11:17:12 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.715 2010/09/30 06:29:21 vapier Exp $
+
+ 30 Sep 2010; Mike Frysinger <vapier@gentoo.org> files/eblits/common.eblit,
+ files/eblits/src_compile.eblit:
+ Take care of checking binutils gnu indirect support ourselves for now
+ #336792 by Sergei Trofimovich.
24 Sep 2010; Raúl Porcel <armin76@gentoo.org> glibc-2.12.1-r1.ebuild:
Mark -sparc since it fails to build, bug #336792
diff --git a/sys-libs/glibc/files/eblits/common.eblit b/sys-libs/glibc/files/eblits/common.eblit
index 985457e71313..d5643fc5b126 100644
--- a/sys-libs/glibc/files/eblits/common.eblit
+++ b/sys-libs/glibc/files/eblits/common.eblit
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/common.eblit,v 1.11 2010/06/16 01:43:37 zorry Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/common.eblit,v 1.12 2010/09/30 06:29:21 vapier Exp $
# We need to be able to set alternative headers for
# compiling for non-native platform
@@ -251,6 +251,17 @@ use_multilib() {
esac
}
+use_multiarch() {
+ # Make sure binutils is new enough to support indirect functions #336792
+ local bver=$($(tc-getLD ${CTARGET}) -v | awk '{print $NF}') nver
+ case $(tc-arch ${CTARGET}) in
+ amd64|x86) nver="2.20" ;;
+ sparc) nver="2.21" ;;
+ *) return 1 ;;
+ esac
+ version_is_at_least ${nver} ${bver}
+}
+
# Setup toolchain variables that would be defined in the profiles for these archs.
setup_env() {
# silly users
diff --git a/sys-libs/glibc/files/eblits/src_compile.eblit b/sys-libs/glibc/files/eblits/src_compile.eblit
index 0abce11d9896..eb0dfc053a25 100644
--- a/sys-libs/glibc/files/eblits/src_compile.eblit
+++ b/sys-libs/glibc/files/eblits/src_compile.eblit
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/src_compile.eblit,v 1.14 2010/09/30 06:27:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/src_compile.eblit,v 1.15 2010/09/30 06:29:21 vapier Exp $
glibc_do_configure() {
local myconf
@@ -85,6 +85,7 @@ glibc_do_configure() {
--mandir=/usr/share/man
--infodir=/usr/share/info
--libexecdir=/usr/$(get_libdir)/misc/glibc
+ $(use_multiarch || echo --disable-multi-arch)
${EXTRA_ECONF}"
# There is no configure option for this and we need to export it