summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul de Vrieze <pauldv@gentoo.org>2003-06-07 12:21:31 +0000
committerPaul de Vrieze <pauldv@gentoo.org>2003-06-07 12:21:31 +0000
commit9bb7cac522ac353e88b2c82cc182233d35097d35 (patch)
tree55ae4126a1c5042300e28d2125ec944bf37e2d10 /sys-libs
parentCPAN update (diff)
downloadgentoo-2-9bb7cac522ac353e88b2c82cc182233d35097d35.tar.gz
gentoo-2-9bb7cac522ac353e88b2c82cc182233d35097d35.tar.bz2
gentoo-2-9bb7cac522ac353e88b2c82cc182233d35097d35.zip
Allow for crosscompiling
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/db/ChangeLog7
-rw-r--r--sys-libs/db/Manifest10
-rw-r--r--sys-libs/db/db-3.2.9-r5.ebuild19
-rw-r--r--sys-libs/db/db-4.0.14.ebuild19
-rw-r--r--sys-libs/db/db-4.1.24.ebuild19
-rw-r--r--sys-libs/db/db-4.1.25.ebuild21
6 files changed, 49 insertions, 46 deletions
diff --git a/sys-libs/db/ChangeLog b/sys-libs/db/ChangeLog
index e83488a1aac9..68b1a8791a17 100644
--- a/sys-libs/db/ChangeLog
+++ b/sys-libs/db/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/db
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.31 2003/05/30 10:04:24 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.32 2003/06/07 12:21:22 pauldv Exp $
+
+ 07 Jun 2003; Paul de Vrieze <pauldv@gentoo.org> db-3.2.9-r5.ebuild,
+ db-4.0.14.ebuild, db-4.1.24.ebuild, db-4.1.25.ebuild:
+ Fix the autosymlinking script to work in a cross environment. Courtessy of
+ Alastair Tse <liquidx@gentoo.org>, bug #22393.
*db-4.1.25 (30 May 2003)
diff --git a/sys-libs/db/Manifest b/sys-libs/db/Manifest
index 8c6834794f0b..4b91e568f632 100644
--- a/sys-libs/db/Manifest
+++ b/sys-libs/db/Manifest
@@ -1,14 +1,14 @@
-MD5 5fff10dda1a1fe063bb1dd378ab7cda1 ChangeLog 5535
+MD5 8051114e84e907b83a4e81153820a70d ChangeLog 5788
MD5 4e148693b2d6fe0b1e66a8724cbfc20c db-1.85-r1.ebuild 1411
MD5 744542679cd64194e3ac9e84e5f7056e db-3.2.3h-r4.ebuild 2455
MD5 4be311009c1216a911e76dcf33bb568d db-3.2.9-r1.ebuild 2587
MD5 e03298e927335414c7db1882f24ed8e4 db-3.2.9-r2.ebuild 3221
MD5 af7ea3ee5a3a001d516413c0b9bc52e5 db-3.2.9.ebuild 2464
MD5 64badf49ee0112cc58008c6c9ada4e52 db-3.3.11.ebuild 2408
-MD5 713efe2ab508f0bef006582f29b60857 db-4.1.25.ebuild 2160
-MD5 f3bfd0cfb4c1930298030a47da11697f db-4.1.24.ebuild 2161
-MD5 e61c8b762acd61e18cdd1b4e2015c116 db-4.0.14.ebuild 2317
-MD5 797258fc74365ad6ac636969ea8b4037 db-3.2.9-r5.ebuild 4184
+MD5 2c93626d3417626c2480afb464f6dcf4 db-4.1.25.ebuild 2190
+MD5 0250feacd38626800c3f5722d50116fc db-4.1.24.ebuild 2189
+MD5 ed34b96b146f80ae51dd28bac88896b5 db-4.0.14.ebuild 2343
+MD5 3c7777f7cd26a964b0ab49de4cda5b9d db-3.2.9-r5.ebuild 4212
MD5 1260aeee2785bda43e81a36b6cb247be files/digest-db-4.1.25 62
MD5 194200b3295b95b46b4564980af27f1f files/db-3.2.9-fix-dep-link.patch 1005
MD5 ecd81fa9868ec49c61306444144d44a9 files/db.1.85.patch 55584
diff --git a/sys-libs/db/db-3.2.9-r5.ebuild b/sys-libs/db/db-3.2.9-r5.ebuild
index 5e27aeb11f57..ad5be88773ef 100644
--- a/sys-libs/db/db-3.2.9-r5.ebuild
+++ b/sys-libs/db/db-3.2.9-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.2.9-r5.ebuild,v 1.6 2003/05/30 10:04:24 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.2.9-r5.ebuild,v 1.7 2003/06/07 12:21:22 pauldv Exp $
IUSE=""
@@ -136,20 +136,19 @@ src_install () {
}
fix_so () {
- cd /usr/lib
+ cd ${ROOT}/usr/lib
target=`find -type f -maxdepth 1 -name "libdb-*.so" |sort |tail -n 1`
- [ ${target} ] && ln -sf ${target//.\//} libdb.so
+ [ -n "${target}" ] && ln -sf ${target//.\//} libdb.so
target=`find -type f -maxdepth 1 -name "libdb_cxx*.so" |sort |tail -n 1`
- [ ${target} ] && ln -sf ${target//.\//} libdb_cxx.so
+ [ -n "${target}" ] && ln -sf ${target//.\//} libdb_cxx.so
target=`find -type f -maxdepth 1 -name "libdb_tcl*.so" |sort |tail -n 1`
- [ ${target} ] && ln -sf ${target//.\//} libdb_tcl.so
+ [ -n "${target}" ] && ln -sf ${target//.\//} libdb_tcl.so
target=`find -type f -maxdepth 1 -name "libdb_java*.so" |sort |tail -n 1`
- [ ${target} ] && ln -sf ${target//.\//} libdb_java.so
- cd -
- cd /usr/include
+ [ -n "${target}" ] && ln -sf ${target//.\//} libdb_java.so
+
+ cd ${ROOT}/usr/include
target=`ls -d db? |tail -n 1`
- [ ${target} ] && ln -sf ${target}/db.h .
- cd -
+ [ -n "${target}" ] && ln -sf ${target}/db.h .
}
pkg_postinst () {
diff --git a/sys-libs/db/db-4.0.14.ebuild b/sys-libs/db/db-4.0.14.ebuild
index 18e04dc0d12a..2f46af76eb8c 100644
--- a/sys-libs/db/db-4.0.14.ebuild
+++ b/sys-libs/db/db-4.0.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.0.14.ebuild,v 1.20 2003/05/28 15:37:35 g2boojum Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.0.14.ebuild,v 1.21 2003/06/07 12:21:22 pauldv Exp $
IUSE="tcltk java"
@@ -69,20 +69,19 @@ src_install () {
}
fix_so () {
- cd /usr/lib
+ cd ${ROOT}/usr/lib
target=`find -type f -maxdepth 1 -name "libdb-*.so" |sort |tail -n 1`
- [ ${target} ] && ln -sf ${target//.\//} libdb.so
+ [ -n "${target}" ] && ln -sf ${target//.\//} libdb.so
target=`find -type f -maxdepth 1 -name "libdb_cxx*.so" |sort |tail -n 1`
- [ ${target} ] && ln -sf ${target//.\//} libdb_cxx.so
+ [ -n "${target}" ] && ln -sf ${target//.\//} libdb_cxx.so
target=`find -type f -maxdepth 1 -name "libdb_tcl*.so" |sort |tail -n 1`
- [ ${target} ] && ln -sf ${target//.\//} libdb_tcl.so
+ [ -n "${target}" ] && ln -sf ${target//.\//} libdb_tcl.so
target=`find -type f -maxdepth 1 -name "libdb_java*.so" |sort |tail -n 1`
- [ ${target} ] && ln -sf ${target//.\//} libdb_java.so
- cd -
- cd /usr/include
+ [ -n "${target}" ] && ln -sf ${target//.\//} libdb_java.so
+
+ cd ${ROOT}/usr/include
target=`ls -d db? |tail -n 1`
- [ ${target} ] && ln -sf ${target}/db.h .
- cd -
+ [ -n "${target}" ] && ln -sf ${target}/db.h .
}
pkg_postinst () {
diff --git a/sys-libs/db/db-4.1.24.ebuild b/sys-libs/db/db-4.1.24.ebuild
index f8f6eee938e8..88d99b222740 100644
--- a/sys-libs/db/db-4.1.24.ebuild
+++ b/sys-libs/db/db-4.1.24.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.1.24.ebuild,v 1.14 2003/05/25 18:49:13 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.1.24.ebuild,v 1.15 2003/06/07 12:21:23 pauldv Exp $
IUSE="tcltk java"
@@ -64,20 +64,19 @@ src_install () {
}
fix_so () {
- cd /usr/lib
+ cd ${ROOT}/usr/lib
target=`find -type f -maxdepth 1 -name "libdb-*.so" |sort |tail -n 1`
- [ ${target} ] && ln -sf ${target//.\//} libdb.so
+ [ -n "${target}" ] && ln -sf ${target//.\//} libdb.so
target=`find -type f -maxdepth 1 -name "libdb_cxx*.so" |sort |tail -n 1`
- [ ${target} ] && ln -sf ${target//.\//} libdb_cxx.so
+ [ -n "${target}" ] && ln -sf ${target//.\//} libdb_cxx.so
target=`find -type f -maxdepth 1 -name "libdb_tcl*.so" |sort |tail -n 1`
- [ ${target} ] && ln -sf ${target//.\//} libdb_tcl.so
+ [ -n "${target}" ] && ln -sf ${target//.\//} libdb_tcl.so
target=`find -type f -maxdepth 1 -name "libdb_java*.so" |sort |tail -n 1`
- [ ${target} ] && ln -sf ${target//.\//} libdb_java.so
- cd -
- cd /usr/include
+ [ -n "${target}" ] && ln -sf ${target//.\//} libdb_java.so
+
+ cd ${ROOT}/usr/include
target=`ls -d db? |tail -n 1`
- [ ${target} ] && ln -sf ${target}/db.h .
- cd -
+ [ -n "${target}" ] && ln -sf ${target}/db.h .
}
pkg_postinst () {
diff --git a/sys-libs/db/db-4.1.25.ebuild b/sys-libs/db/db-4.1.25.ebuild
index 9df88288acf8..4700505a7a5c 100644
--- a/sys-libs/db/db-4.1.25.ebuild
+++ b/sys-libs/db/db-4.1.25.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.1.25.ebuild,v 1.1 2003/05/30 10:04:24 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.1.25.ebuild,v 1.2 2003/06/07 12:21:23 pauldv Exp $
IUSE="tcltk java"
@@ -64,20 +64,21 @@ src_install () {
}
fix_so () {
- cd /usr/lib
+
+ cd ${ROOT}/usr/lib
target=`find -type f -maxdepth 1 -name "libdb-*.so" |sort |tail -n 1`
- [ ${target} ] && ln -sf ${target//.\//} libdb.so
+ [ -n "${target}" ] && ln -sf ${target//.\//} libdb.so
target=`find -type f -maxdepth 1 -name "libdb_cxx*.so" |sort |tail -n 1`
- [ ${target} ] && ln -sf ${target//.\//} libdb_cxx.so
+ [ -n "${target}" ] && ln -sf ${target//.\//} libdb_cxx.so
target=`find -type f -maxdepth 1 -name "libdb_tcl*.so" |sort |tail -n 1`
- [ ${target} ] && ln -sf ${target//.\//} libdb_tcl.so
+ [ -n "${target}" ] && ln -sf ${target//.\//} libdb_tcl.so
target=`find -type f -maxdepth 1 -name "libdb_java*.so" |sort |tail -n 1`
- [ ${target} ] && ln -sf ${target//.\//} libdb_java.so
- cd -
- cd /usr/include
+ [ -n "${target}" ] && ln -sf ${target//.\//} libdb_java.so
+
+ cd ${ROOT}/usr/include
target=`ls -d db? |tail -n 1`
- [ ${target} ] && ln -sf ${target}/db.h .
- cd -
+ [ -n "${target}" ] && ln -sf ${target}/db.h .
+
}
pkg_postinst () {