summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuy Martin <gmsoft@gentoo.org>2003-03-24 13:26:09 +0000
committerGuy Martin <gmsoft@gentoo.org>2003-03-24 13:26:09 +0000
commitce28e320a1f49738100e9bcbe5df7f696cc28b26 (patch)
treed03bb620f7ba3bf4e23c46f37c25fb3318859dba /sys-libs
parentEtherboot pxe loadable roms updated to 5.0.9, fixes dos booting. (diff)
downloadgentoo-2-ce28e320a1f49738100e9bcbe5df7f696cc28b26.tar.gz
gentoo-2-ce28e320a1f49738100e9bcbe5df7f696cc28b26.tar.bz2
gentoo-2-ce28e320a1f49738100e9bcbe5df7f696cc28b26.zip
dded patch to fix linking under some circumstances.
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/pwdb/ChangeLog5
-rw-r--r--sys-libs/pwdb/files/pwdb-0.61-hppa.patch12
-rw-r--r--sys-libs/pwdb/pwdb-0.61-r4.ebuild6
3 files changed, 20 insertions, 3 deletions
diff --git a/sys-libs/pwdb/ChangeLog b/sys-libs/pwdb/ChangeLog
index 91dd44e54233..8b67649c8089 100644
--- a/sys-libs/pwdb/ChangeLog
+++ b/sys-libs/pwdb/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-libs/pwdb
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/pwdb/ChangeLog,v 1.12 2003/02/20 22:00:24 zwelch Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pwdb/ChangeLog,v 1.13 2003/03/24 13:26:09 gmsoft Exp $
+
+ 24 Mar 2003; Guy Martin <gmsoft@gentoo.org> pwdb-0.61-r4.ebuild, pwdb-0.61-hppa.patch :
+ Added patch to fix linking under some circumstances on hppa.
18 Feb 2003; Zach Welch <zwelch@gentoo.org> pwdb-0.61-r4.ebuild :
Added arm to keywords.
diff --git a/sys-libs/pwdb/files/pwdb-0.61-hppa.patch b/sys-libs/pwdb/files/pwdb-0.61-hppa.patch
new file mode 100644
index 000000000000..1a866f3be661
--- /dev/null
+++ b/sys-libs/pwdb/files/pwdb-0.61-hppa.patch
@@ -0,0 +1,12 @@
+--- work/pwdb-0.61/libpwdb/Makefile 2003-03-24 09:42:42.000000000 +0000
++++ work.old/pwdb-0.61/libpwdb/Makefile 2003-03-24 09:34:04.000000000 +0000
+@@ -50,7 +50,8 @@
+
+
+ $(LIBDYNAME): $(LIBOBJ)
+- $(LD) -soname $(LIBSONAME) -x -shared -o $(LIBFILENAME) $(LIBOBJ) -lcrypt -lnsl -lc
++ #$(LD) -soname $(LIBSONAME) -x -shared -o $(LIBFILENAME) $(LIBOBJ) -lcrypt -lnsl -lc
++ $(CC) -shared -o $(LIBFILENAME) $(LIBOBJ) -lcrypt -lnsl -lc
+ @ln -sf $(LIBFILENAME) $@
+
+ $(LIBSTATIC): $(LIBOBJ)
diff --git a/sys-libs/pwdb/pwdb-0.61-r4.ebuild b/sys-libs/pwdb/pwdb-0.61-r4.ebuild
index 60a0e98dd567..e7ba4bf9408c 100644
--- a/sys-libs/pwdb/pwdb-0.61-r4.ebuild
+++ b/sys-libs/pwdb/pwdb-0.61-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/pwdb/pwdb-0.61-r4.ebuild,v 1.7 2003/02/20 22:00:24 zwelch Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pwdb/pwdb-0.61-r4.ebuild,v 1.8 2003/03/24 13:26:09 gmsoft Exp $
inherit eutils
@@ -19,7 +19,9 @@ src_unpack () {
mkdir ${S}
cd ${S}
unpack ${A}
-}
+ [ "${ARCH}" = "hppa" ] && patch -p 2 < ${FILESDIR}/pwdb-0.61-hppa.patch
+
+}
src_compile() {
cp Makefile Makefile.orig