summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-08-03 09:33:19 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-08-03 09:33:19 +0000
commitdf0f03101b21348fdf958afaab2548d0c3c277d0 (patch)
tree9225014e04b4f22175175a12ebdadeab3235bb17 /sys-libs
parentVersion bump (diff)
downloadgentoo-2-df0f03101b21348fdf958afaab2548d0c3c277d0.tar.gz
gentoo-2-df0f03101b21348fdf958afaab2548d0c3c277d0.tar.bz2
gentoo-2-df0f03101b21348fdf958afaab2548d0c3c277d0.zip
Bump to 20110727 SELinux userspace release
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libselinux/ChangeLog8
-rw-r--r--sys-libs/libselinux/libselinux-2.1.0.ebuild83
2 files changed, 90 insertions, 1 deletions
diff --git a/sys-libs/libselinux/ChangeLog b/sys-libs/libselinux/ChangeLog
index 3ae10e9994ba..d2fc7387337e 100644
--- a/sys-libs/libselinux/ChangeLog
+++ b/sys-libs/libselinux/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/libselinux
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/ChangeLog,v 1.72 2011/07/15 20:57:55 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/ChangeLog,v 1.73 2011/08/03 09:33:19 blueness Exp $
+
+*libselinux-2.1.0 (03 Aug 2011)
+
+ 03 Aug 2011; Anthony G. Basile <blueness@gentoo.org>
+ +libselinux-2.1.0.ebuild:
+ Bump to 20110727 SELinux userspace release
*libselinux-2.0.98 (15 Jul 2011)
diff --git a/sys-libs/libselinux/libselinux-2.1.0.ebuild b/sys-libs/libselinux/libselinux-2.1.0.ebuild
new file mode 100644
index 000000000000..333e50e94f7e
--- /dev/null
+++ b/sys-libs/libselinux/libselinux-2.1.0.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/libselinux-2.1.0.ebuild,v 1.1 2011/08/03 09:33:19 blueness Exp $
+
+EAPI="2"
+PYTHON_DEPEND="python? 2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit multilib python toolchain-funcs
+
+SEPOL_VER="2.1.0"
+
+DESCRIPTION="SELinux userland library"
+HOMEPAGE="http://userspace.selinuxproject.org"
+SRC_URI="http://userspace.selinuxproject.org/releases/20110727/devel/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python ruby"
+
+RDEPEND=">=sys-libs/libsepol-${SEPOL_VER}
+ ruby? ( dev-lang/ruby )"
+DEPEND="${RDEPEND}
+ ruby? ( dev-lang/swig )"
+
+pkg_setup() {
+ if use python; then
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ # fix up paths for multilib
+ sed -i -e "/^LIBDIR/s/lib/$(get_libdir)/" "${S}/src/Makefile" \
+ || die "Fix for multilib LIBDIR failed."
+ sed -i -e "/^SHLIBDIR/s/lib/$(get_libdir)/" "${S}/src/Makefile" \
+ || die "Fix for multilib SHLIBDIR failed."
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)" LDFLAGS="-fPIC ${LDFLAGS}" all || die
+
+ if use python; then
+ python_copy_sources src
+ building() {
+ emake CC="$(tc-getCC)" PYLIBVER="python$(python_get_version)" LDFLAGS="-fPIC ${LDFLAGS}" pywrap
+ }
+ python_execute_function -s --source-dir src building
+ fi
+
+ if use ruby; then
+ emake CC="$(tc-getCC)" rubywrap || die
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ if use python; then
+ installation() {
+ emake DESTDIR="${D}" PYLIBVER="python$(python_get_version)" install-pywrap
+ }
+ python_execute_function -s --source-dir src installation
+ fi
+
+ if use ruby; then
+ emake DESTDIR="${D}" install-rubywrap || die
+ fi
+}
+
+pkg_postinst() {
+ if use python; then
+ python_mod_optimize selinux
+ fi
+}
+
+pkg_postrm() {
+ if use python; then
+ python_mod_cleanup selinux
+ fi
+}