summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2006-11-13 22:21:37 +0000
committerLuca Barbato <lu_zero@gentoo.org>2006-11-13 22:21:37 +0000
commitf92ba6f1469d63643ae3ddc3e8cf59d4a7a96ddf (patch)
tree9b8daf20378b753ca58f5c6ce187f68c6e954f3a /sys-libs
parentStable on Alpha. (diff)
downloadgentoo-2-f92ba6f1469d63643ae3ddc3e8cf59d4a7a96ddf.tar.gz
gentoo-2-f92ba6f1469d63643ae3ddc3e8cf59d4a7a96ddf.tar.bz2
gentoo-2-f92ba6f1469d63643ae3ddc3e8cf59d4a7a96ddf.zip
Snapshot with updated Cell support
(Portage version: 2.1.2_rc1-r6)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/newlib/ChangeLog7
-rw-r--r--sys-libs/newlib/files/digest-newlib-200611133
-rw-r--r--sys-libs/newlib/newlib-20061113.ebuild75
3 files changed, 84 insertions, 1 deletions
diff --git a/sys-libs/newlib/ChangeLog b/sys-libs/newlib/ChangeLog
index ba671ccfc372..ee3c69b7102b 100644
--- a/sys-libs/newlib/ChangeLog
+++ b/sys-libs/newlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/newlib
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/ChangeLog,v 1.1 2006/08/21 03:06:20 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/ChangeLog,v 1.2 2006/11/13 22:21:37 lu_zero Exp $
+
+*newlib-20061113 (13 Nov 2006)
+
+ 13 Nov 2006; Luca Barbato <lu_zero@gentoo.org> +newlib-20061113.ebuild:
+ Snapshot with updated Cell support
*newlib-1.14.0 (21 Aug 2006)
diff --git a/sys-libs/newlib/files/digest-newlib-20061113 b/sys-libs/newlib/files/digest-newlib-20061113
new file mode 100644
index 000000000000..e57727fb015a
--- /dev/null
+++ b/sys-libs/newlib/files/digest-newlib-20061113
@@ -0,0 +1,3 @@
+MD5 70c7f4b4e0b53a43ff5ec4ca8788e224 newlib-20061113.tar.bz2 6518578
+RMD160 6bc1d077379d3ef8d73621d0db826602338825b5 newlib-20061113.tar.bz2 6518578
+SHA256 540abf8c4716b0d6a269485d2d44e69e0fcd96f47cc84794e9ebb0d8129ec2f9 newlib-20061113.tar.bz2 6518578
diff --git a/sys-libs/newlib/newlib-20061113.ebuild b/sys-libs/newlib/newlib-20061113.ebuild
new file mode 100644
index 000000000000..2496366dd6e6
--- /dev/null
+++ b/sys-libs/newlib/newlib-20061113.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/newlib-20061113.ebuild,v 1.1 2006/11/13 22:21:37 lu_zero Exp $
+
+inherit eutils flag-o-matic
+
+export CBUILD=${CBUILD:-${CHOST}}
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
+ export CTARGET=${CATEGORY/cross-}
+ fi
+fi
+
+# Handle the case where we want newlib on glibc ...
+if [[ ${CTARGET} == ${CHOST} ]] && [[ ${CHOST} != *-newlib ]] ; then
+ export CTARGET=${CHOST%%-*}-pc-linux-newlib
+fi
+
+DESCRIPTION="Newlib is a C library intended for use on embedded systems"
+HOMEPAGE="http://sourceware.org/newlib/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="NEWLIB LIBGLOSS GPL-2"
+[[ ${CTARGET} != ${CHOST} ]] \
+ && SLOT="${CTARGET}" \
+ || SLOT="0"
+KEYWORDS="-* ~ppc64 ~ppc"
+IUSE="nls threads unicode multilib"
+RESTRICT="strip"
+
+DEPEND=""
+RDEPEND=""
+
+NEWLIBBUILD="${WORKDIR}/build"
+S="${WORKDIR}/newlib"
+
+src_unpack() {
+ unpack ${A}
+ mkdir -p "${NEWLIBBUILD}"
+}
+
+src_compile() {
+ # we should fix this ...
+ unset LDFLAGS
+ CHOST=${CTARGET} strip-unsupported-flags
+
+ local myconf=""
+ # hardwired to avoid breakages
+ [[ ${CTARGET} == *-softfloat-* ]] \
+ && myconf="--disable-newlib-hw-fp" \
+ || myconf="--enable-newlib-hw-fp"
+ [[ ${CTARGET} == "spu" ]] \
+ && myconf="${myconf} --disable-threads" \
+ || myconf="${myconf} $(use_enable threads)"
+
+ cd "${NEWLIBBUILD}"
+
+ ECONF_SOURCE=${S} \
+ econf \
+ $(use_enable unicode newlib-mb) \
+ $(use_enable nls) \
+ $(use_enable multilib) \
+ ${myconf} \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ cd "${NEWLIBBUILD}"
+ emake -j1 DESTDIR="${D}" install
+ env -uRESTRICT CHOST=${CTARGET} prepallstrip
+ # minor hack to keep things clean
+ rm -fR "${D}"/usr/info
+}