summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2009-04-04 11:43:03 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2009-04-04 11:43:03 +0000
commitebe8f76da6c3d151810dcf92e49d7b313eaef714 (patch)
tree017022d42664181177680588122442fe83a1ae2b /sys-power/hibernate-script
parentVersion bump. (diff)
downloadgentoo-2-ebe8f76da6c3d151810dcf92e49d7b313eaef714.tar.gz
gentoo-2-ebe8f76da6c3d151810dcf92e49d7b313eaef714.tar.bz2
gentoo-2-ebe8f76da6c3d151810dcf92e49d7b313eaef714.zip
Version bump.
(Portage version: 2.1.6.11/cvs/Linux x86_64)
Diffstat (limited to 'sys-power/hibernate-script')
-rw-r--r--sys-power/hibernate-script/ChangeLog8
-rw-r--r--sys-power/hibernate-script/hibernate-script-2.0.ebuild59
2 files changed, 66 insertions, 1 deletions
diff --git a/sys-power/hibernate-script/ChangeLog b/sys-power/hibernate-script/ChangeLog
index d81026bedf4e..c55db2223491 100644
--- a/sys-power/hibernate-script/ChangeLog
+++ b/sys-power/hibernate-script/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-power/hibernate-script
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/ChangeLog,v 1.81 2009/02/02 23:51:21 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/ChangeLog,v 1.82 2009/04/04 11:43:03 nelchael Exp $
+
+*hibernate-script-2.0 (04 Apr 2009)
+
+ 04 Apr 2009; Krzysiek Pawlik <nelchael@gentoo.org>
+ +hibernate-script-2.0.ebuild:
+ Version bump.
02 Feb 2009; Krzysiek Pawlik <nelchael@gentoo.org> ChangeLog:
Fix ChangeLog entries.
diff --git a/sys-power/hibernate-script/hibernate-script-2.0.ebuild b/sys-power/hibernate-script/hibernate-script-2.0.ebuild
new file mode 100644
index 000000000000..1ad383e88266
--- /dev/null
+++ b/sys-power/hibernate-script/hibernate-script-2.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/hibernate-script-2.0.ebuild,v 1.1 2009/04/04 11:43:03 nelchael Exp $
+
+PATCH_VERSION="1"
+
+DESCRIPTION="Hibernate script supporting multiple suspend methods"
+HOMEPAGE="http://www.tuxonice.net/"
+SRC_URI="http://www.tuxonice.net/downloads/all/${P}.tar.gz
+ mirror://gentoo/${PN}-1.98.1-patches-${PATCH_VERSION}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="vim-syntax"
+
+DEPEND=""
+RDEPEND="!<media-gfx/splashutils-1.5.2"
+
+src_install() {
+ BASE_DIR="${D}" \
+ DISTRIBUTION="gentoo" \
+ PREFIX="/usr" \
+ MAN_DIR="${D}/usr/share/man" \
+ "${S}/install.sh" || die "Install failed"
+
+ # hibernate-ram will default to using ram.conf
+ dosym /usr/sbin/hibernate /usr/sbin/hibernate-ram
+
+ newinitd "${S}"/init.d/hibernate-cleanup.sh hibernate-cleanup
+
+ # other ebuilds can install scriplets to this dir
+ keepdir /etc/hibernate/scriptlets.d/
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins hibernate.vim
+ fi
+
+ dodoc CHANGELOG README SCRIPTLET-API hibernate.vim
+
+ insinto /etc/logrotate.d
+ newins "${S}"/logrotate.d-hibernate-script hibernate-script
+}
+
+pkg_postinst() {
+ elog
+ elog "You should run the following command to invalidate suspend"
+ elog "images on a clean boot."
+ elog
+ elog " # rc-update add hibernate-cleanup boot"
+ elog
+ elog "See /usr/share/doc/${PF}/README.* for further details."
+ elog
+ elog "Please note that you will need to manually emerge any utilities"
+ elog "(radeontool, vbetool, ...) enabled in the configuration files,"
+ elog "should you wish to use them."
+}