summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-07-31 06:47:10 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-07-31 06:47:10 +0000
commit56cae24d70c16d0be292361e26b385fed2b5b050 (patch)
treeba2789cdde0d1251b1c270a0de3bbfc4462b5734 /sys-power/iasl/iasl-20080514.ebuild
parentadd now released GNU Emacs 23 to the virtual (diff)
downloadgentoo-2-56cae24d70c16d0be292361e26b385fed2b5b050.tar.gz
gentoo-2-56cae24d70c16d0be292361e26b385fed2b5b050.tar.bz2
gentoo-2-56cae24d70c16d0be292361e26b385fed2b5b050.zip
Bug #278730.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sys-power/iasl/iasl-20080514.ebuild')
-rw-r--r--sys-power/iasl/iasl-20080514.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/sys-power/iasl/iasl-20080514.ebuild b/sys-power/iasl/iasl-20080514.ebuild
index 9ac0969d9380..af0ae2745768 100644
--- a/sys-power/iasl/iasl-20080514.ebuild
+++ b/sys-power/iasl/iasl-20080514.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20080514.ebuild,v 1.3 2008/06/07 02:55:49 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20080514.ebuild,v 1.4 2009/07/31 06:47:10 robbat2 Exp $
inherit toolchain-funcs flag-o-matic eutils
@@ -74,15 +74,15 @@ src_install() {
dobin "${T}"/${bin}
done
dodoc README changes.txt
- if hasq test $FEATURES ; then
+ if use test ; then
+ tb="${T}"/testresults.tar.bz2
export ASLTSDIR="$(<"${T}"/asltdir)"
- cd "${ASLTSDIR}"/tmp/RESULTS || die "cd ${ASLTSDIR}/tmp/RESULTS failed"
ebegin "Creating Test Tarball"
- tar -cjf testresults.tar.bz2 * || die "tar failed"
+ tar -cjf "${tb}" -C "${ASLTSDIR}"/tmp/RESULTS . || die "tar failed"
eend $?
dodir /usr/share/${PF}
insinto /usr/share/${PF}
- doins testresults.tar.bz2 || die "doins testresults.tar.bz2 failed"
+ doins ${tb} || die "doins testresults.tar.bz2 failed"
fi
}