summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-07-13 19:09:02 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-07-13 19:09:02 +0000
commitfd2a554a33c94e8fb58ce47baf3a232bdfca68e3 (patch)
tree03ec62d9ac3a293bf306065b0d2c8039f9987328 /sys-power/iasl
parentMarked ppc stable for bug #212241. (diff)
downloadgentoo-2-fd2a554a33c94e8fb58ce47baf3a232bdfca68e3.tar.gz
gentoo-2-fd2a554a33c94e8fb58ce47baf3a232bdfca68e3.tar.bz2
gentoo-2-fd2a554a33c94e8fb58ce47baf3a232bdfca68e3.zip
Version bump as the 20080514 version fails under KVM, per bug #231574.
(Portage version: 2.2_rc1/cvs/Linux 2.6.26-rc4-00103-g1beee8d x86_64)
Diffstat (limited to 'sys-power/iasl')
-rw-r--r--sys-power/iasl/ChangeLog7
-rw-r--r--sys-power/iasl/iasl-20080701.ebuild117
2 files changed, 123 insertions, 1 deletions
diff --git a/sys-power/iasl/ChangeLog b/sys-power/iasl/ChangeLog
index 5827f64152d9..3cbcf1fee778 100644
--- a/sys-power/iasl/ChangeLog
+++ b/sys-power/iasl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-power/iasl
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/ChangeLog,v 1.19 2008/06/07 02:55:49 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/ChangeLog,v 1.20 2008/07/13 19:09:02 robbat2 Exp $
+
+*iasl-20080701 (13 Jul 2008)
+
+ 13 Jul 2008; Robin H. Johnson <robbat2@gentoo.org> +iasl-20080701.ebuild:
+ Version bump as the 20080514 version fails under KVM, per bug #231574.
07 Jun 2008; Robin H. Johnson <robbat2@gentoo.org> iasl-20080514.ebuild:
Per bug #224505, we need to check FEATURES in src_install, as ASLTDIR will
diff --git a/sys-power/iasl/iasl-20080701.ebuild b/sys-power/iasl/iasl-20080701.ebuild
new file mode 100644
index 000000000000..e09bbd1731f7
--- /dev/null
+++ b/sys-power/iasl/iasl-20080701.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20080701.ebuild,v 1.1 2008/07/13 19:09:02 robbat2 Exp $
+
+inherit toolchain-funcs flag-o-matic eutils
+
+MY_PN=acpica-unix
+MY_P=${MY_PN}-${PV}
+MY_TESTS_P=${MY_PN/ca/tests}-${PV}
+DESCRIPTION="Intel ACPI Source Language (ASL) compiler"
+HOMEPAGE="http://www.intel.com/technology/iapc/acpi/"
+SRC_URI="http://www.acpica.org/download/${MY_P}.tar.gz
+ test? ( http://www.acpica.org/download/${MY_TESTS_P}.tar.gz )"
+
+LICENSE="iASL"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+IUSE="test"
+DEPEND="sys-devel/bison
+ sys-devel/flex"
+
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ if use test
+ then
+ ewarn 'You have selected USE="test". This will install the test results'
+ ewarn "into /usr/share/${PF}/, compressed as a tarball."
+ ewarn 'The tests themselves will only rarely die, but the test results'
+ ewarn 'are interesting for arch testing. The tests may take quite some'
+ ewarn 'time to complete.'
+ fi
+}
+
+src_compile() {
+ local target bin
+ append-flags -fno-strict-aliasing
+
+ for target in compiler tools/acpisrc tools/acpixtract tools/acpiexec
+ do
+ einfo "Compiling in ${target}/"
+ cd "${S}"/${target}
+ case "${target}" in
+ compiler) bin=iasl;;
+ *) bin=${target#*/};;
+ esac
+
+ emake -j1 CC="$(tc-getCC)" || die "emake in ${target} failed"
+ einfo "Finished compiling ${target}"
+
+ mv ${bin} "${T}" || die "mv ${bin} failed"
+ einfo "Finished moving ${bin}"
+
+ make clean || die "make clean in ${target} failed"
+ einfo "Finished cleaning ${target}"
+
+ echo ${bin} >>"${T}"/binlist
+ done
+ einfo "$(<"${T}"/binlist)"
+}
+
+src_test() {
+ aslts_test
+ #aapits_test
+ #The aapits test currently fails, missing include probably.
+}
+
+src_install() {
+ local bin
+ for bin in $(<"${T}"/binlist) ; do
+ dobin "${T}"/${bin}
+ done
+ dodoc README changes.txt
+ if hasq test $FEATURES ; then
+ export ASLTSDIR="$(<"${T}"/asltdir)"
+ cd "${ASLTSDIR}"/tmp/RESULTS || die "cd ${ASLTSDIR}/tmp/RESULTS failed"
+ ebegin "Creating Test Tarball"
+ tar -cjf testresults.tar.bz2 * || die "tar failed"
+ eend $?
+ dodir /usr/share/${PF}
+ insinto /usr/share/${PF}
+ doins testresults.tar.bz2 || die "doins testresults.tar.bz2 failed"
+ fi
+
+}
+
+aslts_test() {
+ export ASL="${T}"/iasl \
+ acpiexec="${T}"/acpiexec \
+ ASLTSDIR="${WORKDIR}/${MY_TESTS_P}"/tests/aslts
+ export PATH="${PATH}:${ASLTSDIR}/bin"
+ echo "$ASLTSDIR" >"${T}"/asltdir
+ cd "${ASLTSDIR}"
+ edos2unix $(find . -type 'f') || die "edos2unix failed in aslts"
+ make install || die "make install aslts test failed"
+ chmod +x $(find bin/ | sed -r -e '/\/[A-Z_]+$/d') || die "chmod bin +x failed"
+
+ #The below Do commands runs the tests twice and then dies if the results aren't
+ #Identical.
+ Do 1 || die "failed Do 1"
+ Do 2 || die "failed Do 2"
+}
+
+aapits_test() {
+ mv "${WORKDIR}/${MY_TESTS_P}/tests/aapits" "${S}/tools/" || die "mv failed"
+ cd "${S}/tools/aapits" || die "cannot find ${S}/tools/aapits"
+ edos2unix $(find . -type 'f') || die "edos2unix failed in aapits"
+ chmod +x $(find bin/ | sed -r -e '/\/[A-Z_]+$/d') || die "chmod bin +x failed"
+ make || die "make in aapits failed"
+ cd asl || die "cd asl failed"
+ make || die "make in asl failed"
+ cd ../bin
+ ./aapitsrun || die "aapitsrun failed"
+}