summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2009-10-16 13:22:12 +0000
committerThilo Bangert <bangert@gentoo.org>2009-10-16 13:22:12 +0000
commit26258d74f043c6201d1e907c23dd39738ac302cc (patch)
treeb7851866a2014470ac59daa642746781e8437c27 /sys-power
parentAdd patches for latest fbsd sec. advisory and errata. (diff)
downloadgentoo-2-26258d74f043c6201d1e907c23dd39738ac302cc.tar.gz
gentoo-2-26258d74f043c6201d1e907c23dd39738ac302cc.tar.bz2
gentoo-2-26258d74f043c6201d1e907c23dd39738ac302cc.zip
fix dep on lm_sensors (<3) bug #244588
(Portage version: 2.2_rc42/cvs/Linux i686)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/cpufreqd/ChangeLog8
-rw-r--r--sys-power/cpufreqd/cpufreqd-2.1.1.ebuild12
-rw-r--r--sys-power/cpufreqd/cpufreqd-2.2.0-r2.ebuild6
-rw-r--r--sys-power/cpufreqd/cpufreqd-2.2.1.ebuild6
4 files changed, 18 insertions, 14 deletions
diff --git a/sys-power/cpufreqd/ChangeLog b/sys-power/cpufreqd/ChangeLog
index a83a792db8f9..ac2f45f00795 100644
--- a/sys-power/cpufreqd/ChangeLog
+++ b/sys-power/cpufreqd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-power/cpufreqd
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufreqd/ChangeLog,v 1.52 2008/08/16 04:12:00 cardoe Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufreqd/ChangeLog,v 1.53 2009/10/16 13:22:12 bangert Exp $
+
+ 16 Oct 2009; Thilo Bangert <bangert@gentoo.org> cpufreqd-2.1.1.ebuild,
+ cpufreqd-2.2.0-r2.ebuild, cpufreqd-2.2.1.ebuild:
+ fix dep on lm_sensors (<3) bug #244588
16 Aug 2008; Doug Goldstein <cardoe@gentoo.org> metadata.xml:
add GLEP 56 USE flag desc from use.local.desc
diff --git a/sys-power/cpufreqd/cpufreqd-2.1.1.ebuild b/sys-power/cpufreqd/cpufreqd-2.1.1.ebuild
index d02ba9d2294f..1d3dfcb25d0d 100644
--- a/sys-power/cpufreqd/cpufreqd-2.1.1.ebuild
+++ b/sys-power/cpufreqd/cpufreqd-2.1.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufreqd/cpufreqd-2.1.1.ebuild,v 1.6 2006/11/13 10:20:12 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufreqd/cpufreqd-2.1.1.ebuild,v 1.7 2009/10/16 13:22:12 bangert Exp $
inherit eutils
@@ -17,17 +17,17 @@ KEYWORDS="amd64 ppc ~sparc x86"
IUSE="acpi apm lm_sensors nforce2 nvidia pmu"
RDEPEND=">=sys-power/cpufrequtils-002
- lm_sensors? ( sys-apps/lm_sensors )"
+ lm_sensors? ( <sys-apps/lm_sensors-3 )"
DEPEND="sys-apps/sed
${RDEPEND}"
src_unpack() {
unpack ${A}
- sed -i -e "s:acpi_event:acpi:" ${S}/cpufreqd.conf
+ sed -i -e "s:acpi_event:acpi:" "${S}"/cpufreqd.conf
if use nvidia; then
- cd ${WORKDIR}/nvclock${NVCLOCK_VERSION}
+ cd "${WORKDIR}"/nvclock${NVCLOCK_VERSION}
epatch "${FILESDIR}"/nvclock${NVCLOCK_VERSION}-fd.patch
epatch "${FILESDIR}"/nvclock${NVCLOCK_VERSION}-fpic.patch
fi
@@ -37,7 +37,7 @@ src_compile() {
local config
if use nvidia; then
- cd ${WORKDIR}/nvclock${NVCLOCK_VERSION}
+ cd "${WORKDIR}"/nvclock${NVCLOCK_VERSION}
econf \
--disable-gtk \
--disable-qt \
diff --git a/sys-power/cpufreqd/cpufreqd-2.2.0-r2.ebuild b/sys-power/cpufreqd/cpufreqd-2.2.0-r2.ebuild
index bfdece55882f..28c20ab36269 100644
--- a/sys-power/cpufreqd/cpufreqd-2.2.0-r2.ebuild
+++ b/sys-power/cpufreqd/cpufreqd-2.2.0-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufreqd/cpufreqd-2.2.0-r2.ebuild,v 1.3 2007/05/17 08:51:45 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufreqd/cpufreqd-2.2.0-r2.ebuild,v 1.4 2009/10/16 13:22:12 bangert Exp $
inherit eutils autotools
@@ -17,7 +17,7 @@ KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE="acpi apm lm_sensors nforce2 nvidia pmu"
RDEPEND=">=sys-power/cpufrequtils-002
- lm_sensors? ( sys-apps/lm_sensors )"
+ lm_sensors? ( <sys-apps/lm_sensors-3 )"
DEPEND="sys-apps/sed
${RDEPEND}"
diff --git a/sys-power/cpufreqd/cpufreqd-2.2.1.ebuild b/sys-power/cpufreqd/cpufreqd-2.2.1.ebuild
index 0004492e3c6d..4e7812085ab7 100644
--- a/sys-power/cpufreqd/cpufreqd-2.2.1.ebuild
+++ b/sys-power/cpufreqd/cpufreqd-2.2.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufreqd/cpufreqd-2.2.1.ebuild,v 1.5 2007/10/11 05:57:00 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufreqd/cpufreqd-2.2.1.ebuild,v 1.6 2009/10/16 13:22:12 bangert Exp $
inherit eutils autotools
@@ -17,7 +17,7 @@ KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="acpi apm lm_sensors nforce2 nvidia pmu"
RDEPEND=">=sys-power/cpufrequtils-002
- lm_sensors? ( sys-apps/lm_sensors )"
+ lm_sensors? ( <sys-apps/lm_sensors-3 )"
DEPEND="sys-apps/sed
${RDEPEND}"