summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-06-15 05:39:03 +0000
committerJeroen Roovers <jer@gentoo.org>2011-06-15 05:39:03 +0000
commitbfe45dedd09a83e0a06575e434156eabae55e91e (patch)
tree74c8c356c3b9fc949211f4f2c5923e63767e5ecd /sys-power
parentAdded ~x86-fbsd, bug #358079 (diff)
downloadgentoo-2-bfe45dedd09a83e0a06575e434156eabae55e91e.tar.gz
gentoo-2-bfe45dedd09a83e0a06575e434156eabae55e91e.tar.bz2
gentoo-2-bfe45dedd09a83e0a06575e434156eabae55e91e.zip
Version bump. Set RDEPEND.
(Portage version: 2.2.0_alpha41/cvs/Linux i686)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/athcool/ChangeLog10
-rw-r--r--sys-power/athcool/athcool-0.3.11-r1.ebuild5
-rw-r--r--sys-power/athcool/athcool-0.3.11-r2.ebuild5
-rw-r--r--sys-power/athcool/athcool-0.3.12.ebuild44
4 files changed, 58 insertions, 6 deletions
diff --git a/sys-power/athcool/ChangeLog b/sys-power/athcool/ChangeLog
index 80abcb5c0e98..b0c89ffda9a7 100644
--- a/sys-power/athcool/ChangeLog
+++ b/sys-power/athcool/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-power/athcool
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/athcool/ChangeLog,v 1.8 2010/05/25 15:45:13 jer Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/athcool/ChangeLog,v 1.9 2011/06/15 05:39:03 jer Exp $
+
+*athcool-0.3.12 (15 Jun 2011)
+
+ 15 Jun 2011; Jeroen Roovers <jer@gentoo.org> athcool-0.3.11-r1.ebuild,
+ athcool-0.3.11-r2.ebuild, +athcool-0.3.12.ebuild:
+ Version bump. Set RDEPEND.
*athcool-0.3.11-r2 (25 May 2010)
diff --git a/sys-power/athcool/athcool-0.3.11-r1.ebuild b/sys-power/athcool/athcool-0.3.11-r1.ebuild
index 4ba3d972433c..813c57b1456d 100644
--- a/sys-power/athcool/athcool-0.3.11-r1.ebuild
+++ b/sys-power/athcool/athcool-0.3.11-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/athcool/athcool-0.3.11-r1.ebuild,v 1.3 2008/11/27 21:24:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/athcool/athcool-0.3.11-r1.ebuild,v 1.4 2011/06/15 05:39:03 jer Exp $
inherit eutils
@@ -14,6 +14,7 @@ KEYWORDS="-* x86"
IUSE=""
DEPEND="sys-apps/pciutils"
+RDEPEND=""
src_unpack() {
unpack ${A}
diff --git a/sys-power/athcool/athcool-0.3.11-r2.ebuild b/sys-power/athcool/athcool-0.3.11-r2.ebuild
index 9d57b56fefeb..a3713d429892 100644
--- a/sys-power/athcool/athcool-0.3.11-r2.ebuild
+++ b/sys-power/athcool/athcool-0.3.11-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/athcool/athcool-0.3.11-r2.ebuild,v 1.1 2010/05/25 15:45:13 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/athcool/athcool-0.3.11-r2.ebuild,v 1.2 2011/06/15 05:39:03 jer Exp $
inherit eutils toolchain-funcs
@@ -14,6 +14,7 @@ KEYWORDS="-* ~x86"
IUSE=""
DEPEND="sys-apps/pciutils"
+RDEPEND=""
pkg_setup() {
tc-export CC
diff --git a/sys-power/athcool/athcool-0.3.12.ebuild b/sys-power/athcool/athcool-0.3.12.ebuild
new file mode 100644
index 000000000000..c8f58f806efe
--- /dev/null
+++ b/sys-power/athcool/athcool-0.3.12.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/athcool/athcool-0.3.12.ebuild,v 1.1 2011/06/15 05:39:03 jer Exp $
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="small utility to toggle Powersaving mode for AMD Athlon/Duron processors"
+HOMEPAGE="http://members.jcom.home.ne.jp/jacobi/linux/softwares.html#athcool"
+SRC_URI="http://members.jcom.home.ne.jp/jacobi/linux/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~x86"
+IUSE=""
+
+DEPEND="sys-apps/pciutils"
+RDEPEND=""
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.3.11-build.patch
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ doinitd "${FILESDIR}"/athcool
+ dodoc README ChangeLog
+}
+
+pkg_postinst() {
+ ewarn "WARNING: Depending on your motherboard and/or hardware components,"
+ ewarn "enabling powersaving mode may cause:"
+ ewarn " * noisy or distorted sound playback"
+ ewarn " * a slowdown in harddisk performance"
+ ewarn " * system locks or unpredictable behavior"
+ ewarn " * file system corruption"
+ ewarn "If you met those problems, you should not use athcool. Please use"
+ ewarn "athcool AT YOUR OWN RISK!"
+}