summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-08-04 17:01:47 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-08-04 17:01:47 +0000
commitdee49a142a908316bf58c4bc855cdb2b80aea91e (patch)
tree51e82a842b0f2b8388913a3b9baf3cd7bb6d6f66 /sys-power
parentRevision bump to ensure that users update to the new tarballs, which install ... (diff)
downloadgentoo-2-dee49a142a908316bf58c4bc855cdb2b80aea91e.tar.gz
gentoo-2-dee49a142a908316bf58c4bc855cdb2b80aea91e.tar.bz2
gentoo-2-dee49a142a908316bf58c4bc855cdb2b80aea91e.zip
Version bump. Install systemd unit file wrt #375269 by Michał Górny. Remove deprecated --oknodo from initd script wrt #377761. Remove support for sys-apps/hal and drop "before hald" from initd script.
(Portage version: 2.2.0_alpha47/cvs/Linux x86_64)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/acpid/ChangeLog10
-rw-r--r--sys-power/acpid/acpid-2.0.11.ebuild50
-rw-r--r--sys-power/acpid/files/acpid-2.0.11-init.d29
-rw-r--r--sys-power/acpid/files/acpid.service9
4 files changed, 97 insertions, 1 deletions
diff --git a/sys-power/acpid/ChangeLog b/sys-power/acpid/ChangeLog
index 810f13c179f0..03e75572c9c2 100644
--- a/sys-power/acpid/ChangeLog
+++ b/sys-power/acpid/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-power/acpid
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/ChangeLog,v 1.65 2011/06/12 14:31:34 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/ChangeLog,v 1.66 2011/08/04 17:01:47 ssuominen Exp $
+
+*acpid-2.0.11 (04 Aug 2011)
+
+ 04 Aug 2011; Samuli Suominen <ssuominen@gentoo.org> +acpid-2.0.11.ebuild,
+ +files/acpid-2.0.11-init.d, +files/acpid.service:
+ Version bump. Install systemd unit file wrt #375269 by Michał Górny. Remove
+ deprecated --oknodo from initd script wrt #377761. Remove support for
+ sys-apps/hal and drop "before hald" from initd script.
12 Jun 2011; Raúl Porcel <armin76@gentoo.org> acpid-2.0.9.ebuild:
ia64 stable wrt #368233
diff --git a/sys-power/acpid/acpid-2.0.11.ebuild b/sys-power/acpid/acpid-2.0.11.ebuild
new file mode 100644
index 000000000000..281fc1e2640a
--- /dev/null
+++ b/sys-power/acpid/acpid-2.0.11.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/acpid-2.0.11.ebuild,v 1.1 2011/08/04 17:01:47 ssuominen Exp $
+
+EAPI=4
+inherit eutils systemd toolchain-funcs
+
+DESCRIPTION="Daemon for Advanced Configuration and Power Interface"
+HOMEPAGE="http://tedfelix.com/linux/acpid-netlink.html"
+SRC_URI="http://tedfelix.com/linux/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 -ppc ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.0.3.patch
+}
+
+src_compile() {
+ tc-export CC CPP
+ emake
+ emake -C kacpimon
+}
+
+src_install() {
+ emake DESTDIR="${D}" DOCDIR=/usr/share/doc/${PF} install
+
+ dobin kacpimon/kacpimon
+ newdoc kacpimon/README README.kacpimon
+
+ exeinto /etc/acpi
+ newexe "${FILESDIR}"/${PN}-1.0.6-default.sh default.sh
+ insinto /etc/acpi/events
+ newins "${FILESDIR}"/${PN}-1.0.4-default default
+
+ newinitd "${FILESDIR}"/${PN}-2.0.11-init.d acpid
+ newconfd "${FILESDIR}"/${PN}-1.0.6-conf.d acpid
+
+ systemd_dounit "${FILESDIR}"/${PN}.service
+}
+
+pkg_postinst() {
+ elog
+ elog "You may wish to read the Gentoo Linux Power Management Guide,"
+ elog "which can be found online at:"
+ elog "http://www.gentoo.org/doc/en/power-management-guide.xml"
+ elog
+}
diff --git a/sys-power/acpid/files/acpid-2.0.11-init.d b/sys-power/acpid/files/acpid-2.0.11-init.d
new file mode 100644
index 000000000000..1f2c68e3c9c5
--- /dev/null
+++ b/sys-power/acpid/files/acpid-2.0.11-init.d
@@ -0,0 +1,29 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/files/acpid-2.0.11-init.d,v 1.1 2011/08/04 17:01:47 ssuominen Exp $
+
+opts="reload"
+
+depend() {
+ need localmount
+ use logger
+}
+
+start() {
+ ebegin "Starting acpid"
+ start-stop-daemon --start --quiet --exec /usr/sbin/acpid -- ${ACPID_OPTIONS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping acpid"
+ start-stop-daemon --stop --exec /usr/sbin/acpid
+ eend $?
+}
+
+reload() {
+ ebegin "Reloading acpid configuration"
+ start-stop-daemon --stop --exec /usr/sbin/acpid --signal HUP
+ eend $?
+}
diff --git a/sys-power/acpid/files/acpid.service b/sys-power/acpid/files/acpid.service
new file mode 100644
index 000000000000..4e224ebe62e8
--- /dev/null
+++ b/sys-power/acpid/files/acpid.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=ACPI Event Daemon
+After=syslog.target
+
+[Service]
+ExecStart=/usr/sbin/acpid -f
+
+[Install]
+WantedBy=multi-user.target