summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-15 21:15:50 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-15 21:15:50 +0000
commit8672c01e64ebd2c38549ff9c61b88fe85c0e7446 (patch)
tree2ee66321e18cfac02d80004eb026cfe126c3a83e /sys-process/audit/files
parentFix calls to python_mod_optimize() and python_mod_cleanup() (bug #316965). (diff)
downloadgentoo-2-8672c01e64ebd2c38549ff9c61b88fe85c0e7446.tar.gz
gentoo-2-8672c01e64ebd2c38549ff9c61b88fe85c0e7446.tar.bz2
gentoo-2-8672c01e64ebd2c38549ff9c61b88fe85c0e7446.zip
Update EAPI, fix dependencies, use Python 2, don't install .a, .la and .pyc files in Python site-packages directories, fix calls to python_mod_optimize() and python_mod_cleanup() (bug #316965).
(Portage version: 2.2_rc96_p20/cvs/Linux x86_64)
Diffstat (limited to 'sys-process/audit/files')
-rw-r--r--sys-process/audit/files/audit-1.7.17-python.patch12
-rw-r--r--sys-process/audit/files/audit-1.7.4-python.patch12
2 files changed, 24 insertions, 0 deletions
diff --git a/sys-process/audit/files/audit-1.7.17-python.patch b/sys-process/audit/files/audit-1.7.17-python.patch
new file mode 100644
index 000000000000..13fed4a803f8
--- /dev/null
+++ b/sys-process/audit/files/audit-1.7.17-python.patch
@@ -0,0 +1,12 @@
+--- swig/Makefile.am
++++ swig/Makefile.am
+@@ -28,7 +28,8 @@
+ pyexec_PYTHON = audit.py
+ pyexec_LTLIBRARIES = _audit.la
+ pyexec_SOLIBRARIES = _audit.so
+-_audit_la_LDFLAGS = -module -avoid-version
++_audit_la_CFLAGS = -shared
++_audit_la_LDFLAGS = -module -avoid-version -shared
+ _audit_la_HEADERS: $(top_builddir)/config.h
+ _audit_la_DEPENDENCIES =${top_srcdir}/lib/libaudit.h ${top_builddir}/lib/libaudit.la
+ nodist__audit_la_SOURCES = audit_wrap.c
diff --git a/sys-process/audit/files/audit-1.7.4-python.patch b/sys-process/audit/files/audit-1.7.4-python.patch
new file mode 100644
index 000000000000..32fca2ab1e4c
--- /dev/null
+++ b/sys-process/audit/files/audit-1.7.4-python.patch
@@ -0,0 +1,12 @@
+--- swig/Makefile.am
++++ swig/Makefile.am
+@@ -27,7 +27,8 @@
+ LIBS = $(top_builddir)/lib/libaudit.la
+ python_PYTHON = audit.py
+ pyexec_LTLIBRARIES = _audit.la
+-_audit_la_LDFLAGS = -module -avoid-version
++_audit_la_CFLAGS = -shared
++_audit_la_LDFLAGS = -module -avoid-version -shared
+ _audit_la_HEADERS: $(top_builddir)/config.h
+ _audit_la_DEPENDENCIES =${top_srcdir}/lib/libaudit.h ${top_builddir}/lib/libaudit.la
+ nodist__audit_la_SOURCES = audit_wrap.c