summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-04-13 19:34:15 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-04-13 19:34:15 +0000
commit274e1eeb2701b328b7aa026d6700c06f2c89f0a5 (patch)
tree24cb2954e19c641333a3af6fce6934f65ff43b10 /sys-process/pidof-bsd/pidof-bsd-20050501-r2.ebuild
parentChanged 3.3.11a to use klibc 1.2.1 instead of 1.1.16, which should resolve bu... (diff)
downloadgentoo-2-274e1eeb2701b328b7aa026d6700c06f2c89f0a5.tar.gz
gentoo-2-274e1eeb2701b328b7aa026d6700c06f2c89f0a5.tar.bz2
gentoo-2-274e1eeb2701b328b7aa026d6700c06f2c89f0a5.zip
Add patch to check only first argument when using pidof -x, fixes rc-daemon.
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'sys-process/pidof-bsd/pidof-bsd-20050501-r2.ebuild')
-rw-r--r--sys-process/pidof-bsd/pidof-bsd-20050501-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-process/pidof-bsd/pidof-bsd-20050501-r2.ebuild b/sys-process/pidof-bsd/pidof-bsd-20050501-r2.ebuild
new file mode 100644
index 000000000000..87014a1aaf1b
--- /dev/null
+++ b/sys-process/pidof-bsd/pidof-bsd-20050501-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/pidof-bsd/pidof-bsd-20050501-r2.ebuild,v 1.1 2006/04/13 19:34:15 flameeyes Exp $
+
+inherit base bsdmk
+
+DESCRIPTION="pidof(1) utility for *BSD"
+HOMEPAGE="http://people.freebsd.org/~novel/pidof.html"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!sys-process/psmisc"
+
+S="${WORKDIR}/pidof"
+
+PATCHES="${FILESDIR}/${P}-gfbsd.patch
+ ${FILESDIR}/${P}-firstarg.patch"
+
+src_install() {
+ into /
+ dobin pidof
+}
+