summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-08-31 07:37:55 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-08-31 07:37:55 +0000
commit1516a19db9424b019733b5d4287c1fca931af26c (patch)
treea47f7fbea57f90d650ce3d8c3922d211e8ab4522 /sys-process
parentUpstream patch for fuser to work with unix sockets wrt #398811. Thanks to Pio... (diff)
downloadgentoo-2-1516a19db9424b019733b5d4287c1fca931af26c.tar.gz
gentoo-2-1516a19db9424b019733b5d4287c1fca931af26c.tar.bz2
gentoo-2-1516a19db9424b019733b5d4287c1fca931af26c.zip
old
(Portage version: 2.2.0_alpha122/cvs/Linux x86_64)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/psmisc/ChangeLog7
-rw-r--r--sys-process/psmisc/files/psmisc-22.13-no-nls.patch32
-rw-r--r--sys-process/psmisc/psmisc-22.14.ebuild55
-rw-r--r--sys-process/psmisc/psmisc-22.18.ebuild50
-rw-r--r--sys-process/psmisc/psmisc-22.19.ebuild50
5 files changed, 6 insertions, 188 deletions
diff --git a/sys-process/psmisc/ChangeLog b/sys-process/psmisc/ChangeLog
index 59f622da636e..b5d40e5034b0 100644
--- a/sys-process/psmisc/ChangeLog
+++ b/sys-process/psmisc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-process/psmisc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/psmisc/ChangeLog,v 1.137 2012/08/31 07:35:39 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/psmisc/ChangeLog,v 1.138 2012/08/31 07:37:55 ssuominen Exp $
+
+ 31 Aug 2012; Samuli Suominen <ssuominen@gentoo.org>
+ -files/psmisc-22.13-no-nls.patch, -psmisc-22.14.ebuild, -psmisc-22.18.ebuild,
+ -psmisc-22.19.ebuild:
+ old
*psmisc-22.19-r1 (31 Aug 2012)
diff --git a/sys-process/psmisc/files/psmisc-22.13-no-nls.patch b/sys-process/psmisc/files/psmisc-22.13-no-nls.patch
deleted file mode 100644
index d18b36af3f6c..000000000000
--- a/sys-process/psmisc/files/psmisc-22.13-no-nls.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-http://bugs.gentoo.org/193920
-
---- configure.ac
-+++ configure.ac
-@@ -57,10 +57,6 @@
- AC_CHECK_MEMBERS([struct stat.st_rdev])
- AC_TYPE_UID_T
-
--dnl Check for language stuff
--AM_GNU_GETTEXT([external])
--AM_GNU_GETTEXT_VERSION([0.16.1])
--
- dnl Must be after the gettext stuff as it sets build_cpu
- AC_CHECK_MEMBERS([struct user_regs_struct.orig_eax,
- struct user_regs_struct.eax,
-@@ -120,6 +116,5 @@
- AC_CONFIG_FILES([Makefile
- doc/Makefile
- src/Makefile
-- icons/Makefile
-- po/Makefile.in])
-+ icons/Makefile])
- AC_OUTPUT
---- Makefile.am
-+++ Makefile.am
-@@ -1,5 +1,5 @@
-
--SUBDIRS = doc src po icons
-+SUBDIRS = doc src icons
-
- #EXTRA_DIST = config.rpath ABOUT-NLS mkinstalldirs
-
diff --git a/sys-process/psmisc/psmisc-22.14.ebuild b/sys-process/psmisc/psmisc-22.14.ebuild
deleted file mode 100644
index d049ba2b9891..000000000000
--- a/sys-process/psmisc/psmisc-22.14.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/psmisc/psmisc-22.14.ebuild,v 1.6 2012/01/26 13:29:35 ssuominen Exp $
-
-EAPI=3
-inherit autotools eutils
-
-DESCRIPTION="A set of tools that use the proc filesystem"
-HOMEPAGE="http://psmisc.sourceforge.net/"
-SRC_URI="mirror://sourceforge/psmisc/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~ia64-linux ~x86-linux"
-IUSE="ipv6 nls selinux X"
-
-RDEPEND=">=sys-libs/ncurses-5.2-r2
- selinux? ( sys-libs/libselinux )"
-DEPEND="${RDEPEND}
- sys-devel/libtool
- nls? ( sys-devel/gettext )"
-
-src_prepare() {
- use nls || epatch "${FILESDIR}"/${PN}-22.13-no-nls.patch
- eautoreconf
-}
-
-src_configure() {
- # the nls looks weird, but it's because we actually delete the nls stuff
- # above when USE=-nls. this should get cleaned up so we dont have to patch
- # it out, but until then, let's not confuse users ... #220787
- econf \
- --disable-dependency-tracking \
- $(use_enable selinux) \
- $(use_enable ipv6) \
- $(use nls && use_enable nls)
-}
-
-src_compile() {
- # peekfd is a fragile crap hack #330631
- emake -C src peekfd || touch src/peekfd{.o,}
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog NEWS README
- [[ -s ${D}/usr/bin/peekfd ]] || rm -f "${D}"/usr/bin/peekfd
- use X || rm "${ED}"/usr/bin/pstree.x11
- # fuser is needed by init.d scripts
- dodir /bin
- mv "${ED}"/usr/bin/fuser "${ED}"/bin/ || die
- # easier to do this than forcing regen of autotools
- [[ -e ${ED}/usr/bin/peekfd ]] || rm -f "${ED}"/usr/share/man/man1/peekfd.1
-}
diff --git a/sys-process/psmisc/psmisc-22.18.ebuild b/sys-process/psmisc/psmisc-22.18.ebuild
deleted file mode 100644
index d810b2c9f0ea..000000000000
--- a/sys-process/psmisc/psmisc-22.18.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/psmisc/psmisc-22.18.ebuild,v 1.2 2012/08/25 22:33:18 vapier Exp $
-
-EAPI=4
-
-DESCRIPTION="A set of tools that use the proc filesystem"
-HOMEPAGE="http://psmisc.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux"
-IUSE="ipv6 nls selinux X"
-
-RDEPEND=">=sys-libs/ncurses-5.7-r7
- nls? ( virtual/libintl )
- selinux? ( sys-libs/libselinux )"
-DEPEND="${RDEPEND}
- >=sys-devel/libtool-2.2.6b
- nls? ( sys-devel/gettext )"
-
-DOCS="AUTHORS ChangeLog NEWS README"
-
-src_configure() {
- econf \
- $(use_enable selinux) \
- --disable-harden-flags \
- $(use_enable ipv6) \
- $(use_enable nls)
-}
-
-src_compile() {
- # peekfd is a fragile crap hack #330631
- nonfatal emake -C src peekfd || touch src/peekfd{.o,}
- emake
-}
-
-src_install() {
- default
-
- use X || rm -f "${ED}"/usr/bin/pstree.x11
-
- [[ -s ${ED}/usr/bin/peekfd ]] || rm -f "${ED}"/usr/bin/peekfd
- [[ -e ${ED}/usr/bin/peekfd ]] || rm -f "${ED}"/usr/share/man/man1/peekfd.1
-
- # fuser is needed by init.d scripts
- dodir /bin
- mv "${ED}"/usr/bin/fuser "${ED}"/bin || die
-}
diff --git a/sys-process/psmisc/psmisc-22.19.ebuild b/sys-process/psmisc/psmisc-22.19.ebuild
deleted file mode 100644
index 90cff6b0a87a..000000000000
--- a/sys-process/psmisc/psmisc-22.19.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/psmisc/psmisc-22.19.ebuild,v 1.2 2012/08/25 22:33:18 vapier Exp $
-
-EAPI=4
-
-DESCRIPTION="A set of tools that use the proc filesystem"
-HOMEPAGE="http://psmisc.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux"
-IUSE="ipv6 nls selinux X"
-
-RDEPEND=">=sys-libs/ncurses-5.7-r7
- nls? ( virtual/libintl )
- selinux? ( sys-libs/libselinux )"
-DEPEND="${RDEPEND}
- >=sys-devel/libtool-2.2.6b
- nls? ( sys-devel/gettext )"
-
-DOCS="AUTHORS ChangeLog NEWS README"
-
-src_configure() {
- econf \
- $(use_enable selinux) \
- --disable-harden-flags \
- $(use_enable ipv6) \
- $(use_enable nls)
-}
-
-src_compile() {
- # peekfd is a fragile crap hack #330631
- nonfatal emake -C src peekfd || touch src/peekfd{.o,}
- emake
-}
-
-src_install() {
- default
-
- use X || rm -f "${ED}"/usr/bin/pstree.x11
-
- [[ -s ${ED}/usr/bin/peekfd ]] || rm -f "${ED}"/usr/bin/peekfd
- [[ -e ${ED}/usr/bin/peekfd ]] || rm -f "${ED}"/usr/share/man/man1/peekfd.1
-
- # fuser is needed by init.d scripts
- dodir /bin
- mv "${ED}"/usr/bin/fuser "${ED}"/bin || die
-}