summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-01-24 05:54:28 +0000
committerMike Frysinger <vapier@gentoo.org>2008-01-24 05:54:28 +0000
commit36dae629e89199c6bf5dd73ba57eaba456ce31f3 (patch)
tree43c1dca8556485448f1336ce4cc7ce547645001b /sys-process
parentold (diff)
downloadgentoo-2-36dae629e89199c6bf5dd73ba57eaba456ce31f3.tar.gz
gentoo-2-36dae629e89199c6bf5dd73ba57eaba456ce31f3.tar.bz2
gentoo-2-36dae629e89199c6bf5dd73ba57eaba456ce31f3.zip
Version bump.
(Portage version: 2.1.4)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/latencytop/ChangeLog7
-rw-r--r--sys-process/latencytop/files/digest-latencytop-0.33
-rw-r--r--sys-process/latencytop/latencytop-0.3.ebuild45
3 files changed, 54 insertions, 1 deletions
diff --git a/sys-process/latencytop/ChangeLog b/sys-process/latencytop/ChangeLog
index 590f540d84a6..2b8470218ad9 100644
--- a/sys-process/latencytop/ChangeLog
+++ b/sys-process/latencytop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-process/latencytop
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/latencytop/ChangeLog,v 1.1 2008/01/19 21:24:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/latencytop/ChangeLog,v 1.2 2008/01/24 05:54:28 vapier Exp $
+
+*latencytop-0.3 (24 Jan 2008)
+
+ 24 Jan 2008; Mike Frysinger <vapier@gentoo.org> +latencytop-0.3.ebuild:
+ Version bump.
*latencytop-0.1 (19 Jan 2008)
diff --git a/sys-process/latencytop/files/digest-latencytop-0.3 b/sys-process/latencytop/files/digest-latencytop-0.3
new file mode 100644
index 000000000000..98d5748d9c93
--- /dev/null
+++ b/sys-process/latencytop/files/digest-latencytop-0.3
@@ -0,0 +1,3 @@
+MD5 3ed2878fb7772e2a500ec71aa01abbb2 latencytop-0.3.tar.gz 7800
+RMD160 2b18bd0f99605cc8adebe642f15f75e4a9eb9f2b latencytop-0.3.tar.gz 7800
+SHA256 76a1e9e243aea869979024c0267563c115d82de92b0b379a769e3edf92397929 latencytop-0.3.tar.gz 7800
diff --git a/sys-process/latencytop/latencytop-0.3.ebuild b/sys-process/latencytop/latencytop-0.3.ebuild
new file mode 100644
index 000000000000..6ced093e185c
--- /dev/null
+++ b/sys-process/latencytop/latencytop-0.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/latencytop/latencytop-0.3.ebuild,v 1.1 2008/01/24 05:54:28 vapier Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="tool for identifying where in the system latency is happening"
+HOMEPAGE="http://www.latencytop.org/"
+SRC_URI="http://www.latencytop.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="unicode"
+
+RDEPEND="=dev-libs/glib-2*
+ sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i 's:latencytop.trans:/usr/share/misc/latencytop.trans:' latencytop.c || die
+}
+
+src_compile() {
+ # this sucks, but makefile is worse (for now)
+ use_echo() { use $1 && echo $2 || echo $3 ; }
+ echoit() { echo "$@" ; "$@" ; }
+ echoit \
+ $(tc-getCC) \
+ ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} \
+ $(pkg-config glib-2.0 --cflags) \
+ *.c -o latencytop \
+ $(pkg-config glib-2.0 --libs) \
+ $(use_echo unicode -lncursesw -lncurses) \
+ || die
+}
+
+src_install() {
+ dosbin latencytop || die
+ insinto /usr/share/misc
+ doins latencytop.trans || die
+}