summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2015-02-20 02:47:47 +0000
committerChristoph Junghans <ottxor@gentoo.org>2015-02-20 02:47:47 +0000
commit72967712ff60443ad96e36175742b0f2f7fb0026 (patch)
tree15e89cae3c02ed1f35a5060da2848a847abe8cb4 /sys-process
parentUse wiki for HOMEPAGE #534468 by Alex Legler. (diff)
downloadgentoo-2-72967712ff60443ad96e36175742b0f2f7fb0026.tar.gz
gentoo-2-72967712ff60443ad96e36175742b0f2f7fb0026.tar.bz2
gentoo-2-72967712ff60443ad96e36175742b0f2f7fb0026.zip
added multilib support (bug #540034)
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/numactl/ChangeLog9
-rw-r--r--sys-process/numactl/numactl-2.0.10-r1.ebuild49
2 files changed, 56 insertions, 2 deletions
diff --git a/sys-process/numactl/ChangeLog b/sys-process/numactl/ChangeLog
index 49d8de51be2a..093a30a877ca 100644
--- a/sys-process/numactl/ChangeLog
+++ b/sys-process/numactl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-process/numactl
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/numactl/ChangeLog,v 1.38 2014/11/12 14:56:05 jlec Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/numactl/ChangeLog,v 1.39 2015/02/20 02:47:47 ottxor Exp $
+
+*numactl-2.0.10-r1 (20 Feb 2015)
+
+ 20 Feb 2015; Christoph Junghans <ottxor@gentoo.org> +numactl-2.0.10-r1.ebuild:
+ added multilib support (bug #540034)
12 Nov 2014; Justin Lecher <jlec@gentoo.org> numactl-2.0.10.ebuild,
metadata.xml:
diff --git a/sys-process/numactl/numactl-2.0.10-r1.ebuild b/sys-process/numactl/numactl-2.0.10-r1.ebuild
new file mode 100644
index 000000000000..251e08eca8a5
--- /dev/null
+++ b/sys-process/numactl/numactl-2.0.10-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/numactl/numactl-2.0.10-r1.ebuild,v 1.1 2015/02/20 02:47:47 ottxor Exp $
+
+EAPI=5
+
+inherit autotools eutils toolchain-funcs multilib-minimal
+
+DESCRIPTION="Utilities and libraries for NUMA systems"
+HOMEPAGE="http://oss.sgi.com/projects/libnuma/"
+SRC_URI="ftp://oss.sgi.com/www/projects/libnuma/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+# ARM lacks the __NR_migrate_pages syscall.
+KEYWORDS="~amd64 -arm ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux"
+IUSE=""
+
+ECONF_SOURCE=${S}
+
+src_prepare() {
+ eautoreconf
+ epatch "${FILESDIR}"/${PN}-2.0.8-cpuid-pic.patch #456238
+}
+
+src_test() {
+ if [ -d /sys/devices/system/node ]; then
+ einfo "The only generically safe test is regress2."
+ einfo "The other test cases require 2 NUMA nodes."
+ emake regress2
+ else
+ ewarn "You do not have baseline NUMA support in your kernel, skipping tests."
+ fi
+}
+
+multilib_src_compile() {
+ multilib_is_native_abi && default || emake libnuma.la
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install$(multilib_is_native_abi || echo "-libLTLIBRARIES install-includeHEADERS")
+}
+
+multilib_src_install_all() {
+ DOCS=( README TODO CHANGES DESIGN )
+ einstalldocs
+ # delete man pages provided by the man-pages package #238805
+ rm -r "${ED}"/usr/share/man/man[25] || die
+}