summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2011-01-18 19:31:39 +0000
committerThilo Bangert <bangert@gentoo.org>2011-01-18 19:31:39 +0000
commit9dd433949a75bbfe9f61c362a19526863c8e6a0a (patch)
tree2d404ffb9f799a0175fc201ef1fb674a7bc53c26 /sys-process
parentVersion bump (diff)
downloadgentoo-2-9dd433949a75bbfe9f61c362a19526863c8e6a0a.tar.gz
gentoo-2-9dd433949a75bbfe9f61c362a19526863c8e6a0a.tar.bz2
gentoo-2-9dd433949a75bbfe9f61c362a19526863c8e6a0a.zip
version bump (#351901)
(Portage version: 2.2.0_alpha14/cvs/Linux i686)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/daemontools-encore/ChangeLog8
-rw-r--r--sys-process/daemontools-encore/daemontools-encore-1.04.ebuild51
2 files changed, 58 insertions, 1 deletions
diff --git a/sys-process/daemontools-encore/ChangeLog b/sys-process/daemontools-encore/ChangeLog
index dec0cbc0b7b6..bb566e2f0814 100644
--- a/sys-process/daemontools-encore/ChangeLog
+++ b/sys-process/daemontools-encore/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-process/daemontools-encore
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/daemontools-encore/ChangeLog,v 1.1 2011/01/05 12:32:39 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/daemontools-encore/ChangeLog,v 1.2 2011/01/18 19:31:39 bangert Exp $
+
+*daemontools-encore-1.04 (18 Jan 2011)
+
+ 18 Jan 2011; Thilo Bangert <bangert@gentoo.org>
+ +daemontools-encore-1.04.ebuild:
+ version bump (#351901)
*daemontools-encore-1.02 (05 Jan 2011)
diff --git a/sys-process/daemontools-encore/daemontools-encore-1.04.ebuild b/sys-process/daemontools-encore/daemontools-encore-1.04.ebuild
new file mode 100644
index 000000000000..6993bc86c172
--- /dev/null
+++ b/sys-process/daemontools-encore/daemontools-encore-1.04.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/daemontools-encore/daemontools-encore-1.04.ebuild,v 1.1 2011/01/18 19:31:39 bangert Exp $
+
+EAPI=3
+
+inherit eutils toolchain-funcs flag-o-matic qmail
+
+DESCRIPTION="Collection of tools for managing UNIX services"
+HOMEPAGE="http://untroubled.org/daemontools-encore/"
+SRC_URI="${HOMEPAGE}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="selinux static"
+
+DEPEND=""
+RDEPEND="selinux? ( sec-policy/selinux-daemontools )
+ !sys-process/daemontools
+ !app-doc/daemontools-man"
+
+src_compile() {
+ use static && append-ldflags -static
+ qmail_set_cc
+ emake || die
+}
+
+src_install() {
+ keepdir /service
+
+ echo ${D}/usr/bin >conf-bin
+ echo ${D}/usr/share/man >conf-man
+ dodir /usr/bin
+ dodir /usr/share/man
+ emake install || die
+
+ dodoc ChangeLog CHANGES CHANGES.djb README TODO
+
+ newinitd "${FILESDIR}"/svscan.init-1.02 svscan || die
+}
+
+pkg_postinst() {
+ einfo
+ einfo "You can run daemontools using the svscan init.d script,"
+ einfo "or you could run it through inittab."
+ einfo "To use inittab, emerge supervise-scripts and run:"
+ einfo "svscan-add-to-inittab"
+ einfo "Then you can hup init with the command telinit q"
+ einfo
+}