summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-01-28 19:22:59 +0000
committerLars Wendler <polynomial-c@gentoo.org>2015-01-28 19:22:59 +0000
commitc56b11af3a1cc44aae8d7a079248c6d953b5508c (patch)
tree17bfb6b14d417e3eeb6db05bbd37826013384e43 /sys-process
parentMask CPU_FLAGS_X86 for non-x86 arches. (diff)
downloadgentoo-2-c56b11af3a1cc44aae8d7a079248c6d953b5508c.tar.gz
gentoo-2-c56b11af3a1cc44aae8d7a079248c6d953b5508c.tar.bz2
gentoo-2-c56b11af3a1cc44aae8d7a079248c6d953b5508c.zip
Revbump to fix a typo in fuser which leads to -M option being enabled all the time. Committed straight to stable
(Portage version: 2.2.15/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/psmisc/ChangeLog9
-rw-r--r--sys-process/psmisc/files/psmisc-22.21-fuser_typo_fix.patch44
-rw-r--r--sys-process/psmisc/psmisc-22.21-r2.ebuild (renamed from sys-process/psmisc/psmisc-22.21-r1.ebuild)6
3 files changed, 57 insertions, 2 deletions
diff --git a/sys-process/psmisc/ChangeLog b/sys-process/psmisc/ChangeLog
index 3b78458cf9cb..9c7edae39b2d 100644
--- a/sys-process/psmisc/ChangeLog
+++ b/sys-process/psmisc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-process/psmisc
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/psmisc/ChangeLog,v 1.165 2015/01/22 11:05:02 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/psmisc/ChangeLog,v 1.166 2015/01/28 19:22:59 polynomial-c Exp $
+
+*psmisc-22.21-r2 (28 Jan 2015)
+
+ 28 Jan 2015; Lars Wendler <polynomial-c@gentoo.org> -psmisc-22.21-r1.ebuild,
+ +psmisc-22.21-r2.ebuild, +files/psmisc-22.21-fuser_typo_fix.patch:
+ Revbump to fix a typo in fuser which leads to -M option being enabled all the
+ time. Committed straight to stable.
*psmisc-22.21-r1 (22 Jan 2015)
diff --git a/sys-process/psmisc/files/psmisc-22.21-fuser_typo_fix.patch b/sys-process/psmisc/files/psmisc-22.21-fuser_typo_fix.patch
new file mode 100644
index 000000000000..5c5fd990f9ca
--- /dev/null
+++ b/sys-process/psmisc/files/psmisc-22.21-fuser_typo_fix.patch
@@ -0,0 +1,44 @@
+From 3638cc55b4d08851faba46635d737b24d016665b Mon Sep 17 00:00:00 2001
+From: Brad Jorsch <anomie@users.sourceforge.net>
+Date: Fri, 28 Feb 2014 21:55:02 +1100
+Subject: [PATCH] Typo in fuser makes -M on all the time
+
+Brad found that fuser had the -M option on all the time.
+A simple but significant typo caused this, thanks the the patch.
+
+Bug-Debian: http://bugs.debian.org/740275
+
+Signed-off-by: Craig Small <csmall@enc.com.au>
+---
+ ChangeLog | 4 ++++
+ src/fuser.c | 2 +-
+ 2 files changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/ChangeLog b/ChangeLog
+index fd1cccf..e5f784c 100644
+--- a/ChangeLog
++++ b/ChangeLog
+@@ -1,3 +1,7 @@
++Changes in 22.22
++================
++ * Fixed typo in fuser which has -M on Debian #740275
++
+ Changes in 22.21
+ ================
+ * Missing comma in fuser(1) added Debian #702391
+diff --git a/src/fuser.c b/src/fuser.c
+index b485f65..389b302 100644
+--- a/src/fuser.c
++++ b/src/fuser.c
+@@ -1174,7 +1174,7 @@ int main(int argc, char *argv[])
+ usage(_("No process specification given"));
+
+ /* Check if -M flag was used and if so check mounts */
+- if (opts * OPT_ISMOUNTPOINT) {
++ if (opts & OPT_ISMOUNTPOINT) {
+ check_mountpoints(&mounts, &names_head, &names_tail);
+ }
+
+--
+2.2.2
+
diff --git a/sys-process/psmisc/psmisc-22.21-r1.ebuild b/sys-process/psmisc/psmisc-22.21-r2.ebuild
index f061a1dcd6dc..6990ea7a15bc 100644
--- a/sys-process/psmisc/psmisc-22.21-r1.ebuild
+++ b/sys-process/psmisc/psmisc-22.21-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/psmisc/psmisc-22.21-r1.ebuild,v 1.1 2015/01/22 11:05:02 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/psmisc/psmisc-22.21-r2.ebuild,v 1.1 2015/01/28 19:22:59 polynomial-c Exp $
EAPI="4"
@@ -24,6 +24,10 @@ DEPEND="${RDEPEND}
DOCS="AUTHORS ChangeLog NEWS README"
+src_prepare() {
+ epatch "${FILESDIR}/${P}-fuser_typo_fix.patch"
+}
+
src_configure() {
econf \
$(use_enable selinux) \