summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2011-11-21 17:58:14 +0000
committerChristian Ruppert <idl0r@gentoo.org>2011-11-21 17:58:14 +0000
commitcdb79177ee9863f2c3f688f761fda5074a4c7859 (patch)
tree51f2c9bbb5c1a20c8a61195106d6308bd4bb45fb /sys-process
parentFix buildtime deps, bug #381585,381591 (diff)
downloadgentoo-2-cdb79177ee9863f2c3f688f761fda5074a4c7859.tar.gz
gentoo-2-cdb79177ee9863f2c3f688f761fda5074a4c7859.tar.bz2
gentoo-2-cdb79177ee9863f2c3f688f761fda5074a4c7859.zip
Version bump, bug 391211.
(Portage version: 2.2.0_alpha76/cvs/Linux x86_64)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/htop/ChangeLog7
-rw-r--r--sys-process/htop/htop-1.0.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/sys-process/htop/ChangeLog b/sys-process/htop/ChangeLog
index 0452f839e7d8..3935468ee3ff 100644
--- a/sys-process/htop/ChangeLog
+++ b/sys-process/htop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-process/htop
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/ChangeLog,v 1.101 2011/11/19 17:45:58 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/ChangeLog,v 1.102 2011/11/21 17:58:14 idl0r Exp $
+
+*htop-1.0 (21 Nov 2011)
+
+ 21 Nov 2011; Christian Ruppert <idl0r@gentoo.org> +htop-1.0.ebuild:
+ Version bump, bug 391211.
19 Nov 2011; Jeroen Roovers <jer@gentoo.org> htop-0.9-r2.ebuild:
Stable for HPPA (bug #390969).
diff --git a/sys-process/htop/htop-1.0.ebuild b/sys-process/htop/htop-1.0.ebuild
new file mode 100644
index 000000000000..ae0e5c98e2f2
--- /dev/null
+++ b/sys-process/htop/htop-1.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/htop-1.0.ebuild,v 1.1 2011/11/21 17:58:14 idl0r Exp $
+
+EAPI=4
+
+inherit autotools eutils flag-o-matic multilib
+
+DESCRIPTION="interactive process viewer"
+HOMEPAGE="http://htop.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+IUSE="debug elibc_FreeBSD kernel_linux openvz unicode vserver"
+
+RDEPEND="sys-libs/ncurses[unicode?]"
+DEPEND="${RDEPEND}"
+
+DOCS=( ChangeLog README )
+
+pkg_setup() {
+ if use elibc_FreeBSD && ! [[ -f ${ROOT}/proc/stat && -f ${ROOT}/proc/meminfo ]]; then
+ eerror
+ eerror "htop needs /proc mounted to compile and work, to mount it type"
+ eerror "mount -t linprocfs none /proc"
+ eerror "or uncomment the example in /etc/fstab"
+ eerror
+ die "htop needs /proc mounted"
+ fi
+
+ if ! has_version sys-process/lsof; then
+ ewarn "To use lsof features in htop(what processes are accessing"
+ ewarn "what files), you must have sys-process/lsof installed."
+ fi
+}
+
+src_prepare() {
+ sed -i -e '1c\#!'"${EPREFIX}"'/usr/bin/python' \
+ scripts/MakeHeader.py || die
+}
+
+src_configure() {
+ use debug && append-flags -DDEBUG
+
+ econf \
+ $(use_enable openvz) \
+ $(use_enable kernel_linux cgroup) \
+ $(use_enable vserver) \
+ $(use_enable unicode) \
+ --enable-taskstats
+}