summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2015-03-11 22:38:29 +0000
committerTim Harder <radhermit@gentoo.org>2015-03-11 22:38:29 +0000
commitf3208eb45b35da55ab02f5c7539b55c7b2af8bba (patch)
tree84ac14f1fd90058124f16fe42ec21d8d7f4c95a1 /sys-process
parentKeyword ~ppc, bug #473920. (diff)
downloadgentoo-2-f3208eb45b35da55ab02f5c7539b55c7b2af8bba.tar.gz
gentoo-2-f3208eb45b35da55ab02f5c7539b55c7b2af8bba.tar.bz2
gentoo-2-f3208eb45b35da55ab02f5c7539b55c7b2af8bba.zip
Add setproctitle use flag to fix automagic dep on dev-libs/libbsd (bug #540744).
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/criu/ChangeLog9
-rw-r--r--sys-process/criu/criu-1.5-r1.ebuild50
-rw-r--r--sys-process/criu/files/criu-1.5-automagic-libbsd.patch29
-rw-r--r--sys-process/criu/metadata.xml3
4 files changed, 90 insertions, 1 deletions
diff --git a/sys-process/criu/ChangeLog b/sys-process/criu/ChangeLog
index ea05c561697f..a7d1bdf7dec8 100644
--- a/sys-process/criu/ChangeLog
+++ b/sys-process/criu/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-process/criu
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/criu/ChangeLog,v 1.13 2015/03/11 22:03:38 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/criu/ChangeLog,v 1.14 2015/03/11 22:38:29 radhermit Exp $
+
+*criu-1.5-r1 (11 Mar 2015)
+
+ 11 Mar 2015; Tim Harder <radhermit@gentoo.org> +criu-1.5-r1.ebuild,
+ +files/criu-1.5-automagic-libbsd.patch, metadata.xml:
+ Add setproctitle use flag to fix automagic dep on dev-libs/libbsd (bug
+ #540744).
*criu-1.5 (11 Mar 2015)
diff --git a/sys-process/criu/criu-1.5-r1.ebuild b/sys-process/criu/criu-1.5-r1.ebuild
new file mode 100644
index 000000000000..50fc8327d21c
--- /dev/null
+++ b/sys-process/criu/criu-1.5-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/criu/criu-1.5-r1.ebuild,v 1.1 2015/03/11 22:38:29 radhermit Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs linux-info flag-o-matic
+
+DESCRIPTION="utility to checkpoint/restore a process tree"
+HOMEPAGE="http://criu.org/"
+SRC_URI="http://download.openvz.org/criu/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="setproctitle"
+
+RDEPEND="<dev-libs/protobuf-c-1.1.0
+ setproctitle? ( dev-libs/libbsd )"
+DEPEND="${RDEPEND}
+ app-text/asciidoc
+ app-text/xmlto"
+
+CONFIG_CHECK="~CHECKPOINT_RESTORE ~NAMESPACES ~PID_NS ~FHANDLE ~EVENTFD ~EPOLL ~INOTIFY_USER
+ ~IA32_EMULATION ~UNIX_DIAG ~INET_DIAG ~INET_UDP_DIAG ~PACKET_DIAG ~NETLINK_DIAG"
+
+RESTRICT="test"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.3.1-flags.patch
+ epatch "${FILESDIR}"/${PN}-1.3.1-makefile.patch
+ epatch "${FILESDIR}"/${P}-automagic-libbsd.patch
+}
+
+src_compile() {
+ unset ARCH
+ emake CC="$(tc-getCC)" LD="$(tc-getLD)" V=1 SETPROCTITLE=$(usex setproctitle) WERROR=0 all docs
+}
+
+src_test() {
+ # root privileges are required to dump all necessary info
+ if [[ ${EUID} -eq 0 ]] ; then
+ emake -j1 CC="$(tc-getCC)" V=1 WERROR=0 test
+ fi
+}
+
+src_install() {
+ emake SYSCONFDIR="${EPREFIX}"/etc PREFIX="${EPREFIX}"/usr DESTDIR="${D}" install
+ dodoc CREDITS README
+}
diff --git a/sys-process/criu/files/criu-1.5-automagic-libbsd.patch b/sys-process/criu/files/criu-1.5-automagic-libbsd.patch
new file mode 100644
index 000000000000..8f5e4b4e02d0
--- /dev/null
+++ b/sys-process/criu/files/criu-1.5-automagic-libbsd.patch
@@ -0,0 +1,29 @@
+Control libbsd dependency via SETPROCTITLE definition.
+
+--- criu-1.5/Makefile.config
++++ criu-1.5/Makefile.config
+@@ -3,10 +3,12 @@
+
+ CONFIG := include/config.h
+
++ifeq ($(SETPROCTITLE),yes)
+ ifeq ($(call try-cc,$(LIBBSD_DEV_TEST),-lbsd),y)
+ LIBS += -lbsd
+ DEFINES += -DCONFIG_HAS_LIBBSD
+ endif
++endif
+
+ $(CONFIG): scripts/utilities.mak scripts/feature-tests.mak include/config-base.h
+ $(E) " GEN " $@
+@@ -33,9 +35,11 @@
+ ifeq ($(VDSO),y)
+ $(Q) @echo '#define CONFIG_VDSO' >> $@
+ endif
++ifeq ($(SETPROCTITLE),yes)
+ ifeq ($(call try-cc,$(SETPROCTITLE_INIT_TEST),-lbsd),y)
+ $(Q) @echo '#define CONFIG_HAS_SETPROCTITLE_INIT' >> $@
+ endif
++endif
+ $(Q) @echo '#endif /* __CR_CONFIG_H__ */' >> $@
+
+ config: $(CONFIG)
diff --git a/sys-process/criu/metadata.xml b/sys-process/criu/metadata.xml
index efa5eb0078f3..39d397d2bb14 100644
--- a/sys-process/criu/metadata.xml
+++ b/sys-process/criu/metadata.xml
@@ -5,4 +5,7 @@
<email>radhermit@gentoo.org</email>
<name>Tim Harder</name>
</maintainer>
+ <use>
+ <flag name='setproctitle'>Make process titles of service workers to be more verbose</flag>
+ </use>
</pkgmetadata>