summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-01-10 16:16:01 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-01-10 16:16:01 +0000
commit5230ec38f19a84885525956ff36e602985b275ec (patch)
tree756d0cfca28dd99d32af41d0bbffebdc2612d679 /www-apache/anyterm
parentwhitespace (diff)
downloadgentoo-2-5230ec38f19a84885525956ff36e602985b275ec.tar.gz
gentoo-2-5230ec38f19a84885525956ff36e602985b275ec.tar.bz2
gentoo-2-5230ec38f19a84885525956ff36e602985b275ec.zip
version bump, #203928
(Portage version: 2.1.4_rc11)
Diffstat (limited to 'www-apache/anyterm')
-rw-r--r--www-apache/anyterm/ChangeLog8
-rw-r--r--www-apache/anyterm/anyterm-1.1.16.ebuild90
-rw-r--r--www-apache/anyterm/files/50_anyterm.conf11
-rw-r--r--www-apache/anyterm/files/digest-anyterm-1.1.163
4 files changed, 103 insertions, 9 deletions
diff --git a/www-apache/anyterm/ChangeLog b/www-apache/anyterm/ChangeLog
index 77c826ce397b..2f73c06739fb 100644
--- a/www-apache/anyterm/ChangeLog
+++ b/www-apache/anyterm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apache/anyterm
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/anyterm/ChangeLog,v 1.9 2008/01/06 20:17:49 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/anyterm/ChangeLog,v 1.10 2008/01/10 16:16:00 hollow Exp $
+
+*anyterm-1.1.16 (10 Jan 2008)
+
+ 10 Jan 2008; Benedikt Böhm <hollow@gentoo.org> files/50_anyterm.conf,
+ +anyterm-1.1.16.ebuild:
+ version bump, #203928
06 Jan 2008; Benedikt Böhm <hollow@gentoo.org>
-files/anyterm-1.1.8-apachemod-Makefile.patch,
diff --git a/www-apache/anyterm/anyterm-1.1.16.ebuild b/www-apache/anyterm/anyterm-1.1.16.ebuild
new file mode 100644
index 000000000000..cdc989c9f9b4
--- /dev/null
+++ b/www-apache/anyterm/anyterm-1.1.16.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/anyterm/anyterm-1.1.16.ebuild,v 1.1 2008/01/10 16:16:00 hollow Exp $
+
+inherit apache-module eutils toolchain-funcs webapp
+
+KEYWORDS="~x86"
+
+DESCRIPTION="A terminal anywhere."
+HOMEPAGE="http://anyterm.org/"
+SRC_URI="http://anyterm.org/download/${P}.tbz2"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="opera pam ssl"
+
+DEPEND="dev-libs/boost
+ >=dev-libs/rote-0.2.8
+ >=sys-devel/gcc-3
+ virtual/ssh
+ pam? ( www-apache/mod_auth_pam )"
+RDEPEND="${DEPEND}"
+
+APACHE2_MOD_CONF="50_${PN}"
+APACHE2_MOD_DEFINE="ANYTERM"
+use pam && APACHE2_MOD_DEFINE="${APACHE2_MOD_DEFINE} -D AUTH_PAM"
+use ssl && APACHE2_MOD_DEFINE="${APACHE2_MOD_DEFINE} -D SSL"
+APACHE2_MOD_FILE="${S}/apachemod/.libs/${PN}.so"
+DOCFILES="CHANGELOG README"
+
+WEBAPP_MANUAL_SLOT="yes"
+
+need_apache2_2
+
+pkg_setup() {
+ webapp_pkg_setup
+ apache-module_pkg_setup
+
+ if use ssl && ! built_with_use www-servers/apache ssl; then
+ die "Build www-servers/apache with USE=ssl."
+ fi
+
+ if ! built_with_use --missing true dev-libs/boost threads; then
+ die "Build dev-libs/boost with USE=threads."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-1.1.15-browser-gentoo.patch
+ sed -i -e "s:apr-config:apr-1-config:g" apachemod/Makefile
+}
+
+src_compile() {
+ cd apachemod
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" || die "Apachemod make failed"
+ cd ..
+
+ # Modify browser files to reflect USE flags.
+ for flag in opera pam ssl ; do
+ if use ${flag} ; then
+ sed -i -e "s/^#USE=${flag}#//" browser/{*,.htaccess}
+ sed -i -e "/^#USE=-${flag}#/D" browser/{*,.htaccess}
+ else
+ sed -i -e "s/^#USE=-${flag}#//" browser/{*,.htaccess}
+ sed -i -e "/^#USE=${flag}#/D" browser/{*,.htaccess}
+ fi
+ done
+}
+
+src_install() {
+ apache-module_src_install
+ webapp_src_preinst
+ cp -f browser/{*,.htaccess} "${D}/${MY_HTDOCSDIR}"
+ webapp_postinst_txt en "${FILESDIR}"/${PN}-1.1.15-postinst-en.txt
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+ apache-module_pkg_postinst
+
+ use ssl || ewarn "USE=-ssl: Anyterm without SSL is very insecure!"
+ use pam || ewarn "USE=-pam: You will have to add your own authentication mechanism."
+ use opera || ewarn "USE=opera: Be sure to disable some logging in your Apache configuration files!"
+ if ! use ssl || ! use pam || use opera ; then
+ ewarn "For more information see http://anyterm.org/security.html"
+ fi
+}
diff --git a/www-apache/anyterm/files/50_anyterm.conf b/www-apache/anyterm/files/50_anyterm.conf
index 24e04ce564ef..3a36d8362862 100644
--- a/www-apache/anyterm/files/50_anyterm.conf
+++ b/www-apache/anyterm/files/50_anyterm.conf
@@ -1,10 +1,5 @@
<IfDefine ANYTERM>
- <IfModule !anyterm.c>
- LoadModule anyterm modules/anyterm.so
- </IfModule>
- <IfDefine DEFAULT_VHOST>
- <Directory "/var/www/localhost/htdocs/anyterm">
- AllowOverride All
- </Directory>
- </IfDefine>
+LoadModule anyterm modules/anyterm.so
</IfDefine>
+
+# vim: ts=4 filetype=apache
diff --git a/www-apache/anyterm/files/digest-anyterm-1.1.16 b/www-apache/anyterm/files/digest-anyterm-1.1.16
new file mode 100644
index 000000000000..0e45528f0904
--- /dev/null
+++ b/www-apache/anyterm/files/digest-anyterm-1.1.16
@@ -0,0 +1,3 @@
+MD5 9b30f8d0fe23b7c7c668d9b11dc6d6b7 anyterm-1.1.16.tbz2 234458
+RMD160 e9a871f864bb260d2e0bb762d00235c936febb66 anyterm-1.1.16.tbz2 234458
+SHA256 3d9bb4158b6e67a14d6044473474549553db11566f59da64efb354522aa463e7 anyterm-1.1.16.tbz2 234458