summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2009-07-21 09:40:38 +0000
committerHanno Böck <hanno@gentoo.org>2009-07-21 09:40:38 +0000
commit5e29ec3cbd01c2534b19c533141b5b8e76a06222 (patch)
treeca4d1a6ee77b108f01b69c454dc2cc7d50bdd461 /www-apache/mod_fastcgi/mod_fastcgi-2.4.7_pre0811090952.ebuild
parentAdd !! blockers on old versions (diff)
downloadgentoo-2-5e29ec3cbd01c2534b19c533141b5b8e76a06222.tar.gz
gentoo-2-5e29ec3cbd01c2534b19c533141b5b8e76a06222.tar.bz2
gentoo-2-5e29ec3cbd01c2534b19c533141b5b8e76a06222.zip
mod_fastcgi bump to snapshot version
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'www-apache/mod_fastcgi/mod_fastcgi-2.4.7_pre0811090952.ebuild')
-rw-r--r--www-apache/mod_fastcgi/mod_fastcgi-2.4.7_pre0811090952.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/www-apache/mod_fastcgi/mod_fastcgi-2.4.7_pre0811090952.ebuild b/www-apache/mod_fastcgi/mod_fastcgi-2.4.7_pre0811090952.ebuild
new file mode 100644
index 000000000000..22a8918bea99
--- /dev/null
+++ b/www-apache/mod_fastcgi/mod_fastcgi-2.4.7_pre0811090952.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_fastcgi/mod_fastcgi-2.4.7_pre0811090952.ebuild,v 1.1 2009/07/21 09:40:38 hanno Exp $
+
+inherit apache-module eutils
+
+MY_P="${PN}-SNAP-${PV/2.4.7_pre/}"
+
+DESCRIPTION="FastCGI is a open extension to CGI without the limitations of server specific APIs."
+HOMEPAGE="http://fastcgi.com/"
+SRC_URI="http://www.fastcgi.com/dist/${MY_P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="FastCGI"
+IUSE=""
+
+APXS2_ARGS="-c mod_fastcgi.c fcgi*.c"
+APACHE2_MOD_CONF="20_${PN}"
+APACHE2_MOD_DEFINE="FASTCGI"
+
+DOCFILES="CHANGES README docs/LICENSE.TERMS docs/mod_fastcgi.html"
+
+S="${WORKDIR}/${MY_P}"
+
+need_apache
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/2.4.6-graceful.patch
+}