summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Thomson <wltjr@gentoo.org>2007-04-02 15:22:39 +0000
committerWilliam Thomson <wltjr@gentoo.org>2007-04-02 15:22:39 +0000
commitde97bc564e5337dec9df591c368271377f7f9b0e (patch)
tree00f8746c0ff7caa1914c1bd66cad70172cec3666 /www-apache/mod_jk
parentia64 stable wrt bug 161781 (diff)
downloadgentoo-2-de97bc564e5337dec9df591c368271377f7f9b0e.tar.gz
gentoo-2-de97bc564e5337dec9df591c368271377f7f9b0e.tar.bz2
gentoo-2-de97bc564e5337dec9df591c368271377f7f9b0e.zip
Bumped to latest dev snapshot of upcoming release
(Portage version: 2.1.2.2)
Diffstat (limited to 'www-apache/mod_jk')
-rw-r--r--www-apache/mod_jk/ChangeLog8
-rw-r--r--www-apache/mod_jk/files/digest-mod_jk-1.2.22_pre3
-rw-r--r--www-apache/mod_jk/mod_jk-1.2.22_pre.ebuild71
3 files changed, 81 insertions, 1 deletions
diff --git a/www-apache/mod_jk/ChangeLog b/www-apache/mod_jk/ChangeLog
index 634756c6d217..7d346ba2e0be 100644
--- a/www-apache/mod_jk/ChangeLog
+++ b/www-apache/mod_jk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apache/mod_jk
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_jk/ChangeLog,v 1.27 2007/03/08 19:16:39 wltjr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_jk/ChangeLog,v 1.28 2007/04/02 15:22:39 wltjr Exp $
+
+*mod_jk-1.2.22_pre (02 Apr 2007)
+
+ 02 Apr 2007; William L. Thomson Jr. <wltjr@gentoo.org>
+ +mod_jk-1.2.22_pre.ebuild:
+ Bumped to latest dev snapshot of upcoming release
08 Mar 2007; William L. Thomson Jr. <wltjr@gentoo.org>
mod_jk-1.2.21-r2.ebuild:
diff --git a/www-apache/mod_jk/files/digest-mod_jk-1.2.22_pre b/www-apache/mod_jk/files/digest-mod_jk-1.2.22_pre
new file mode 100644
index 000000000000..f9d77699ae48
--- /dev/null
+++ b/www-apache/mod_jk/files/digest-mod_jk-1.2.22_pre
@@ -0,0 +1,3 @@
+MD5 61f2a1dbf062bcba4970e4f4f88f95c6 tomcat-connectors-1.1.22-dev-524775-src.tar.gz 1347416
+RMD160 0d296fc1a4e7496d9f42eacde6a14204cf943ec0 tomcat-connectors-1.1.22-dev-524775-src.tar.gz 1347416
+SHA256 055cb877bef6ce75fb4e11e15e63f835f9005dabed96080fb7980bf081a9d01b tomcat-connectors-1.1.22-dev-524775-src.tar.gz 1347416
diff --git a/www-apache/mod_jk/mod_jk-1.2.22_pre.ebuild b/www-apache/mod_jk/mod_jk-1.2.22_pre.ebuild
new file mode 100644
index 000000000000..6593e59b514b
--- /dev/null
+++ b/www-apache/mod_jk/mod_jk-1.2.22_pre.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_jk/mod_jk-1.2.22_pre.ebuild,v 1.1 2007/04/02 15:22:39 wltjr Exp $
+
+inherit apache-module autotools
+
+MY_P="tomcat-connectors-${PV/2.22_pre/1.22-dev-524775}-src"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DESCRIPTION="JK module for connecting Tomcat and Apache using the ajp13 protocol."
+HOMEPAGE="http://tomcat.apache.org/connectors-doc/"
+#SRC_URI="mirror://apache/tomcat/tomcat-connectors/jk/source/jk-${PV}/${MY_P}.tar.gz"
+SRC_URI="http://people.apache.org/~mturk/jk-1.2.22-dev/${MY_P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+
+S="${WORKDIR}/${MY_P}/native"
+
+APACHE1_MOD_FILE="${S}/apache-1.3/${PN}.so"
+APACHE1_MOD_CONF="88_${PN}"
+APACHE1_MOD_DEFINE="JK"
+
+APACHE2_MOD_FILE="${S}/apache-2.0/${PN}.so"
+APACHE2_MOD_CONF="88_${PN}"
+APACHE2_MOD_DEFINE="JK"
+
+DOCFILES="CHANGES.txt README"
+
+need_apache
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ eautoreconf
+}
+
+src_compile() {
+ local apxs
+ use apache2 && apxs="${APXS2}"
+ use apache2 || apxs="${APXS1}"
+
+ econf \
+ --with-apxs=${apxs} \
+ --with-apr-config=/usr/bin/apr-config \
+ || die "econf failed"
+ emake LIBTOOL="/bin/sh $(pwd)/libtool --silent" || die "emake failed"
+}
+
+src_install() {
+ # install the workers.properties file
+ insinto "${APACHE_CONFDIR}"
+ doins "${FILESDIR}/jk-workers.properties"
+
+ # call the nifty default src_install :-)
+ apache-module_src_install
+
+ if ! use apache2 ; then
+ sed -i -e 's:/apache2/:/apache/:' "${D}${APACHE_CONFDIR}/modules.d/88_${PN}.conf" \
+ || die "Could not update jk-workers.properties for apache"
+ fi
+}
+
+pkg_postinst() {
+ elog "Tomcat is not a dependency of mod_jk any longer, if you intend"
+ elog "to use it with Tomcat, you have to merge www-servers/tomcat on"
+ elog "your own."
+}