summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlistair Bush <ali_bush@gentoo.org>2010-03-17 10:16:32 +0000
committerAlistair Bush <ali_bush@gentoo.org>2010-03-17 10:16:32 +0000
commit090eda7f0cd54612c09e4a81c4d3392838b27c94 (patch)
tree9b960af8aa21333e24628e21b9e67b13f29b1370 /www-apache
parentRemove entries for removed packages (diff)
downloadgentoo-2-090eda7f0cd54612c09e4a81c4d3392838b27c94.tar.gz
gentoo-2-090eda7f0cd54612c09e4a81c4d3392838b27c94.tar.bz2
gentoo-2-090eda7f0cd54612c09e4a81c4d3392838b27c94.zip
Version Bump
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_jk/ChangeLog9
-rw-r--r--www-apache/mod_jk/mod_jk-1.2.30.ebuild75
2 files changed, 82 insertions, 2 deletions
diff --git a/www-apache/mod_jk/ChangeLog b/www-apache/mod_jk/ChangeLog
index 419d9fc47333..ef87db2085c1 100644
--- a/www-apache/mod_jk/ChangeLog
+++ b/www-apache/mod_jk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apache/mod_jk
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_jk/ChangeLog,v 1.64 2009/10/30 17:56:06 betelgeuse Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_jk/ChangeLog,v 1.65 2010/03/17 10:16:32 ali_bush Exp $
+
+*mod_jk-1.2.30 (16 Mar 2010)
+
+ 16 Mar 2010; Alistair Bush <ali_bush@gentoo.org> +mod_jk-1.2.30.ebuild:
+ Version Bump.
30 Oct 2009; Petteri Räty <betelgeuse@gentoo.org>
mod_jk-1.2.28-r1.ebuild:
diff --git a/www-apache/mod_jk/mod_jk-1.2.30.ebuild b/www-apache/mod_jk/mod_jk-1.2.30.ebuild
new file mode 100644
index 000000000000..560d60db204a
--- /dev/null
+++ b/www-apache/mod_jk/mod_jk-1.2.30.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_jk/mod_jk-1.2.30.ebuild,v 1.1 2010/03/17 10:16:32 ali_bush Exp $
+
+EAPI="2"
+
+inherit apache-module java-pkg-2
+
+MY_P="tomcat-connectors-${PV}-src"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DESCRIPTION="JK module for connecting Tomcat and Apache using the ajp13 protocol."
+HOMEPAGE="http://tomcat.apache.org/connectors-doc/"
+SRC_URI="mirror://apache/tomcat/tomcat-connectors/jk/source/jk-${PV}/${MY_P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}/native"
+
+APACHE2_MOD_FILE="${S}/apache-2.0/${PN}.so"
+APACHE2_MOD_CONF="88_${PN}"
+APACHE2_MOD_DEFINE="JK"
+
+DOCFILES="CHANGES"
+CONF_DIR="${WORKDIR}/${MY_P}/conf"
+
+DEPEND=">=virtual/jdk-1.4"
+RDEPEND=""
+
+need_apache
+
+pkg_setup() {
+ java-pkg-2_pkg_setup
+}
+
+src_configure() {
+ econf \
+ --with-apxs=${APXS} \
+ --with-apr-config=/usr/bin/apr-config \
+ || die "econf failed"
+}
+
+src_compile() {
+ emake LIBTOOL="/bin/sh $(pwd)/libtool --silent" || die "emake failed"
+}
+
+src_install() {
+ # install the workers.properties file
+ insinto "${APACHE_CONFDIR}"
+ newins "${CONF_DIR}/workers.properties.minimal" \
+ jk-workers-minimal.properties || die
+ newins "${CONF_DIR}/workers.properties" \
+ jk-workers.properties || die
+ doins "${CONF_DIR}/uriworkermap.properties" || die
+
+ # call the nifty default src_install :-)
+ apache-module_src_install
+}
+
+pkg_postinst() {
+ elog "Tomcat is not a dependency of mod_jk any longer, if you intend"
+ elog "to use it with Tomcat, you have to merge www-servers/tomcat on"
+ elog "your own."
+
+ elog "Advanced Directives and Options can be found at: "
+ elog "http://tomcat.apache.org/connectors-doc/reference/workers.html"
+
+ elog ""
+ elog "JNI Worker Deprecation:"
+ elog "Workers of type jni are broken since a long time."
+ elog "Since there is no more use for them, they have been deprecated now,"
+ elog "and will be removed in a future release."
+}