summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2007-06-16 22:46:57 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2007-06-16 22:46:57 +0000
commitb2db15a95c874537c8f74fb5fa136daed1de1f06 (patch)
tree628fb7a32545eb9ca2d0295618ef25a7bc73bec8 /www-apache
parentAdded the -i switch to the configure options and a DEPEND on either konsole o... (diff)
downloadgentoo-2-b2db15a95c874537c8f74fb5fa136daed1de1f06.tar.gz
gentoo-2-b2db15a95c874537c8f74fb5fa136daed1de1f06.tar.bz2
gentoo-2-b2db15a95c874537c8f74fb5fa136daed1de1f06.zip
Add a patch for disabling sticky sessions, bug #181886.
(Portage version: 2.1.3_rc3)
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_caucho/ChangeLog12
-rw-r--r--www-apache/mod_caucho/files/digest-mod_caucho-3.0.23-r1 (renamed from www-apache/mod_caucho/files/digest-mod_caucho-3.0.23)0
-rw-r--r--www-apache/mod_caucho/files/digest-mod_caucho-3.1.1-r1 (renamed from www-apache/mod_caucho/files/digest-mod_caucho-3.1.1)1
-rw-r--r--www-apache/mod_caucho/files/mod_caucho-3.0.23-disable-sticky-sessions.patch30
-rw-r--r--www-apache/mod_caucho/files/mod_caucho-3.1.1-disable-sticky-sessions.patch30
-rw-r--r--www-apache/mod_caucho/mod_caucho-3.0.23-r1.ebuild (renamed from www-apache/mod_caucho/mod_caucho-3.0.23.ebuild)3
-rw-r--r--www-apache/mod_caucho/mod_caucho-3.1.1-r1.ebuild (renamed from www-apache/mod_caucho/mod_caucho-3.1.1.ebuild)3
7 files changed, 75 insertions, 4 deletions
diff --git a/www-apache/mod_caucho/ChangeLog b/www-apache/mod_caucho/ChangeLog
index 519d68b9a9cc..5be4ecc31b5f 100644
--- a/www-apache/mod_caucho/ChangeLog
+++ b/www-apache/mod_caucho/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for www-apache/mod_caucho
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_caucho/ChangeLog,v 1.17 2007/05/15 16:37:41 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_caucho/ChangeLog,v 1.18 2007/06/16 22:46:57 nelchael Exp $
+
+*mod_caucho-3.1.1-r1 (16 Jun 2007)
+*mod_caucho-3.0.23-r1 (16 Jun 2007)
+
+ 16 Jun 2007; Krzysiek Pawlik <nelchael@gentoo.org>
+ +files/mod_caucho-3.0.23-disable-sticky-sessions.patch,
+ +files/mod_caucho-3.1.1-disable-sticky-sessions.patch,
+ -mod_caucho-3.0.23.ebuild, +mod_caucho-3.0.23-r1.ebuild,
+ -mod_caucho-3.1.1.ebuild, +mod_caucho-3.1.1-r1.ebuild:
+ Add a patch for disabling sticky sessions, bug #181886.
*mod_caucho-3.1.1 (15 May 2007)
*mod_caucho-3.0.23 (15 May 2007)
diff --git a/www-apache/mod_caucho/files/digest-mod_caucho-3.0.23 b/www-apache/mod_caucho/files/digest-mod_caucho-3.0.23-r1
index bae42a23b37b..bae42a23b37b 100644
--- a/www-apache/mod_caucho/files/digest-mod_caucho-3.0.23
+++ b/www-apache/mod_caucho/files/digest-mod_caucho-3.0.23-r1
diff --git a/www-apache/mod_caucho/files/digest-mod_caucho-3.1.1 b/www-apache/mod_caucho/files/digest-mod_caucho-3.1.1-r1
index 1ed7597677ec..fb32cc0031b9 100644
--- a/www-apache/mod_caucho/files/digest-mod_caucho-3.1.1
+++ b/www-apache/mod_caucho/files/digest-mod_caucho-3.1.1-r1
@@ -1,3 +1,2 @@
-MD5 860fbaf78013c0bc5bde742e45a13e21 resin-3.1.1-src.tar.gz 7351646
RMD160 8b09954308408ef1312d2257bd607efb3b9dd1ce resin-3.1.1-src.tar.gz 7351646
SHA256 f37740327cda3b24c668ddcf61a28da825d258e3ba70a95073da02dafbe21424 resin-3.1.1-src.tar.gz 7351646
diff --git a/www-apache/mod_caucho/files/mod_caucho-3.0.23-disable-sticky-sessions.patch b/www-apache/mod_caucho/files/mod_caucho-3.0.23-disable-sticky-sessions.patch
new file mode 100644
index 000000000000..1e49f750218a
--- /dev/null
+++ b/www-apache/mod_caucho/files/mod_caucho-3.0.23-disable-sticky-sessions.patch
@@ -0,0 +1,30 @@
+diff -Nru resin-3.0.23.vanilla/modules/c/src/apache2/mod_caucho.c resin-3.0.23/modules/c/src/apache2/mod_caucho.c
+--- resin-3.0.23.vanilla/modules/c/src/apache2/mod_caucho.c 2006-11-01 19:09:04.000000000 +0100
++++ resin-3.0.23/modules/c/src/apache2/mod_caucho.c 2007-05-22 11:02:20.000000000 +0200
+@@ -391,6 +391,16 @@
+ }
+
+ /**
++ * Parse the CauchoDisableStickySessions configuration in the apache config file.
++ */
++static const char cse_disable_sticky_sessions(cmd_parms *cmd, void *pconfig, int on)
++{
++ config_t *config = pconfig;
++ config->disable_sticky_sessions = on;
++ return 0;
++}
++
++/**
+ * Parse the CauchoBackup configuration in the apache config file.
+ */
+ static const char *
+@@ -1215,6 +1225,9 @@
+ AP_INIT_TAKE1("CauchoConfigCacheDirectory", resin_config_cache_command,
+ NULL, RSRC_CONF|ACCESS_CONF,
+ "Configures the saved configuration file."),
++ AP_INIT_FLAG("CauchoDisableStickySessions", cse_disable_sticky_sessions,
++ NULL, RSRC_CONF,
++ "Disable sticky sessions."),
+ {NULL}
+ };
+
diff --git a/www-apache/mod_caucho/files/mod_caucho-3.1.1-disable-sticky-sessions.patch b/www-apache/mod_caucho/files/mod_caucho-3.1.1-disable-sticky-sessions.patch
new file mode 100644
index 000000000000..694559078152
--- /dev/null
+++ b/www-apache/mod_caucho/files/mod_caucho-3.1.1-disable-sticky-sessions.patch
@@ -0,0 +1,30 @@
+diff -Nru resin-3.1.1.vanilla/modules/c/src/apache2/mod_caucho.c resin-3.1.1/modules/c/src/apache2/mod_caucho.c
+--- resin-3.1.1.vanilla/modules/c/src/apache2/mod_caucho.c 2007-04-05 23:38:30.000000000 +0200
++++ resin-3.1.1/modules/c/src/apache2/mod_caucho.c 2007-05-22 17:24:38.000000000 +0200
+@@ -391,6 +391,16 @@
+ }
+
+ /**
++ * Parse the CauchoDisableStickySessions configuration in the apache config file.
++ */
++static const char cse_disable_sticky_sessions(cmd_parms *cmd, void *pconfig, int on)
++{
++ config_t *config = pconfig;
++ config->disable_sticky_sessions = on;
++ return 0;
++}
++
++/**
+ * Parse the CauchoBackup configuration in the apache config file.
+ */
+ static const char *
+@@ -1278,6 +1288,9 @@
+ AP_INIT_TAKE1("CauchoConfigCacheDirectory", resin_config_cache_command,
+ NULL, RSRC_CONF|ACCESS_CONF,
+ "Configures the saved configuration file."),
++ AP_INIT_FLAG("CauchoDisableStickySessions", cse_disable_sticky_sessions,
++ NULL, RSRC_CONF,
++ "Disable sticky sessions."),
+ {NULL}
+ };
+
diff --git a/www-apache/mod_caucho/mod_caucho-3.0.23.ebuild b/www-apache/mod_caucho/mod_caucho-3.0.23-r1.ebuild
index b5d2c916ca45..f2689dd6d83d 100644
--- a/www-apache/mod_caucho/mod_caucho-3.0.23.ebuild
+++ b/www-apache/mod_caucho/mod_caucho-3.0.23-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_caucho/mod_caucho-3.0.23.ebuild,v 1.1 2007/05/15 16:37:41 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_caucho/mod_caucho-3.0.23-r1.ebuild,v 1.1 2007/06/16 22:46:57 nelchael Exp $
inherit eutils apache-module autotools
@@ -28,6 +28,7 @@ src_unpack() {
epatch "${FILESDIR}/${P}-gentoo.patch"
epatch "${FILESDIR}/${P}-ssl.patch"
epatch "${FILESDIR}/${P}-java.patch"
+ epatch "${FILESDIR}/${P}-disable-sticky-sessions.patch"
eautoreconf
chmod 755 ./configure
}
diff --git a/www-apache/mod_caucho/mod_caucho-3.1.1.ebuild b/www-apache/mod_caucho/mod_caucho-3.1.1-r1.ebuild
index 2f015b24cef5..575a22864e8f 100644
--- a/www-apache/mod_caucho/mod_caucho-3.1.1.ebuild
+++ b/www-apache/mod_caucho/mod_caucho-3.1.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_caucho/mod_caucho-3.1.1.ebuild,v 1.1 2007/05/15 16:37:41 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_caucho/mod_caucho-3.1.1-r1.ebuild,v 1.1 2007/06/16 22:46:57 nelchael Exp $
inherit eutils apache-module autotools
@@ -31,6 +31,7 @@ src_unpack() {
epatch "${FILESDIR}/${P}-gentoo.patch"
epatch "${FILESDIR}/${P}-ssl.patch"
epatch "${FILESDIR}/${P}-java.patch"
+ epatch "${FILESDIR}/${P}-disable-sticky-sessions.patch"
eautoreconf
chmod 755 ./configure
}