summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2010-01-31 19:38:01 +0000
committerHanno Böck <hanno@gentoo.org>2010-01-31 19:38:01 +0000
commitb77590b99c3a650bbee0c6787f9c4d468650bf7b (patch)
tree283514a0b02d698c6139105e09193c01fff5a8c3 /www-apache
parentVersion bump. (diff)
downloadgentoo-2-b77590b99c3a650bbee0c6787f9c4d468650bf7b.tar.gz
gentoo-2-b77590b99c3a650bbee0c6787f9c4d468650bf7b.tar.bz2
gentoo-2-b77590b99c3a650bbee0c6787f9c4d468650bf7b.zip
mod_fcgid bump
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_fcgid/ChangeLog9
-rw-r--r--www-apache/mod_fcgid/mod_fcgid-2.3.5.ebuild27
2 files changed, 34 insertions, 2 deletions
diff --git a/www-apache/mod_fcgid/ChangeLog b/www-apache/mod_fcgid/ChangeLog
index 4cf09e5879d8..ed589cf84049 100644
--- a/www-apache/mod_fcgid/ChangeLog
+++ b/www-apache/mod_fcgid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apache/mod_fcgid
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_fcgid/ChangeLog,v 1.42 2009/12/21 15:18:34 hanno Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_fcgid/ChangeLog,v 1.43 2010/01/31 19:38:01 hanno Exp $
+
+*mod_fcgid-2.3.5 (31 Jan 2010)
+
+ 31 Jan 2010; Hanno Boeck <hanno@gentoo.org> +mod_fcgid-2.3.5.ebuild:
+ Version bump.
*mod_fcgid-2.3.5_pre20091221 (21 Dec 2009)
diff --git a/www-apache/mod_fcgid/mod_fcgid-2.3.5.ebuild b/www-apache/mod_fcgid/mod_fcgid-2.3.5.ebuild
new file mode 100644
index 000000000000..de0a3a6fdb96
--- /dev/null
+++ b/www-apache/mod_fcgid/mod_fcgid-2.3.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_fcgid/mod_fcgid-2.3.5.ebuild,v 1.1 2010/01/31 19:38:01 hanno Exp $
+
+inherit apache-module eutils multilib
+
+DESCRIPTION="mod_fcgid is a binary-compatible alternative to mod_fastcgi with better process management."
+HOMEPAGE="http://httpd.apache.org/mod_fcgid/"
+SRC_URI="mirror://apache/httpd/mod_fcgid/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+APACHE2_MOD_CONF="2.2/20_${PN}"
+APACHE2_MOD_DEFINE="FCGID"
+
+DOCFILES="CHANGES-FCGID README-FCGID STATUS-FCGID"
+
+need_apache2_2
+
+src_compile () {
+ ./configure.apxs || die "apxs configure failed!"
+ make || die "make failed"
+ ln -sf modules/fcgid/.libs .libs || die "symlink creation failed"
+}