summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2010-04-15 07:13:38 +0000
committerTorsten Veller <tove@gentoo.org>2010-04-15 07:13:38 +0000
commit16a33c1086f3a0d791d348531d29ca5fc26543d3 (patch)
tree8e2c9ba7b60671c3b1946a8b10c821a87fbbed68 /www-apps/bugzilla
parentVersion bump, bug #309947, thank Evert for this job. (diff)
downloadgentoo-2-16a33c1086f3a0d791d348531d29ca5fc26543d3.tar.gz
gentoo-2-16a33c1086f3a0d791d348531d29ca5fc26543d3.tar.bz2
gentoo-2-16a33c1086f3a0d791d348531d29ca5fc26543d3.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'www-apps/bugzilla')
-rw-r--r--www-apps/bugzilla/ChangeLog10
-rw-r--r--www-apps/bugzilla/bugzilla-3.6.ebuild104
-rw-r--r--www-apps/bugzilla/files/3.6/bugzilla.cron.daily5
-rw-r--r--www-apps/bugzilla/files/3.6/bugzilla.cron.tab1
-rw-r--r--www-apps/bugzilla/files/3.6/postinstall-en.txt12
-rw-r--r--www-apps/bugzilla/files/3.6/reconfig19
6 files changed, 150 insertions, 1 deletions
diff --git a/www-apps/bugzilla/ChangeLog b/www-apps/bugzilla/ChangeLog
index a5d55f2016f7..7f9338c32dac 100644
--- a/www-apps/bugzilla/ChangeLog
+++ b/www-apps/bugzilla/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for www-apps/bugzilla
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/bugzilla/ChangeLog,v 1.162 2010/03/14 11:42:18 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/bugzilla/ChangeLog,v 1.163 2010/04/15 07:13:37 tove Exp $
+
+*bugzilla-3.6 (15 Apr 2010)
+
+ 15 Apr 2010; Torsten Veller <tove@gentoo.org>
+ +files/3.6/bugzilla.cron.daily, +bugzilla-3.6.ebuild,
+ +files/3.6/bugzilla.cron.tab, +files/3.6/postinstall-en.txt,
+ +files/3.6/reconfig:
+ Version bump
14 Mar 2010; Torsten Veller <tove@gentoo.org> bugzilla-3.0.11.ebuild,
bugzilla-3.2.6.ebuild, bugzilla-3.4.5.ebuild, bugzilla-3.4.6.ebuild:
diff --git a/www-apps/bugzilla/bugzilla-3.6.ebuild b/www-apps/bugzilla/bugzilla-3.6.ebuild
new file mode 100644
index 000000000000..9922525a723a
--- /dev/null
+++ b/www-apps/bugzilla/bugzilla-3.6.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/bugzilla/bugzilla-3.6.ebuild,v 1.1 2010/04/15 07:13:37 tove Exp $
+
+EAPI="2"
+
+inherit webapp depend.apache versionator eutils
+
+MY_PB=$(get_version_component_range 1-2)
+
+DESCRIPTION="Bugzilla is the Bug-Tracking System from the Mozilla project"
+SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/webtools/${P}.tar.gz"
+HOMEPAGE="http://www.bugzilla.org"
+
+LICENSE="MPL-1.1 NPL-1.1"
+# KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="modperl extras graphviz mysql postgres"
+
+RDEPEND="
+ virtual/httpd-cgi
+ >=dev-lang/perl-5.8.8
+
+ >=dev-perl/DBI-1.601
+ >=dev-perl/DateTime-0.50
+ >=dev-perl/DateTime-Locale-0.43
+ >=dev-perl/DateTime-TimeZone-0.71
+ >=dev-perl/URI-1.38
+ >=dev-perl/Email-MIME-1.900
+ >=dev-perl/Email-MIME-Encodings-1.313
+ >=dev-perl/Email-Send-2.190
+ >=dev-perl/MIME-tools-5.427
+ >=dev-perl/Template-Toolkit-2.22
+ >=dev-perl/TimeDate-1.16
+ >=virtual/perl-CGI-3.33
+ >=virtual/perl-Digest-SHA-5.46
+ >=virtual/perl-File-Spec-3.27.01
+ >=virtual/perl-MIME-Base64-3.07
+
+ mysql? ( >=dev-perl/DBD-mysql-4.00.5 )
+ postgres? ( >=dev-perl/DBD-Pg-1.49 )
+ graphviz? ( media-gfx/graphviz )
+
+ modperl? (
+ >=dev-perl/Apache-DBI-1.06
+ www-apache/mod_perl:1
+ )
+
+ extras? (
+ dev-perl/Authen-SASL
+ >=dev-perl/Chart-2.4.1
+ dev-perl/Email-MIME-Attachment-Stripper
+ dev-perl/Email-Reply
+ >=dev-perl/GD-2.35
+ dev-perl/GDGraph
+ dev-perl/GDTextUtil
+ >=dev-perl/HTML-Parser-3.60
+ dev-perl/HTML-Scrubber
+ dev-perl/JSON-RPC
+ dev-perl/libwww-perl
+ >=dev-perl/PatchReader-0.9.5
+ dev-perl/perl-ldap
+ dev-perl/SOAP-Lite
+ dev-perl/Template-GD
+ dev-perl/Test-Taint
+ dev-perl/XML-Twig
+ media-gfx/imagemagick[perl]
+ dev-perl/TheSchwartz
+ dev-perl/Daemon-Generic
+ )
+"
+# from extras we miss:
+# (nothing)
+
+want_apache modperl
+
+pkg_setup() {
+ depend.apache_pkg_setup modperl
+ webapp_pkg_setup
+}
+
+src_prepare() {
+ ecvs_clean
+}
+
+src_install () {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+ for f in bugzilla.cron.daily bugzilla.cron.tab; do
+ doins "${FILESDIR}"/${MY_PB}/${f} || die
+ done
+
+ webapp_hook_script "${FILESDIR}"/${MY_PB}/reconfig
+ webapp_postinst_txt en "${FILESDIR}"/${MY_PB}/postinstall-en.txt
+ webapp_src_install
+
+ # bug #124282
+ chmod +x "${D}${MY_HTDOCSDIR}"/*.cgi
+ # configuration must be executable
+ chmod u+x "${D}${MY_HTDOCSDIR}"/checksetup.pl
+}
diff --git a/www-apps/bugzilla/files/3.6/bugzilla.cron.daily b/www-apps/bugzilla/files/3.6/bugzilla.cron.daily
new file mode 100644
index 000000000000..e3e86589891d
--- /dev/null
+++ b/www-apps/bugzilla/files/3.6/bugzilla.cron.daily
@@ -0,0 +1,5 @@
+#!/bin/sh
+cd /var/www/bugzilla/
+./collectstats.pl
+./whineatnews.pl
+echo "*** Bugzilla nighlty flush has done! ***"
diff --git a/www-apps/bugzilla/files/3.6/bugzilla.cron.tab b/www-apps/bugzilla/files/3.6/bugzilla.cron.tab
new file mode 100644
index 000000000000..0ac2ef6d65a6
--- /dev/null
+++ b/www-apps/bugzilla/files/3.6/bugzilla.cron.tab
@@ -0,0 +1 @@
+0 0 * * * /var/www/bugzilla/bugzilla.cron.daily
diff --git a/www-apps/bugzilla/files/3.6/postinstall-en.txt b/www-apps/bugzilla/files/3.6/postinstall-en.txt
new file mode 100644
index 000000000000..3b61f9db1e83
--- /dev/null
+++ b/www-apps/bugzilla/files/3.6/postinstall-en.txt
@@ -0,0 +1,12 @@
+0. Bugzilla has been installed into ${MY_INSTALLDIR}
+
+1. To finish the installation, please read
+ http://www.bugzilla.org/docs/3.6/en/html/installing-bugzilla.html
+ You will need to run ${MY_INSTALLDIR}/checksetup.pl
+
+2. Please read the Release Notes, especially if you are upgrading:
+ http://www.bugzilla.org/releases/3.6/release-notes.html
+
+3. Please note that Apache2 sets AllowOverride None by default. You may have
+ to edit it to process the .htaccess file provided by Bugzilla. Please see
+ http://httpd.apache.org/docs/2.2/mod/core.html#allowoverride for more info.
diff --git a/www-apps/bugzilla/files/3.6/reconfig b/www-apps/bugzilla/files/3.6/reconfig
new file mode 100644
index 000000000000..71b0acea2585
--- /dev/null
+++ b/www-apps/bugzilla/files/3.6/reconfig
@@ -0,0 +1,19 @@
+#!/bin/bash
+
+FILE="bugzilla.cron.daily bugzilla.cron.tab"
+
+function die ()
+{
+ echo
+ echo "***"
+ echo "*** Fatal error: $*"
+ echo "***"
+ exit 1
+}
+
+if [ $1 = "install" ]; then
+ cd "${MY_INSTALLDIR}" || die "Cannot find install dir ${MY_INSTALLDIR}"
+ sed -e "s|/var/www/bugzilla|${MY_INSTALLDIR}|g" -i ${FILE} || die "sed failed"
+else
+ echo "done."
+fi