summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-02-20 12:58:23 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-02-20 12:58:23 +0000
commit9607339b57e4b8d9f980e24f897046d091b09fff (patch)
tree017b3ae9c20875b7fc2d1696354ffe88d20be86f /www-apps/bugzilla
parentput guile-1.6.8 bafck as some ebuilds still depend on it, thanks to tove (diff)
downloadgentoo-2-9607339b57e4b8d9f980e24f897046d091b09fff.tar.gz
gentoo-2-9607339b57e4b8d9f980e24f897046d091b09fff.tar.bz2
gentoo-2-9607339b57e4b8d9f980e24f897046d091b09fff.zip
use ecvs_clean; fix quoting
(Portage version: 2.1.4.4)
Diffstat (limited to 'www-apps/bugzilla')
-rw-r--r--www-apps/bugzilla/ChangeLog6
-rw-r--r--www-apps/bugzilla/bugzilla-2.20.5.ebuild13
-rw-r--r--www-apps/bugzilla/bugzilla-2.22.3.ebuild14
-rw-r--r--www-apps/bugzilla/bugzilla-3.0.2.ebuild12
-rw-r--r--www-apps/bugzilla/bugzilla-3.0.3.ebuild13
5 files changed, 27 insertions, 31 deletions
diff --git a/www-apps/bugzilla/ChangeLog b/www-apps/bugzilla/ChangeLog
index d22a836e22c7..febab2bb0bd6 100644
--- a/www-apps/bugzilla/ChangeLog
+++ b/www-apps/bugzilla/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-apps/bugzilla
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/bugzilla/ChangeLog,v 1.107 2008/02/17 22:37:41 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/bugzilla/ChangeLog,v 1.108 2008/02/20 12:58:23 hollow Exp $
+
+ 20 Feb 2008; Benedikt Böhm <hollow@gentoo.org> bugzilla-2.20.5.ebuild,
+ bugzilla-2.22.3.ebuild, bugzilla-3.0.2.ebuild, bugzilla-3.0.3.ebuild:
+ use ecvs_clean; fix quoting
*bugzilla-3.0.3 (17 Feb 2008)
diff --git a/www-apps/bugzilla/bugzilla-2.20.5.ebuild b/www-apps/bugzilla/bugzilla-2.20.5.ebuild
index afe266113f07..cee63bf3ab58 100644
--- a/www-apps/bugzilla/bugzilla-2.20.5.ebuild
+++ b/www-apps/bugzilla/bugzilla-2.20.5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/bugzilla/bugzilla-2.20.5.ebuild,v 1.9 2008/02/17 22:37:41 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/bugzilla/bugzilla-2.20.5.ebuild,v 1.10 2008/02/20 12:58:23 hollow Exp $
-inherit webapp depend.apache versionator
+inherit webapp depend.apache versionator eutils
MY_PB=$(get_version_component_range 1-2)
@@ -49,22 +49,21 @@ need_apache2
src_unpack() {
unpack ${A}
cd "${S}"
- # remove CVS directories
- find . -type d -name 'CVS' -prune -exec rm -rf {} \;
+ ecvs_clean
}
src_install () {
webapp_src_preinst
- insinto ${MY_HTDOCSDIR}
- doins -r *
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
newins "${FILESDIR}"/${MY_PB}/apache.htaccess .htaccess
for f in bugzilla.cron.daily bugzilla.cron.tab; do
doins "${FILESDIR}"/${MY_PB}/${f}
done
for f in $(find -type d -printf "%p/* "); do
- webapp_serverowned ${MY_HTDOCSDIR}/${f}
+ webapp_serverowned "${MY_HTDOCSDIR}"/${f}
done
webapp_hook_script "${FILESDIR}"/${MY_PB}/reconfig
diff --git a/www-apps/bugzilla/bugzilla-2.22.3.ebuild b/www-apps/bugzilla/bugzilla-2.22.3.ebuild
index 744118e8de82..f4c1eec04417 100644
--- a/www-apps/bugzilla/bugzilla-2.22.3.ebuild
+++ b/www-apps/bugzilla/bugzilla-2.22.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/bugzilla/bugzilla-2.22.3.ebuild,v 1.8 2008/02/17 22:37:41 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/bugzilla/bugzilla-2.22.3.ebuild,v 1.9 2008/02/20 12:58:23 hollow Exp $
-inherit webapp depend.apache versionator
+inherit webapp depend.apache versionator eutils
MY_PB=$(get_version_component_range 1-2)
@@ -55,16 +55,14 @@ need_apache2
src_unpack() {
unpack ${A}
cd "${S}"
-
- # remove CVS directories
- find . -type d -name 'CVS' -prune -exec rm -rf {} \;
+ ecvs_clean
}
src_install () {
webapp_src_preinst
- insinto ${MY_HTDOCSDIR}
- doins -r *
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
newins "${FILESDIR}"/${MY_PB}/apache.htaccess .htaccess
for f in bugzilla.cron.daily bugzilla.cron.tab; do
doins "${FILESDIR}"/${MY_PB}/${f}
@@ -75,5 +73,5 @@ src_install () {
webapp_src_install
# bug #124282
- chmod +x "${D}"${MY_HTDOCSDIR}/*.cgi
+ chmod +x "${D}${MY_HTDOCSDIR}"/*.cgi
}
diff --git a/www-apps/bugzilla/bugzilla-3.0.2.ebuild b/www-apps/bugzilla/bugzilla-3.0.2.ebuild
index f9fbb801b802..14e93cb20b0f 100644
--- a/www-apps/bugzilla/bugzilla-3.0.2.ebuild
+++ b/www-apps/bugzilla/bugzilla-3.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/bugzilla/bugzilla-3.0.2.ebuild,v 1.8 2008/02/17 22:37:41 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/bugzilla/bugzilla-3.0.2.ebuild,v 1.9 2008/02/20 12:58:23 hollow Exp $
inherit webapp depend.apache versionator eutils
@@ -76,9 +76,7 @@ pkg_setup() {
src_unpack() {
unpack ${A}
cd "${S}"
-
- # remove CVS directories
- find . -type d -name 'CVS' -prune -exec rm -rf {} \;
+ ecvs_clean
if use linguas_de ; then
mv ../de template/
@@ -91,8 +89,8 @@ src_unpack() {
src_install () {
webapp_src_preinst
- insinto ${MY_HTDOCSDIR}
- doins -r *
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
for f in bugzilla.cron.daily bugzilla.cron.tab; do
doins "${FILESDIR}"/${MY_PB}/${f}
done
@@ -102,5 +100,5 @@ src_install () {
webapp_src_install
# bug #124282
- chmod +x "${D}"${MY_HTDOCSDIR}/*.cgi
+ chmod +x "${D}${MY_HTDOCSDIR}"/*.cgi
}
diff --git a/www-apps/bugzilla/bugzilla-3.0.3.ebuild b/www-apps/bugzilla/bugzilla-3.0.3.ebuild
index ac0abd94d3a2..9be07f151e20 100644
--- a/www-apps/bugzilla/bugzilla-3.0.3.ebuild
+++ b/www-apps/bugzilla/bugzilla-3.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/bugzilla/bugzilla-3.0.3.ebuild,v 1.1 2008/02/17 22:37:41 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/bugzilla/bugzilla-3.0.3.ebuild,v 1.2 2008/02/20 12:58:23 hollow Exp $
inherit webapp depend.apache versionator eutils
@@ -69,15 +69,12 @@ pkg_setup() {
elog "to convert BMP attachments to PNG"
fi
fi
-
}
src_unpack() {
unpack ${A}
cd "${S}"
-
- # remove CVS directories
- find . -type d -name 'CVS' -prune -exec rm -rf {} \;
+ ecvs_clean
if use linguas_de ; then
mv ../de template/
@@ -90,8 +87,8 @@ src_unpack() {
src_install () {
webapp_src_preinst
- insinto ${MY_HTDOCSDIR}
- doins -r *
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
for f in bugzilla.cron.daily bugzilla.cron.tab; do
doins "${FILESDIR}"/${MY_PB}/${f}
done
@@ -101,5 +98,5 @@ src_install () {
webapp_src_install
# bug #124282
- chmod +x "${D}"${MY_HTDOCSDIR}/*.cgi
+ chmod +x "${D}${MY_HTDOCSDIR}"/*.cgi
}