summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-08-16 18:04:52 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-08-16 18:04:52 +0000
commit576f57d8733bcf244f05633e59a61db92d3e3253 (patch)
tree4f55a151cb3fed22d849280948b8c003cb0fe907 /www-apps/drupal/drupal-6.19.ebuild
parentAdd a new drive to the database (bug #332887). (diff)
downloadgentoo-2-576f57d8733bcf244f05633e59a61db92d3e3253.tar.gz
gentoo-2-576f57d8733bcf244f05633e59a61db92d3e3253.tar.bz2
gentoo-2-576f57d8733bcf244f05633e59a61db92d3e3253.zip
[www-apps/drupal] Version bump
(Portage version: 2.2_rc67_p582/cvs/Linux x86_64)
Diffstat (limited to 'www-apps/drupal/drupal-6.19.ebuild')
-rw-r--r--www-apps/drupal/drupal-6.19.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/www-apps/drupal/drupal-6.19.ebuild b/www-apps/drupal/drupal-6.19.ebuild
new file mode 100644
index 000000000000..770d2df99567
--- /dev/null
+++ b/www-apps/drupal/drupal-6.19.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/drupal/drupal-6.19.ebuild,v 1.1 2010/08/16 18:04:52 alexxy Exp $
+
+inherit webapp eutils depend.php
+
+MY_PV=${PV:0:3}.0
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="http://drupal.org/"
+SRC_URI="http://drupal.org/files/projects/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+
+need_httpd_cgi
+need_php_httpd
+
+pkg_setup() {
+ webapp_pkg_setup
+ has_php
+ if [[ ${PHP_VERSION} == "4" ]] ; then
+ local flags="expat"
+ else
+ local flags="xml"
+ fi
+ if ! PHPCHECKNODIE="yes" require_php_with_use ${flags} \
+ || ! PHPCHECKNODIE="yes" require_php_with_any_use gd gd-external ; then
+ die "Re-install ${PHP_PKG} with ${flags} and either gd or gd-external"
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="MAINTAINERS.txt LICENSE.txt INSTALL.txt CHANGELOG.txt INSTALL.mysql.txt INSTALL.pgsql.txt UPGRADE.txt "
+ dodoc ${docs}
+ rm -f ${docs} INSTALL COPYRIGHT.txt
+
+ cp sites/default/{default.settings.php,settings.php}
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default/settings.php
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ ewarn
+}