summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2015-03-01 17:34:18 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2015-03-01 17:34:18 +0000
commit1735c7d4d97284a74403fb52b0be09c759cf3360 (patch)
treedb567a41e5bfb801db3a88baa74e0480adf09e93 /www-apps/drupal
parentFix py3 support (diff)
downloadgentoo-2-1735c7d4d97284a74403fb52b0be09c759cf3360.tar.gz
gentoo-2-1735c7d4d97284a74403fb52b0be09c759cf3360.tar.bz2
gentoo-2-1735c7d4d97284a74403fb52b0be09c759cf3360.zip
Add initial drupal 8.0 beta release from my overlay.
I've been testing it locally, but will leave it without keywords until there's more feedback. (Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key BB0E6E98)
Diffstat (limited to 'www-apps/drupal')
-rw-r--r--www-apps/drupal/ChangeLog11
-rw-r--r--www-apps/drupal/drupal-8.0.0_beta7.ebuild87
2 files changed, 96 insertions, 2 deletions
diff --git a/www-apps/drupal/ChangeLog b/www-apps/drupal/ChangeLog
index 7db684398103..6792e1d204ca 100644
--- a/www-apps/drupal/ChangeLog
+++ b/www-apps/drupal/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-apps/drupal
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/drupal/ChangeLog,v 1.110 2014/11/20 11:45:49 jmbsvicetto Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/drupal/ChangeLog,v 1.111 2015/03/01 17:34:18 jmbsvicetto Exp $
+
+*drupal-8.0.0_beta7 (01 Mar 2015)
+
+ 01 Mar 2015; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ +drupal-8.0.0_beta7.ebuild:
+ Add initial drupal 8.0 beta release from my overlay. I've been testing it
+ locally, but will leave it without keywords until there's more feedback.
*drupal-6.34 (20 Nov 2014)
*drupal-7.34 (20 Nov 2014)
diff --git a/www-apps/drupal/drupal-8.0.0_beta7.ebuild b/www-apps/drupal/drupal-8.0.0_beta7.ebuild
new file mode 100644
index 000000000000..e018aa784c67
--- /dev/null
+++ b/www-apps/drupal/drupal-8.0.0_beta7.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/drupal/drupal-8.0.0_beta7.ebuild,v 1.1 2015/03/01 17:34:18 jmbsvicetto Exp $
+
+EAPI=5
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+MY_P=${P/_/-}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="http://drupal.org/"
+SRC_URI="http://drupal.org/files/projects/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS=""
+IUSE="+accelerator +mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+ dev-lang/php[gd,hash,pdo,postgres?,simplexml,xml]
+ virtual/httpd-php
+ accelerator? ( ||
+ (
+ dev-php/xcache
+ (
+ >=dev-lang/php-5.5[opcache]
+ dev-php/pecl-apcu
+ )
+ )
+ )
+ uploadprogress? ( dev-php/pecl-uploadprogress )
+ mysql? (
+ || (
+ dev-lang/php[mysql]
+ dev-lang/php[mysqli]
+ )
+ )
+ sqlite? ( dev-lang/php[sqlite] )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="LICENSE.txt README.txt core/MAINTAINERS.txt core/INSTALL.txt core/CHANGELOG.txt \
+ core/INSTALL.mysql.txt core/INSTALL.pgsql.txt core/INSTALL.sqlite.txt core/UPGRADE.txt "
+
+ dodoc ${docs}
+ rm -f ${docs} core/INSTALL core/COPYRIGHT.txt core/LICENSE.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default/settings.php
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+ ewarn "If this is a new install, unless you want anyone with network access to your server to be"
+ ewarn "able to run the setup, you'll have to configure your web server to limit access to it."
+ echo
+ ewarn "If you're doing a new drupal-8 install, you'll have to copy /sites/default/default.services.yml"
+ ewarn "to /sites/default/services.yml and grant it write permissions to your web server."
+ ewarn "Just follow the instructions of the drupal setup and be sure to resolve any permissions issue"
+ ewarn "reported by the setup."
+ echo
+}