summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2006-06-20 21:17:18 +0000
committerRenat Lumpau <rl03@gentoo.org>2006-06-20 21:17:18 +0000
commita0e793db0edc977c36437db4d15dc35f2beb13b4 (patch)
treece3002f334531fde26e3addc5e5254111ecd7fdc /www-apps/mambo
parentSecurity bump. Failure to check the return value of setuid() in a privileged (diff)
downloadgentoo-2-a0e793db0edc977c36437db4d15dc35f2beb13b4.tar.gz
gentoo-2-a0e793db0edc977c36437db4d15dc35f2beb13b4.tar.bz2
gentoo-2-a0e793db0edc977c36437db4d15dc35f2beb13b4.zip
Patch security vulnerability
(Portage version: 2.1)
Diffstat (limited to 'www-apps/mambo')
-rw-r--r--www-apps/mambo/ChangeLog8
-rw-r--r--www-apps/mambo/files/digest-mambo-4.5.4-r16
-rw-r--r--www-apps/mambo/mambo-4.5.4-r1.ebuild46
3 files changed, 59 insertions, 1 deletions
diff --git a/www-apps/mambo/ChangeLog b/www-apps/mambo/ChangeLog
index 75c9c8632344..48e85891e176 100644
--- a/www-apps/mambo/ChangeLog
+++ b/www-apps/mambo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/mambo
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mambo/ChangeLog,v 1.23 2006/06/18 00:36:20 rl03 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mambo/ChangeLog,v 1.24 2006/06/20 21:17:18 rl03 Exp $
+
+*mambo-4.5.4-r1 (20 Jun 2006)
+
+ 20 Jun 2006; Renat Lumpau <rl03@gentoo.org> -mambo-4.5.4.ebuild,
+ +mambo-4.5.4-r1.ebuild:
+ Patch security vulnerability
*mambo-4.5.4 (18 Jun 2006)
diff --git a/www-apps/mambo/files/digest-mambo-4.5.4-r1 b/www-apps/mambo/files/digest-mambo-4.5.4-r1
new file mode 100644
index 000000000000..79dec8afe574
--- /dev/null
+++ b/www-apps/mambo/files/digest-mambo-4.5.4-r1
@@ -0,0 +1,6 @@
+MD5 bda97ff4f32b72efc79b5f9c23c64545 Mambov454_Security_Patch1.tar.gz 3135
+RMD160 7f15c5a674e7a3eb6d975cd6542d2ca259ab8db8 Mambov454_Security_Patch1.tar.gz 3135
+SHA256 6a2c582173efaa5d47665eff009b0e65488fa69e8ac1d90a6a218a2a13bbcfa4 Mambov454_Security_Patch1.tar.gz 3135
+MD5 5e475aa284c05bcae4b3966ca47f9d35 mambov4.5.4.tar.gz 1911335
+RMD160 c25d39ba00d78078dd28eb824e6808d8e76995f0 mambov4.5.4.tar.gz 1911335
+SHA256 4845095dce71fc82e5df7c8ba9743e494aefab40672c8507978b6d4b76f9bd9b mambov4.5.4.tar.gz 1911335
diff --git a/www-apps/mambo/mambo-4.5.4-r1.ebuild b/www-apps/mambo/mambo-4.5.4-r1.ebuild
new file mode 100644
index 000000000000..f22e833c4a98
--- /dev/null
+++ b/www-apps/mambo/mambo-4.5.4-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mambo/mambo-4.5.4-r1.ebuild,v 1.1 2006/06/20 21:17:18 rl03 Exp $
+
+inherit webapp depend.php
+
+MY_PN="${PN/m/M}"
+DESCRIPTION="Mambo is yet another CMS"
+HOMEPAGE="http://www.mamboserver.com/"
+SRC_URI="http://mamboxchange.com/frs/download.php/7877/${PN}v${PV}.tar.gz
+http://mamboxchange.com/frs/download.php/7967/Mambov454_Security_Patch1.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64"
+S=${WORKDIR}
+
+IUSE="mysql"
+
+RDEPEND="mysql? ( dev-db/mysql )
+ virtual/httpd-php
+ net-www/apache"
+
+pkg_setup () {
+ webapp_pkg_setup
+ require_php_with_use mysql zlib
+}
+
+src_install () {
+ webapp_src_preinst
+ local files="administrator/backups administrator/components components
+ images images/banners images/stories mambots mambots/content mambots/search
+ media language administrator/modules administrator/templates cache modules
+ templates"
+
+ dodoc CHANGELOG.php INSTALL.php README
+
+ cp -R [^d]* ${D}/${MY_HTDOCSDIR}
+
+ for file in ${files}; do
+ webapp_serverowned "${MY_HTDOCSDIR}/${file}"
+ done
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+
+ webapp_src_install
+}