summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-02-03 17:48:23 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-02-03 17:48:23 +0000
commit47bbac31c0a3616002986ee461fce1d5f529d0e5 (patch)
tree991f62043fdb044319d31adb6ffc7fc328f33536 /www-apps/metadot/metadot-6.4.5.4.ebuild
parentwhitespace (diff)
downloadgentoo-2-47bbac31c0a3616002986ee461fce1d5f529d0e5.tar.gz
gentoo-2-47bbac31c0a3616002986ee461fce1d5f529d0e5.tar.bz2
gentoo-2-47bbac31c0a3616002986ee461fce1d5f529d0e5.zip
merge from webapps overlay wrt #208584
(Portage version: 2.1.4)
Diffstat (limited to 'www-apps/metadot/metadot-6.4.5.4.ebuild')
-rw-r--r--www-apps/metadot/metadot-6.4.5.4.ebuild15
1 files changed, 7 insertions, 8 deletions
diff --git a/www-apps/metadot/metadot-6.4.5.4.ebuild b/www-apps/metadot/metadot-6.4.5.4.ebuild
index 87ba59047783..d13ef4be2cab 100644
--- a/www-apps/metadot/metadot-6.4.5.4.ebuild
+++ b/www-apps/metadot/metadot-6.4.5.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/metadot/metadot-6.4.5.4.ebuild,v 1.7 2007/07/29 17:30:49 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/metadot/metadot-6.4.5.4.ebuild,v 1.8 2008/02/03 17:48:23 hollow Exp $
inherit webapp
MY_P="Metadot${PV}"
@@ -17,7 +17,6 @@ KEYWORDS="~x86 ~ppc"
DEPEND=""
RDEPEND="
>=dev-lang/perl-5.6
- =www-servers/apache-2*
=www-apache/mod_perl-2*
dev-perl/DBI
>=dev-perl/DBD-mysql-2.1027
@@ -57,16 +56,16 @@ src_install() {
webapp_src_preinst
dodoc CHANGELOG README
- cp -R [[:lower:]][[:lower:]]* ${D}/${MY_HTDOCSDIR}
+ cp -R [[:lower:]][[:lower:]]* "${D}"/${MY_HTDOCSDIR}
- cp ${FILESDIR}/${PN}.conf ${D}/${MY_HOSTROOTDIR}
+ cp "${FILESDIR}"/${PN}.conf "${D}"/${MY_HOSTROOTDIR}
sed -i "s|Apache::Registry|Modperl::Registry|" \
- ${D}/${MY_HOSTROOTDIR}/${PN}.conf
+ "${D}"/${MY_HOSTROOTDIR}/${PN}.conf
webapp_serverowned ${MY_HTDOCSDIR}
webapp_serverowned ${MY_HTDOCSDIR}/sitedata/public
- webapp_postinst_txt en ${FILESDIR}/postinstall-en-6.4_p3.txt
- webapp_hook_script ${FILESDIR}/reconfig-6.4_p3
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-6.4_p3.txt
+ webapp_hook_script "${FILESDIR}"/reconfig-6.4_p3
webapp_src_install
}