summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-07-13 04:41:55 +0000
committerTim Harder <radhermit@gentoo.org>2011-07-13 04:41:55 +0000
commite3ecf1ffbf023aa24ab6f1c05200e509dcf4e770 (patch)
tree28ae7a36ba4c2c76b60eb0d62cc5f5a5649b690a /www-apps/phpBB
parentAltering vim patch logic to deal with monolithic patches (which include runtime (diff)
downloadgentoo-2-e3ecf1ffbf023aa24ab6f1c05200e509dcf4e770.tar.gz
gentoo-2-e3ecf1ffbf023aa24ab6f1c05200e509dcf4e770.tar.bz2
gentoo-2-e3ecf1ffbf023aa24ab6f1c05200e509dcf4e770.zip
Version bump.
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'www-apps/phpBB')
-rw-r--r--www-apps/phpBB/ChangeLog7
-rw-r--r--www-apps/phpBB/phpBB-3.0.9.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/www-apps/phpBB/ChangeLog b/www-apps/phpBB/ChangeLog
index a42fe9cd6393..76101ff6f885 100644
--- a/www-apps/phpBB/ChangeLog
+++ b/www-apps/phpBB/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/phpBB
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/phpBB/ChangeLog,v 1.36 2011/02/10 00:50:36 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/phpBB/ChangeLog,v 1.37 2011/07/13 04:41:55 radhermit Exp $
+
+*phpBB-3.0.9 (13 Jul 2011)
+
+ 13 Jul 2011; Tim Harder <radhermit@gentoo.org> +phpBB-3.0.9.ebuild:
+ Version bump.
10 Feb 2011; Tim Harder <radhermit@gentoo.org> -phpBB-3.0.7_p1.ebuild:
Remove old.
diff --git a/www-apps/phpBB/phpBB-3.0.9.ebuild b/www-apps/phpBB/phpBB-3.0.9.ebuild
new file mode 100644
index 000000000000..26fa92b4aa23
--- /dev/null
+++ b/www-apps/phpBB/phpBB-3.0.9.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/phpBB/phpBB-3.0.9.ebuild,v 1.1 2011/07/13 04:41:55 radhermit Exp $
+
+EAPI=4
+
+inherit webapp depend.php
+
+DESCRIPTION="phpBB is an open-source bulletin board package"
+HOMEPAGE="http://www.phpbb.com/"
+SRC_URI="http://download.phpbb.com/pub/release/${PV:0:3}/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+need_httpd_cgi
+need_php_httpd
+
+S="${WORKDIR}"/${PN}3
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc docs/*
+ rm -rf docs
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/cache
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/images/avatars/upload
+ webapp_serverowned "${MY_HTDOCSDIR}"/store
+ webapp_serverowned "${MY_HTDOCSDIR}"/config.php
+ webapp_configfile "${MY_HTDOCSDIR}"/config.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}